1. Download our Official Android App: Forums for Android!

Support 4.1.2 camera focus

Discussion in 'Android Devices' started by unitypunk, Dec 19, 2013.

  1. unitypunk

    unitypunk Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    53
    Posts:
    292
    Joined:
    Dec 13, 2011

    Dec 13, 2011
    292
    37
    53
    Male
    i first noted it in snapchat,

    but i cant focus my camera, it seems stuck at 6-8 inches from target. tried changing modes, not sure what else to use, im usualy using hdr mode, full mpixel my old commando focused..
     

    Advertisement

  2. unitypunk

    unitypunk Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    53
    Posts:
    292
    Joined:
    Dec 13, 2011

    Dec 13, 2011
    292
    37
    53
    Male
    make that 6 or less... maybe stuck in macro mode...? but i dont see a macro option anywhere.
     
  3. rjglenn

    rjglenn Android Enthusiast
    Rank:
    None
    Points:
    113
    Posts:
    719
    Joined:
    Dec 17, 2010

    Dec 17, 2010
    719
    101
    113
    Firefighter, agrimechanic
    North Florida
    The 4.0.4 camera was bad, the 4.1.2 is worse. Pics look ok on the phone but are horrible on a computer screen. I'd like to try the google edition camera again, but last time it didn't go so well for me...
     
  4. unitypunk

    unitypunk Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    53
    Posts:
    292
    Joined:
    Dec 13, 2011

    Dec 13, 2011
    292
    37
    53
    Male
    after tapping on the camera rather hard, i got it to try to focus, and move a bit....

    verizon is sending me another replacement...

    certified like new my ass...

    i swear it says if its under manufacturer warranty, you're supposed to get a NEW replacement..

    pfft..

    you have 14 days to get a new replacement... ugh... lame.
     
  5. rjglenn

    rjglenn Android Enthusiast
    Rank:
    None
    Points:
    113
    Posts:
    719
    Joined:
    Dec 17, 2010

    Dec 17, 2010
    719
    101
    113
    Firefighter, agrimechanic
    North Florida
    Mines not on the original line it was purchased on so I deal with assurion. Consistently they have been sending brand new in the box with all the accessories.


    Edit: I just downloaded and installed the Google Edition camera. Everything works and it seems to have a little bit better image quality. I disabled the stock camera and gallery app and will run this one for a while and see how it goes.
     
  6. unitypunk

    unitypunk Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    53
    Posts:
    292
    Joined:
    Dec 13, 2011

    Dec 13, 2011
    292
    37
    53
    Male
    rj, is that the one pulled from kitkat/nexus? or the older jellybean one?
     
  7. rjglenn

    rjglenn Android Enthusiast
    Rank:
    None
    Points:
    113
    Posts:
    719
    Joined:
    Dec 17, 2010

    Dec 17, 2010
    719
    101
    113
    Firefighter, agrimechanic
    North Florida
    unitypunk likes this.
  8. Doctoror

    Doctoror Well-Known Member
    Rank:
    None
    Points:
    88
    Posts:
    224
    Joined:
    Nov 5, 2013

    Nov 5, 2013
    224
    105
    88
    Male
    Android developer since 2012
    Lviv, Ukraine
  9. rjglenn

    rjglenn Android Enthusiast
    Rank:
    None
    Points:
    113
    Posts:
    719
    Joined:
    Dec 17, 2010

    Dec 17, 2010
    719
    101
    113
    Firefighter, agrimechanic
    North Florida
    I downloaded it, thanks for that. Camera & camcorder work, panoramic & photosphere modes do not work, the camera force closes if you try to select them. There are probably some missing lib files that the KK camera needs to operate.

    How does it function for you?
     
  10. Doctoror

    Doctoror Well-Known Member
    Rank:
    None
    Points:
    88
    Posts:
    224
    Joined:
    Nov 5, 2013

    Nov 5, 2013
    224
    105
    88
    Male
    Android developer since 2012
    Lviv, Ukraine
    I actually haven't tested it for these features. Woops.
    I don't use Camera pretty much and never used these features anyway.
    And yes. Missing new libraries and no methods in current libraries.

    Sphere:
    Code (Text):
    1.  
    2. Caused by: java.lang.UnsatisfiedLinkError: Couldn't load lightcycle: findLibrary returned null
    3. at java.lang.Runtime.loadLibrary(Runtime.java:365)
    4. at java.lang.System.loadLibrary(System.java:535)
    5. at com.google.android.apps.lightcycle.panorama.LightCycleNative.<clinit>(LightCycleNative.java:60)
    6.  
    Pano:
    Code (Text):
    1.  
    2. java.lang.UnsatisfiedLinkError: Native method not found: com.android.camera.Mosaic.allocateMosaicMemory:(II)
    3. at com.android.camera.Mosaic.allocateMosaicMemory(Native Method)
    4.  
     
  11. Doctoror

    Doctoror Well-Known Member
    Rank:
    None
    Points:
    88
    Posts:
    224
    Joined:
    Nov 5, 2013

    Nov 5, 2013
    224
    105
    88
    Male
    Android developer since 2012
    Lviv, Ukraine
    Found Nexus Camera with working features (no photosphere though).
    Camera KitKat
     
  12. xmguy1

    xmguy1 Well-Known Member
    Rank:
    None
    Points:
    36
    Posts:
    179
    Joined:
    Sep 16, 2013

    Sep 16, 2013
    179
    8
    36
    Male
    McMinnville, TN
    I tried the GPE Camera from the link (JB) all works well. However it lacks HDR.
     

Share This Page

Loading...