1. Are you ready for the Galaxy S20? Here is everything we know so far!

4.1.2 WiFi not working

Discussion in 'Android Devices' started by rsfour, Dec 20, 2012.

  1. rsfour

    rsfour Member
    Thread Starter

    Woo so i am on 4.1.2 and boom issues galore. No wifi access at all. I can see networks but when you connect it sticks at obtaining IP then nothing. boo :(

    ideas?

    i have done a factory reset fyi.
     



    1. Download the Forums for Android™ app!


      Download

       
  2. rsfour

    rsfour Member
    Thread Starter

    Update, the wifi is now connecting after my THRID restore but is continually disconnecting.
     
  3. silentwitness

    silentwitness Android Expert

    are u running a custom ROM? If so which one. It could be an issue with the ROM.
     
  4. SUroot

    SUroot Extreme Android User

    If you're allowing google to restore your phone after a factory reset, afterwards go and forget all your wifi networks and see if its any better starting fresh.
     
  5. Terry51

    Terry51 Member

    Also, try changing your ip setting mode to static...settings / wifi /select wifi network, click on show advance options and set ip settings to static. That might help.
     
  6. rsfour

    rsfour Member
    Thread Starter

    After many hours of pain I managed to get 4.1.1 back on with a samsmobile firmware. Later that the phone was connecting to the network but was disconnecting and reconnecting constantly.

    Do you think I should try at OTA update?
     
  7. rsfour

    rsfour Member
    Thread Starter

    It's a 100% stock rom and kernel
     
  8. silentwitness

    silentwitness Android Expert

    as suggested by terry51 try setting a static ip and see it might solve ure issue. make sure its in the correct range of ure router and outside the dhcp range.
     
  9. rsfour

    rsfour Member
    Thread Starter

    We run two wireless networks in the office. One for us and one for any visitors. Both are totally separate separate and neither worked.
     
  10. HighSierra

    HighSierra Member

  11. rsfour

    rsfour Member
    Thread Starter

    No idea where the % appeared from in the url.
     
  12. smallclone

    smallclone Well-Known Member

    Am I reading this right?

    For my S3 to work with wifi I have to root the phone?
     
  13. SUroot

    SUroot Extreme Android User

    I haven't found a WiFi network I cannot connect to. I am rooted but I didn't have to do anything with Folders from other people's phones or permissions.

    If you have a specific wifi issue, it may be as well creating a new thread.
     
  14. zophini

    zophini Lurker

    This fix will work for any Samsung phone.
    I was having the same issue but someone on this site posted how to fix this issue.
    What you need to do it type in on the number pad *#0011#. You will get a different screen. At this point tap menu and click on wifi. You will see wifi power saver. Below that it will say 'on'. Change 'on' to 'off' by taping it. At that point just exit out by hitting the back button. I made this change a week ago Monday and wifi calling has worked great at work or any other wifi location.
    Two FYIs,
    1. The battery will drain much quicker.
    2. You have to redo the above steps every time you reboot or power th phone off/on.
    I do not have a problem redoing these steps after rebooting but the battery issue bothers me. Any ideas on how to fix that?
     
  15. snow_muncher

    snow_muncher Lurker

    Not a fix, but a work-round

    I use the drop down menu at the top of screen to turn wifi on an off as needed

    tbh you save loads more battery this way too

    ps

    what I find slightly annoying is that the number *#0011# can be entered as a contact, it doesn't dial the number (I turn my phone off alot)
     

Samsung Galaxy S3 Forum

The Samsung Galaxy S3 release date was May 2012. Features and Specs include a 4.8" inch screen, 8MP camera, 1GB RAM, Exynos 4412 Quad processor, and 2100mAh battery.

May 2012
Release Date
0
Reviews
Loading...

Share This Page

Loading...