1. Are you ready for the Galaxy S20? Here is everything we know so far!

4.2.1 update keeps failing

Discussion in 'Android Devices' started by onesicktexan, Dec 27, 2012.

  1. onesicktexan

    onesicktexan Member
    Thread Starter

    Hello, I purchased an Nexus 7 from Office Depot yesterday, its stock 4.1.2.

    I got a notification saying 4.2.1 is available. I downloaded, than clicked install. Device reboots and starts the install, than fails halfway and just freezes.

    When it reboots it just says system is up to date but it still shows 4.1.2.
    Only way I can get it to redownload again is by deleting the data under Google Services App. but even still it fails time after time.

    Any ideas?
     


  2. Digital Controller

    Digital Controller The Real Bass Creator

    Might want to try getting the update from Kies and installing it that way if the direct download from your device doesn't work.
     
  3. Teknologic

    Teknologic Android Expert

    I thought kies was something proprietary to Samsung? Anyway, don't stress too much about the update, it'll come back in a little while. In the meantime, search this forum for similar threads, one of the staff released an app that checks your system against update files. So if you run that before you update, you'll know if it'll fail and why.
    On the other hand, you could just go back to the store and tell them it crashes when it updates. You've got a reasonable chance to get a new one.
    Because honestly, a brand new untouched nexus 7 should update just fine.
     
    onesicktexan likes this.
  4. The_Superhoo

    The_Superhoo Android Enthusiast

    I have a Nexus 10 and I'm having the same issue as OP. I've tried factory resets, locking bootloader, unlocking bootloader, rooting, unrooting, MORE factory resets, clearing the cache, safe mode, nothing makes the update stick. Get the same error every time.

    Where's this app you mention? I cant find it.
     
  5. Teknologic

    Teknologic Android Expert

    The_Superhoo and onesicktexan like this.
  6. onesicktexan

    onesicktexan Member
    Thread Starter

    Great, Will try the app and see if I can find out whats wrong. If not than i'll try returning it, thank you!
     
  7. The_Superhoo

    The_Superhoo Android Enthusiast

    Thanks. It said I didnt have anything (that it could see) that should make the OTA fail... sigh wth...
     
  8. twelvebears

    twelvebears Lurker

    I've had exactly the same issue.

    Brand new, stock, non-rooted Nexus 7 32Gb from Carphone Warehouse which just seems to fail every time I try to run the Android update, so I'm stuck on 4.1.2

    I'm assuming that when it's doing it's update thing, it should have the image of the upright robot with spinning green geometric shape by it's access hatch the whole way through, and that prone robot with red exclamation mark means it's failed?
     
  9. Teknologic

    Teknologic Android Expert

    Hmm, I don't know if the app checks for this, but you might need stock recovery. Only speculating here.


    Correct, try the app above to see what's wrong.
     
Loading...
Similar Threads - update keeps failing
  1. LivnLyfe
    Replies:
    0
    Views:
    43
  2. chiques
    Replies:
    0
    Views:
    80
  3. ironass
    Replies:
    1
    Views:
    87
  4. Guitarist
    Replies:
    0
    Views:
    156
  5. ShadowX5452
    Replies:
    1
    Views:
    418
  6. ironass
    Replies:
    3
    Views:
    235
  7. startac4
    Replies:
    2
    Views:
    248
  8. haplo888
    Replies:
    2
    Views:
    248
  9. james_uk
    Replies:
    0
    Views:
    224
  10. G0spelGirl
    Replies:
    5
    Views:
    2,485

Share This Page

Loading...