1. Are you ready for the Galaxy S20? Here is everything we know so far!

4.4.2 WiFi and BT issues

Discussion in 'Android Devices' started by andruoid, Apr 2, 2014.

  1. andruoid

    andruoid Android Expert
    Thread Starter

    When I bought my N4 it was only a very brief few days with 4.3 JellyBean. So I've been on 4.4 pretty much the entire time. That was back in October sometime. Even though I have reported that WiFi and BT have been ok, they do disconnect randomly, enough that a rebooted and sometimes a reset is in order. My time with the phone in terms of toying with it has been limited for over a couple of months so I lived with the above issues.

    I've been rooted a while but decided to flash the stock 4.3 and unroot. It's been 2 days and zero issues with WiFi discos. The N4 was re-paired with my cars BT so we'll see how long it goes until the phone "forgets" to connect.

    Has anyone had similar issues?
     



    1. Download the Forums for Android™ app!


      Download

       
  2. John Bean

    John Bean Happy Wanderer

    It may not be 4.4 that caused the problem, it's just as likely that something you did while rooted was to blame.

    I have no issues at all with the current Android build on the Nexus 4, less in fact than I had with earlier versions. If I were you I'd have re-flashed the standard 4.4 and unrooted to test rather than going back to 4.3; my bet would be that this would also have fixed whatever was causing the problem.
     
  3. SiempreTuna

    SiempreTuna Android Expert

    :ditto:

    No issues with WiFi or BT on 4.4. The one time I thought I had a WiFi connectivity issues it turned out to be a country-wide issue with my ISP.
     
  4. andruoid

    andruoid Android Expert
    Thread Starter

    Before rooting the N4 had the same issues, even with 4.4.2. Even switched off WiFi frequency from Auto to 2.4GHz or 5GHz on the phone itself. Also tried different router, need a new router anyway ;) Maybe its a hardware issue but so far, 4.3 is solid and maybe the upcoming 4.4.3 might fix it.
     
  5. andruoid

    andruoid Android Expert
    Thread Starter

    Sorry for wasting your time guys, I think i found the problem as mentioned here; http://androidforums.com/nexus-4/835386-orange-bars.html

    Not knowing what the orange bars actually mean, I assumed the colour meant I was connected. No. So I upgraded back to 4.4.2 and powered off, took out the SIM, re-inserted SIM and powered back on; White bars! 72Mbps connection (as oppossed to 65Mbps) and no discos yet. Feel like a noob but a happy one! :egg:
     
    John Bean likes this.
  6. Deleted User

    Deleted User Guest

    Never rooted my phone, and I can never have wifi on when I connect to my BT headset in my helmet.
    I understood it to be a 4.4 issue, it was absolutely fine before the latest upgrade
     
  7. John Bean

    John Bean Happy Wanderer

    No apologies needed, and thanks for being honest about a mistake anybody could have made. Your reply will also be helpful to anyone else who isn't aware of the "orange bars" thing :)
     
    codesplice, andruoid and D-U-R-X like this.

Nexus 4 Forum

The Nexus 4 release date was November 2012. Features and Specs include a 4.7" inch screen, 8MP camera, 2GB RAM, Snapdragon S4 Pro processor, and 2100mAh battery.

November 2012
Release Date
0
Reviews
Loading...

Share This Page

Loading...