1. Are you ready for the Galaxy S20? Here is everything we know so far!

4g speed tweak + potential data problem fixed

Discussion in 'Android Devices' started by ChiweN, May 3, 2012.

  1. ChiweN

    ChiweN Android Expert
    Thread Starter

    Hi guys. Many of us have been having issues with 4g not working. Trying to fix the problem, I have been tweaking build.prop and stumbled on something interesting.

    First thing I did was remove the 3g turbocharger entries at the bottom of build.prop. I don't know how they got there, I never ran it, I only ran v6 supercharger (they are seperate scripts) after doing this, my 4g appears to be fixed.

    Now.. there's two lines in build.prop - ro.ril.hsxpa=1 and ro.ril.gprsclass=10. Using a text editor (I use root explorer to navigate to build.prop, long press it, and choose text editor) I changed ro.ril.hsxpa to 3 and ro.ril.gprsclass to 12 as shown below..


    It nearly doubled my 4g speed. I tested after the changes, and reverted them back to 1 and 10 and tested again. I can verify a definite speed increase. Screen below..


    4+mbps scores were with the new values. Lower scores are with the original values of 1 and 10. As you can see I alternated between the two a couple times for reliable testing.

    Also.. you must be in R/W to edit build.prop or it will not save your changes.

    Edit: I forget who's phone was dumped to package the pre-rooted tar file, but my theory is he may have ran 3g turbocharger, and it got carried over to our phone when we Odin'd the pre root tar. There are other things I've found in the system files that carried over from the original phone the tar came from (nfsshift.apk and Tetris.apk). I forget the exact location but ill post it later for you all to find and delete.

  2. rootmyphone

    rootmyphone Newbie

    How to remove the 3g turbocharge thing ?
  3. gitman

    gitman Newbie

    in your screenshot, its not real clear which options are the 3G turbocharger options?


    here's the build.prop that comes in the pre-root image:

    Code (Text):
    2. # begin build properties
    3. # autogenerated by buildinfo.sh
    4. ro.build.id=GINGERBREAD
    5. ro.build.display.id=GINGERBREAD.EL03
    6. ro.build.version.incremental=EL03
    7. ro.build.version.sdk=10
    8. ro.build.version.codename=REL
    9. ro.build.version.release=2.3.6
    10. ro.build.date=Sat Dec 10 18:39:47 KST 2011
    11. ro.build.date.utc=1323509987
    12. ro.build.type=user
    13. ro.build.user=se.infra
    14. ro.build.host=SEP-51
    15. ro.build.tags=release-keys
    16. ro.product.model=SCH-R920
    17. ro.product.brand=samsung
    18. ro.product.name=SCH-R920
    19. ro.product.device=SCH-R920
    20. ro.product.board=SCH-R920
    21. ro.product.cpu.abi=armeabi-v7a
    22. ro.product.cpu.abi2=armeabi
    23. ro.product.manufacturer=samsung
    24. ro.product.locale.language=en
    25. ro.product.locale.region=US
    26. ro.wifi.channels=
    27. ro.board.platform=s5pc110
    28. # ro.build.product is obsolete; use ro.product.device
    29. ro.build.product=SCH-R920
    30. # Do not try to parse ro.build.description or .fingerprint
    31. ro.build.description=SCH-R920-user 2.3.6 GINGERBREAD EL03 release-keys
    32. ro.build.fingerprint=samsung/SCH-R920/SCH-R920:2.3.6/GINGERBREAD/EL03:user/release-keys
    33. # Samsung Specific Properties
    34. ro.build.PDA=SCH-R920.EL03
    35. ro.build.hidden_ver=
    36. ro.build.changelist=782871
    37. ro.flash.resolution=720
    38. # end build properties
    39. #
    40. # system.prop for smdkc110
    41. #
    43. rild.libpath=/system/lib/libsec-ril40.so
    44. rild.libargs=-d /dev/ttyS0
    45. ro.sf.lcd_density=160
    46. dalvik.vm.heapsize=64m
    48. # Indicate carrier OTA SP number schema
    49. # refer to frameworks/base/telephony/java/com/android/
    50. # internal/telephony/cdma/CDMAPhone.java for the schema:
    51. ro.cdma.otaspnumschema=SELC,3,00,07,80,87,88,99
    52. ro.opengles.version=131072
    54. # Samsung USB default mode
    55. persist.service.usb.setting=2
    57. #
    59. #
    60. ro.opengles.version=131072
    61. ro.config.ringtone=S_Over_the_horizon.ogg
    62. ro.config.notification_sound=01_Sherbet.ogg
    63. ro.config.alarm_alert=Good_Morning.ogg
    64. ro.url.legal=http://www.google.com/intl/%s/mobile/android/basic/phone-legal.html
    65. ro.url.legal.android_privacy=http://www.google.com/intl/%s/mobile/android/basic/privacy.html
    66. ro.com.google.locationfeatures=1
    67. ro.setupwizard.mode=DISABLED
    68. ro.com.google.gmsversion=2.3_r8
    69. ro.carrier=MPCS
    70. ro.com.google.clientidbase=android-samsung
    71. ro.com.google.clientidbase.yt=android-samsung
    72. ro.com.google.clientidbase.am=android-samsung
    73. ro.com.google.clientidbase.gmm=android-samsung
    74. ro.com.google.clientidbase.ms=android-metropcs-us
    75. ro.csc.sales_code=MTR
    76. wifi.interface=eth0
    77. wifi.supplicant_scan_interval=15
    78. ro.error.receiver.default=com.samsung.receiver.error
    79. keyguard.no_require_sim=true
    80. ro.com.android.dateformat=MM-dd-yyyy
    81. ro.com.android.dataroaming=false
    82. ro.ril.hsxpa=1
    83. ro.ril.gprsclass=10
    84. ro.config.notification_sound=OnTheHunt.ogg
    85. ro.config.alarm_alert=Alarm_Classic.ogg
    86. media.stagefright.enable-player=false
    87. media.stagefright.enable-meta=false
    88. media.stagefright.enable-scan=false
    89. media.stagefright.enable-http=true
    90. media.stagefright.enable-rtsp=false
    91. dalvik.vm.dexopt-flags=m=y
    92. net.bt.name=Android
    93. dalvik.vm.stack-trace-file=/data/anr/traces.txt
    no mention of /(V6 Super|3G Turbo)charger/

    edit 2:

    ro.ril.hsxpa=1 and ro.ril.gprsclass are both GSM-specific settings, i can't see how it would have an effect on cdma devices

    edit 3:

    sorry man, didn't intend to take a dump on your thread... you seem pretty excited about it
    blaqueknight likes this.
  4. Tokenpoke

    Tokenpoke Android Expert

    I confirm that there was no 3g charger attached to my build prop

    The other edits DO work. I went from 509kbps to 1.1mbps
    ChiweN likes this.
  5. ChiweN

    ChiweN Android Expert
    Thread Starter

    I'm not excited lol, passing on info, that's what I do. Now that you posted the original (thanks) I see that v6 supercharger did indeed install the 3g turbocharger script.

    I didn't post a screen of the 3g script, I had deleted it already. You have to look for it, it resides at the very end of build.prop, easy to spot if you read the comments, about 12 lines. It won't be there if you did not run v6 apparently.

    I don't know why changing the values made an impact, but they did. I had read about this tweak a few times in various places.

    I did the tests, many times. The results were obvious, and shown in the screen shot. I don't believe it is coincidence, the results were solid each test.

    Don't worry about dumping on me lol, if at any time I'm wrong, I'm wrong. I have been tons of times. Just learning :-D

    Btw, I don't think I'm wrong on this one.
  6. ChiweN

    ChiweN Android Expert
    Thread Starter

    Thanks for giving it a try and confirming it does work mike :-D

    Now. With the people that have their 4g hang on them. I wonder how many used the v6 script, which installs 3g turbocharger to the build.prop. it creates a conflict. After deleting the turbocharger entries it completely fixed my 4g issues. No more hangups.


    This is what the 3g turbocharger entries look like in the build.prop file. Everyone that has 4g issues.. delete everything in between:

    # 3g turbocharger enhancement!


    # end of v6 supercharged entries.

    It WILL fix your 4g issues.

    Also, when I get home I'm going to upload my build.prop file, so anyone that doesn't understand how to do these things, or are nervous about it can just overwrite theirs with mine.
  7. Tokenpoke

    Tokenpoke Android Expert

    I actually did run the v6 script but had no 3g stuff in my prop.... Weird.
    I also did a factory reset (after removing all metro stuff except for visual voicemail) and got the enhancement fota but it failed and gave a message telling me to have metro take a look at my phone.
    Tether works now though.

    I did the reset because my status showed the network as evdo when the 4g icon was active. Now it stays on lte
  8. ChiweN

    ChiweN Android Expert
    Thread Starter

    Hmm.. I wonder why the 3g turbocharger was on my phone. I never ran it. Odd.

    Yeah, as you know my phone does that too. Do you use anycut to turn 4g off and on? Or have you since the factory reset? If I do the volte trick, my lte comes back. But, if I turn 4g off, when I turn it back on it sticks on evdo, with the 4g icon showing.
  9. Tokenpoke

    Tokenpoke Android Expert

    No i haven't used any shortcuts...

    I was also mistaken... My status just showed network as 1x-rtt with the 4g icon showing... Tether still works afaik but i will test again in a couple hours when i get back home.
  10. Goochy

    Goochy Newbie

    Ok, I changed the values, rebooted, checked the values and they are now default. Also, I have run v6 and I dont have the 3g turbocharger in my build prop.

    Edit 1: deleted the .bak created and values stayed after reboot. speeds varied slightly, not doubling. Also I still have the 4g hang. (mind you, without the 3g TC).
  11. Goochy

    Goochy Newbie

    Also, im having trouble noticing a difference in performance with the v6. I have it running (su and run on boot). my apps keep opening on their own. Not 100% what the desired effect of v6, but I assume it was to control the opening and closing of apps on their own.
  12. pandibear

    pandibear Newbie

    Can you tell me what you did to get your tethering working? I seem to get hangs on connecting or it just doesnt connect on the computer. the phone would still work but when I try to use the computer to connect to sites, just hangs and doesnt connect at all.
  13. gitman

    gitman Newbie

    its more about changing the level of aggressiveness at which android closes idle applications to free up memory for other applications. you can also force android to always keep the launcher in memory.

    it is not like the auto-killers and task managers that are out there
  14. Tokenpoke

    Tokenpoke Android Expert

    Rooted and removed all metro stuff.

    Factory reset and failed the fota update.

    Tether was working last i checked but i didn't test again last night.
  15. Goochy

    Goochy Newbie

    Hmm. I wish I could get android to leave my apps alone and not touch them unless I do. I hate opening atk and seeing a bunch of bullshit running for no aparrant reason.
  16. AlexMiami

    AlexMiami Lurker

    That drives me absolutely crazy too! I can have like 15 things open for no reason and eating up my memory! :mad:
  17. ChiweN

    ChiweN Android Expert
    Thread Starter

    Shouldn't be that bad with v6 script installed. Amp it up a bit, set it a bit more aggressive.
  18. gitman

    gitman Newbie

    blame the apps that start themselves at boot and don't give you any kind of "exit" option. don't blame the OS.
  19. Tokenpoke

    Tokenpoke Android Expert

    He has a point.
    Also anything that checks for
    updates and doesn't immediately shut Down after (fb)
  20. skinlab

    skinlab Well-Known Member

    I ran V6 myself and also had no 3g turbocharger entries. I did change the settings from the op and do notice some improvement.
    And yes, it drives me crazy also with all the unnecessary shit running in the background.
  21. Havocx23

    Havocx23 Newbie

    I've tried several different root explorers (ES file explorer, SManager, File manager) and all have been granted su permissions, and i have the option checked to mount system files as writable but it wont save any of my changes. what can I do about this
  22. Tokenpoke

    Tokenpoke Android Expert

    Buy "root explorer"
    Works fine for me
  23. dadcup

    dadcup Android Expert

    how i install v6
  24. jemini1988

    jemini1988 Newbie

    How do i get into the build.prop?
  25. Loveofandroid

    Loveofandroid Newbie

    How can I get my "4G" icon back instead of having the "EV" icon ???? PLEASE HELP

Samsung Galaxy Attain 4G Forum

The Samsung Galaxy Attain 4G release date was February 2012. Features and Specs include a 3.5" inch screen, 3MP camera, 512GB RAM, processor, and 1650mAh battery.

February 2012
Release Date

Share This Page