1. Are you ready for the Galaxy S20? Here is everything we know so far!

7 Pro

Discussion in 'Computers' started by zuben el genub, Jul 15, 2013.

  1. zuben el genub

    zuben el genub Extreme Android User
    Thread Starter

    I posted this in the Nexus forum - no one has bothered to reply, so I'm reposting here.

    I have an ad problem and want to back up before doing ANYTHING.

    I just got a new laptop - windows 7 pro.

    If I plug in the Nexus 4, I get all the files regardless if usb debugging is on or not. I can transfer some either way.

    Try to back up all of it and all I get is "calculating time" nonsense and the computer just sits there and chews. I have no idea if it's doing anything or not. Somehow I don't think it should chew on a folder for 10 minutes and just say "Calculating"

    I got everything copied on XP, dammit. In fact, the backup folder from XP in March is in the Documents file on 7.

    The phone is rooted, but I don't have the Nexus tool kit on this laptop. Would it help?


    __________________
    Thanks
     

    Advertisement

  2. 7Priest7

    7Priest7 Guest

    Without some very specific computer setup info, the best I can give you is speculation.

    Does the laptop have power options? If so, enable high performance mode.

    Enabling High Performance mode may help the issue as power saving steps can include, frequent sleeping, low power usb, turning hdd off, and other things that can cause annoyance in general.

    How large is the folder you are attempting to copy?
    You should attempt to use ms-dos to copy the folder. (copy e:\FOLDER c:\Users\YOURUserName\Document\)<-- Just a crude example to help you.
    Ms-Dos does less silly end user nonsense when moving files.

    I am confident using dos will solve your issue, however if you need further help try to give more specific info in your next post.
     
  3. zuben el genub

    zuben el genub Extreme Android User
    Thread Starter

    I haven't got power saving options enabled. It's an HP pavilion - says it has a Centrino 2 processor, has at leat 4G of ram, and is running Pro. The actual laptop is a refurb and there is no HP crap on it - just an OEM install of Pro. I have XP software I need. I've also got most of the extra crap turned off.

    The old Dell 620 running XP home took forever, but it showed you it was copying with that bar. It might say it needed 4 hours, but as long as the bar moved, I could wait.
    This damn thing just says calculating and sits there. I prefer the moving bar with an estimate of the time.

    I'm also puzzled as why I can get to all files without USB debugging turned on. On XP, all you could get was media unless you enabled USB debugging.
     
  4. 7Priest7

    7Priest7 Guest

    Bloatware is never fun, glad you don't have to go through the headache of uninstalling any.

    Windows 7 takes too long to estimate transfers, it sucks but it is how it is.

    Android has usb mass storage device emulation for any phone with internal/external storage, it shouldn't have ever needed usb debugging(perhaps you had bad drivers).

    I personally cannot assist you much.
    I can suggest the basic I.T. debugging steps but without VNC or physical access that is all I can do.

    So try the following,
    1. Try a new usb cable/usb host controller, Perhaps some of your hardware is faulty.
    2. If you are using a SD Card in your phone try it in your computer directly.
    ^ SD Cards are not perfect and they do get faulty after awhile.
    3. Try doing the same transfer on another computer, this would help you determine if the error is your computer or perhaps your phone.
    4. If you determine it as the computer, try to reinstall the applicable drivers.
    5. Ensure that you have antivirus/spybot and there is no malware causing your computer issues.
    6. If all of the above fails, ask a computer nerd friend, if you have any to diagnose it for you.(Just to be clear I meant if you have any nerd friends, not implying a lack of friends)

    Good luck.
     
  5. zuben el genub

    zuben el genub Extreme Android User
    Thread Starter

    7 pulled the XP crap of "installing driver" Does it really have a driver for the Nexus 4, or do I still have to download it? I think I had to get a driver for the Canon Pixma i6000. Windows told me it couldn't find the driver. XP would just go install an unknown as a Human Interface Device right or wrong.

    When XP installed something that wasn't right, you had to go delete the hardware from the device manager and start over - installing from CD before even plugging usb in. Do you need to do the same in 7?
     
  6. 7Priest7

    7Priest7 Guest

    Each version of Windows has more included drivers than the previous version of Windows.

    Due to user error/oversight the good working drivers that come with windows can get replaced with faulty drivers.

    For example if you installed HTC Sync or Android Developer Kit, The drivers those packages may have installed could cause you issues.
     
  7. mikedt

    mikedt 你好

    Windows 7 taking too long estimating the time to empty the recycle bin/trash. It's shouldn't even need to do that, it's deleting, it's not moving or copying. Should be almost instant. It sucks but that's how it is.
     
  8. 7Priest7

    7Priest7 Guest

    Me and the OP were referring to file transfers, not file deletions.
    Idk where you got the recycle bin idea from.
     
  9. mikedt

    mikedt 你好

    It seems to be something that Win 7 likes to do, waiting and "calculating time", whether it's deleting or transferring files. Win 8 does it as well I've found. XP doesn't do it, don't know about Vista, and neither do Mac OS or Linux Mint. They just get on with the job.

    Microsoft must know about it, so either they don't care or they can't fix it, that's what I'm thinking..
    INABIAF ... It's Not A Bug, It's A Feature!
     
  10. zuben el genub

    zuben el genub Extreme Android User
    Thread Starter

    I still have to get something to back up the damn phone. I'm not sure what 7 will think. I turned off all MS security, opted out of most of the other services and installed the security system of my choice.

    I have virtual XP on the laptop for an Adobe Illustrator problem - wonder if using that mode would work. Anyone know?
     
  11. Joelgp83

    Joelgp83 Android Enthusiast

    I second Mikedt's suggestion of trying a different cable or USB port, or both. Win7 should NOT be doing this on a functioning phone.

    And yes, it is ALWAYS standard procedure to install a USB device's drivers before ever plugging the device in. This is done so that they will override whatever's in the Windows Driver Library.

    Best to proceed by going to Control Panel > Programs and Features and removing any entries for Android drivers or the Nexus 4, then going to Device Manager and removing anything that looks related to the nexus 4. This may be difficult, as Device Manager will tend to hide those devices until you plug the USB device in question back in.

    Finally, download the Android SDK Tools installer and run it. Yes, that is a direct link to the Windows version; here's the download page itself.

    After installation, run the "SDK Manager" and let it look for the latest stuff. Somewhere towards the bottom of the list (I think its in the last group of selections) there is the option to download the "Google Android USB Driver", or words to that effect. That might be the latest reference driver for the Nexus, but it's just a guess.
     
    mikedt likes this.
  12. zuben el genub

    zuben el genub Extreme Android User
    Thread Starter

    So it's still the same as XP. 98SE didn't do that. Anything unknown in XP is an HID.

    Thanks. I've had to do that before with a Canon Scanner on XP. Think one of the phones, too. I wasn't sure this time since I tried to install an older Canon printer and 7 said it didn't have the drivers.
     
  13. Joelgp83

    Joelgp83 Android Enthusiast

    Depends. Are you using Virtualbox to virtualize XP on Win 7? If so, you'll STILL need the host OS to detect the phone properly first, in order to tell virtualbox to create the proper USB filter.
     
Loading...
Similar Threads - Pro
  1. Davdi
    Replies:
    2
    Views:
    107
  2. Android News
    Replies:
    0
    Views:
    64
  3. Android News
    Replies:
    0
    Views:
    56
  4. Android News
    Replies:
    0
    Views:
    57
  5. Android News
    Replies:
    0
    Views:
    60
  6. Android News
    Replies:
    0
    Views:
    60
  7. Android News
    Replies:
    0
    Views:
    56
  8. Android News
    Replies:
    0
    Views:
    41
  9. Android News
    Replies:
    0
    Views:
    3
  10. Android News
    Replies:
    0
    Views:
    4

Share This Page

Loading...