1. Download our Official Android App: Forums for Android!

A VERY strange SD card problem

Discussion in 'Android Lounge' started by ghostvet, Aug 29, 2011.

  1. ghostvet

    ghostvet Lurker
    Thread Starter
    Rank:
    None
    Points:
    6
    Posts:
    7
    Joined:
    Aug 29, 2011

    Aug 29, 2011
    7
    3
    6
    Hello all...

    This is very difficult to articulate, but I will try my best....

    Currently, my MyTouch 4G (Android 2.2) is not playing well with my SD card. Astro can see all of the card, and access all the files (at least all the ones I tried).

    However, most (not all) of the apps installed on the SD card are not being recognized by the phone- showing only the generic icon and a error message saying "The linked program is no longer installed on your phone." Some apps on the SD card are recognized and run with no problem.

    Also, the SD card will not mount when connected to my Mac or my PC (which it usually does with no problem) via USB.

    If I take my SD card out and put it in my daughter's phone (same model), it mounts just fine via USB.

    Attempting to unmount the SD card via the Settings>SD & Phone Storage will not work- it just hangs. I have to shut it down and then take out the card.
    Attempting to install any apps or updates from Market when the SD is mounted will not work- it just hangs. If I do not have the SD card in- updates and installations work just fine.

    Putting another SD card in the phone, the SD card is seen by Astro and mounts to the Mac via USB just fine.

    So, my SD card acts fine in another phone, but not in my phone. Another SD works fine in my phone.

    Multiple restarts of computers or phones does not fix anything.

    This problem appeared last week, but then disappeared while I was trying to diagnose and fix it, so I naturally thought what I did worked. Apparently not since I try the same things to fix it now and they are not effective this time.

    Then I got the card working again yesterday- I do NOT know how... I thought maybe is was because I deleted the .trashes folder. But then it stopped working again today.

    However, now I notice the /asec folder on the phone is empty. Assumably, it was empty before when the card was not acting right, but when the card is working right, the /asec folder is NOT empty- it has all the .apk s in there like they are supposed to be.

    I think it might be some invisible temp file or something... Anyone have any ideas?

    I have seen this problem being discussed far and wide, with no real solutions that I have been able to duplicate. However, nobody else has detailed as much diagnostic work (multiple cards, multiple phones, multiple computers/OSes, asec folder, etc) so maybe this one might be easier for someone to nail down.

    Oh, and the smdl2tmp1 file is not the issue- that has been deleted already.
     

    Advertisement

  2. dan330

    dan330 Android Expert
    Rank:
     #29
    Points:
    923
    Posts:
    11,937
    Joined:
    Jan 22, 2010

    Jan 22, 2010
    11,937
    3,532
    923
    are you rooted?
    are you using a custom ROM? what other custom mods have you installed to your phone?
    are you using a partitioned SD card to move apps to your SDcard?
     
  3. 0range

    0range Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Aug 29, 2011

    Aug 29, 2011
    1
    0
    5
    Chartered Accountant (Student)
    Pakistan
    upgrade ure droid version.
     
  4. !on

    !on Android Expert
    Rank:
    None
    Points:
    93
    Posts:
    824
    Joined:
    Aug 14, 2011

    Aug 14, 2011
    824
    120
    93
    Male
    UK
    I would delete everything on the card except music pictures & video (your media files). Then I would factory reset the phone & re-download or reinstall apps.
     
  5. ghostvet

    ghostvet Lurker
    Thread Starter
    Rank:
    None
    Points:
    6
    Posts:
    7
    Joined:
    Aug 29, 2011

    Aug 29, 2011
    7
    3
    6


    Sorry... should have mentioned that.. non-rooted- T-Mobile 4G Android 2.2, single partition 8GB SanDisk Micro SD Card (I do not know how to check what class it is)

    Have not yet received the OTA update (but I am anxiously awaiting it)
     
  6. ghostvet

    ghostvet Lurker
    Thread Starter
    Rank:
    None
    Points:
    6
    Posts:
    7
    Joined:
    Aug 29, 2011

    Aug 29, 2011
    7
    3
    6
    OK... I had working again- sort of...

    Here is what I did- but I do not know if this is related to a fix, or coincidence...

    I put my SD card in my daughter's 4g and connected to my Mac via USB, set it as a Disk Drive and it mounted on the Mac just fine.

    Using an app called FileBuddy on the Mac (which allows incredible access to many features) I located the invisible .trashes directory and the .spotlight-v100 directory, along with the .DS_Store file and deleted them all. These invisible directories/files are created again when you mount a drive on a Mac, so I knew they were safe to delete.

    I ejected the SD card and returned it to my phone and rebooted. Everything appeared normal again- and the /asec folder is populated again.

    I mounted as a disk drive, and it mounted just fine on the Mac. I ejected it and and set the phone back to Charge Only- it did not recover!

    Now it is hosed again!

    Oh, and as a side- During the times when they are not playing well, Astro has been able to access the SD card, as well as the stock music player, the camera and video cameras (they saved pictures and video to the card), other apps like APP2SD could not see the card.

    So anyway, I repeated the process again-

    No success this time...
     
  7. ghostvet

    ghostvet Lurker
    Thread Starter
    Rank:
    None
    Points:
    6
    Posts:
    7
    Joined:
    Aug 29, 2011

    Aug 29, 2011
    7
    3
    6
    It sure would be nice if there was a set of decent SD card tools for the Android...
     

Share This Page

Loading...