1. Are you ready for the Galaxy S20? Here is everything we know so far!

A2SD confusion....

Discussion in 'Android Devices' started by RCope48, Dec 10, 2011.

  1. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!

    the only reason why i suggested it as well is that in the a2sd check, i believe it showed no sym link flags attached to the apps.....something went wrong. and it never hurts really to do the a2sd reinstall command. plus like mizzou said, it is good to know those commands. hopefully it helped.
     

    Advertisement

    dustwun77 likes this.
  2. dustwun77

    dustwun77 Endeavor to Persevere :)

    I guess I am just totally confused, as well.

    His original post showed that there was something using the a2sd partition. I have seen that, and seen it grow when I dl'd big apps. That is really the only indication I know of to tell me it works, other than the fact that the phone memory isn't full.

    When I did the a2sd check command, it showed that private apps were linked to sd card? No real explanation of what else we should be looking for.
    :thinking:
     
  3. akazabam

    akazabam Android Expert

    Run the following from the terminal emulator:

    su
    a2sd check > /sdcard/a2sd.out

    On your sdcard, you will have a file named a2sd.out. Copy that file from your sdcard to your computer and upload it here. I can tell you from that output exactly what the a2sd script thinks. If you want to go the extra mile, run this command:

    su
    ls -l -d /data/app

    and put the output here. That'll be a dead giveaway if it worked or not. I can't remember if busybox will like that exact syntax or not. I can't check at the moment because my phone is currently sitting in a bowl of rice since I dropped water all over it today...


    Anyway, how've you guys been? Just thought I'd check in and try to help in a random thread. Unfortunately, I haven't kept up on android much recently, but I can still answer a2sd questions I guess...
     
    9to5cynic, Granite1, argedion and 3 others like this.
  4. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!

    AKAZABAM is in the house. you have been sorely missed my friend. good to see that you are alive and well. please feel free to pop in at anytime. i always look forward to reading your posts.

    and that sucks about your phone. hope that goes well for you.
     
  5. dustwun77

    dustwun77 Endeavor to Persevere :)

    Howdy! I am trying to follow your directions, running into some snags.

    I ran the first command and got the a2sd.out file, can't upload it here because .out not an accepted extension. I renamed it to .txt, hope it still works for you.

    It looks to me like the second command is waiting for me to give it some sort of permission that I do not Know how to do.

    Let me know what else you would like me to try.

    Thanks.
     

    Attached Files:

  6. RCope48

    RCope48 Well-Known Member
    Thread Starter

    Ive been messing around with this too, I did the reinstall, didnt seem to change anything, I also downloaded a few smaller programs, and when I use this little program called SD Move, all those programs showed up as being on the phone, and I was given the option to move them to SD? I thought everything went to SD if A2sd was installed? Still confused...I'll keep following along....:)
     
  7. akazabam

    akazabam Android Expert

    Thanks :). I'll try to pop in a little more often. I haven't been keeping up on as much as I used to, so others are probably of more help than me. My phone is fine, btw. It booted up this morning just fine, and everything works. I guess it eventually happens to everyone.

    Sorry, my fault. .txt is fine. As for the second command, that is exactly what I expected to see. /system/sd/ is the mount point for the ext3 partition on your sdcard, and /system/sd/app in the directory that contains all your apps that the normal app location (/data/app) is pointing to via a symlink. If none of that made sense, I think I've probably done a better job explaining it in other posts :)

    As for the output from a2sd check, I'll post each applicable line here and explain what it means:

    [✔] Programs run from SD card
    To run from internal storage, type a2sd remove

    This one is pretty obvious. It means a2sd worked, and apps are now on the sdcard ext3 partition, as confirmed by that second command you ran.


    [✔] Private Programs run from SD card
    To run from internal storage, type a2sd remove

    Same as the above, but with /data/app-private being symlinked to /system/sd/app-private. It means it worked.


    [✔] Dalvik runs from SD card
    To run from internal storage, type a2sd nocache
    To run from /cache partition, type a2sd cachepart

    This means dalvik cache is now on the sdcard ext3 partition, as well. If you run a2sd nocache, it will undo it, entirely for dalvik cache. Personally, I prefer to run a2sd cachepart. This means that dalvik cache will move back to internal storage, but in the /cache partition, which is mostly only used as a temporary holding place for downloaded apps (and a few other things). It's basically wasted spaced. Dalvik cache is normally kept on the /data partition, which will take away from your usable space. If you move it to /cache, you get the benefits of freed up space, but it runs a tad faster since it's on internal storage. That's just my opinion.


    Swap - [ ] Partition not present or no swap support.
    [✔] Swap does not start.

    You can ignore this. You don't need a swap partition. swap is used in a traditional system as overflow for when you run out of RAM, basically. That's a simplified explanation, but you don't need it on a phone, really.



    As for some of the other output, here is a quick explanation of what I think you'll find important to know:

    EXT Partition - [✔] Mounted
    Mount Point - [ ] /system/sd
    Partition Type - [✔] EXT3

    That first part means the ext3 partition (identified as ext3 filesystem type in the first part, there) is indeed mounted, and the second part means it is mounted at /system/sd. That means if you were to use a file browser or the terminal emulator and browse to the /system/sd directory, it would look like part of the normal file system, but you'd actually be looking at files on the sdcard. That is where the app directory has been created, and symlinked to. You saw that in that second command you ran.

    On a quick side note, I think this output confuses a lot of people:

    [ ] No Apps2SD Flag File not found.

    That is a really poorly worded statement. It should look more like this:

    "No Apps2SD Flag File" not found.

    A flag file is a file that exists solely to tell some program or another that something is in a particular state or that it should behave in a certain way. In this case, this flag file would exist if you were to use a2sd to move your apps back to internal storage. If you did, this flag file would be created. It's been a while since I looked into some of the a2sd scripts, but if I remember correctly the flag files basically exist in order to tell the a2sd startup scripts (in /system/etc/init.d) whether or not it should create the necessary symlinks at startup to look on the sdcard for your apps.

    In case you didn't feel like reading all that, it means it's working fine.


    If you want even more output to confirm that it worked, run this from the terminal emulator:

    df -h /system/sd

    or if busybox doesn't like that:

    df|grep /system/sd


    As for other apps not saying anything about apps being on the sdcard, don't trust them. For one, a2sd is "special". Unless an app knows to look at /data/app and realize it's a symlink "shortcut" to the sdcard ext3 partition, it'll just think apps are on internal storage. That's the point of a2sd. It makes android think you now have more internal storage. It even fools some apps into giving your wrong information if they aren't a2sd-aware. The issue is further confused by the fact that android supports moving some apps to the sdcard in a limited fashion. This is not the same thing. That leaves part of the app on internal storage, and moves the non-executable part that it can to the fat32 partition on the card. It also disables widgets. A2sd doesn't work this way, and the android system, in general, thinks apps are still on internal storage when they really aren't


    Did that help clear anything up, or did I just confuse the issue more? :)

    EDIT:

    Oh, and if you're using an aosp ROM, the mount point for the ext3 partition is likely /sd-ext, not /system/sd, so if you ran:

    ls -l -d /data/app

    it would look like this instead:

    app -> /sd-ext
     
    Mikestony, Granite1, argedion and 3 others like this.
  8. dustwun77

    dustwun77 Endeavor to Persevere :)

    @RCope48

    I don't know the precise terms or all the facts but I will share my general knowledge or beliefs, best I can figure.

    There is an older app known as apps2sd (?)that moves portions of apps and stuff to your sd card. No partitioning or anything needed. I think there are various apps with different names that basically do the same thing.

    Then there is a newer version, maybe called the same thing, that does use a partition on your card, if it exists. There is an app or something called Dark Tremors, that you have to flash, and then use terminal emulator to activate, that moves more apps and stuff to your sd card and creates a symbolic link to your phone rom that makes it think the apps are still in there. I think it actually frees up the memory but in settings/apps, it is fooled and still shows the memory being used on the phone. apps like titanium show a different story.

    some of the newer roms have a2sd built in. if you have a partitioned sd card, and restore apps, it puts what it can in the partition automatically, without the need for using terminal emulator or commands. It still shows up as using phone memory even though you see activity in titanium.

    With a2sd built in, the commands can still be used and do valid stuff. I used the zipalign command, it showed up in a2sd check that it did something. I used a2sd repair and it actually seems to have put some apps back onto the phone, had to do the reinstall command to move them back again. all this assumed because of results shown in Titanium backup.

    I have also seen commands to move various caches to the sd card partition. Not sure what they are, have run them though without bad result. Things like superwipe seem to find the cache and wipe it automatically.

    If you have your card partitioned and use a2sd, either built in or with commands, you need to click on sd ext when making a nan backup to copy it so it will be restored.

    If you use the other version, apps2sd, that just moves portions of the apps to sd card, i think you need to click on the android secure option if you want to back up that movement.

    Sure I have missed stuff, not sure of total accuracy, just my thoughts and impressions.
     
    ocnbrze and RCope48 like this.
  9. MizzouBrent

    MizzouBrent Android Expert

    @akazabam

    Nice to see you drop in! Hope all is well.
     
  10. dustwun77

    dustwun77 Endeavor to Persevere :)

    @ akazabam

    Thanks for all of that. Really, it confirms some of my impressions of reading it. Nice to have someone who really knows explain it.

    You also seemed to say what I have thought to be the case, and what caused me confusion, and I think still confuses some, that things are reported as still being in the phone memory that have actually been moved to the sd card partition.

    If you would clarify exactly what command you suggest to use for the cache command, I will take you word for it, trust your judgement, and type it in. You just confused me there a bit.

    Thanks again, glad your phone works and glad to actually see you in here! :p

    Edit: Ok, I got it, put it back in internal memory and speed advantage outweighs loss of space, correct? No, actually, better speed and using space that won't be missed either! Cool
     
    RCope48 likes this.
  11. RCope48

    RCope48 Well-Known Member
    Thread Starter

    Hello,looks like Ive found the resident expert on A2sd! When I run A2sd check from TE, nothing is checked....Ive done A2sd reinstall...and according to TB, it shows the partition and available space, but I dont think its working correctly...how do I proceed?
     
  12. akazabam

    akazabam Android Expert

    Thanks! I'll try to drop in a little more often.

    Right, choose the option to move dalvik cache to the cache partition, and you won't notice any used up space on the normal /data partition, since it'll go to a partition you don't normally use anyway. Some time ago, someone put together a process to actually resize the internal partitions, such as the /cache partition to make them smaller, and make /data bigger. For those that did that, putting dalvik cache on the sdcard makes more sense, because you need over 100 MB free on /cache (it's 160 MB by default). It's all about how you want to save space and what to put where.

    Yeah, the terminal emulator doesn't seem to display the check marks for some reason, so it just looks like an extra space between brackets - [ ] instead of [ ], basically. Go ahead and do the same thing:

    su
    a2sd check > /sdacard/a2sd.txt

    and upload the file here, and I can tell you what it means.
     
    9to5cynic, dustwun77 and ocnbrze like this.
  13. RCope48

    RCope48 Well-Known Member
    Thread Starter

    Here's my file:
     

    Attached Files:

  14. RCope48

    RCope48 Well-Known Member
    Thread Starter

    Why does it open like that? I'll just C&P sorry...

    Darktremor 2.7.5.2 Apps2SD Status Report
    ===================================================================================
    Legend: [✔]=Setting is correct
    [‼]=Setting is correct, but not optimal.
    [✖]=Setting is incorrect and needs to be fixed or option is not available.
    ===================================================================================
    Block Device - [✔] Found
    - [✔] /dev/block/mmcblk0p2
    EXT Partition - [✔] Mounted
    Mount Point - [ ] /system/sd
    Partition Type - [✔] EXT3
    Support EXT2? - [✔] Yes
    Support EXT3? - [✔] Yes
    Support EXT4? - [✖] No

    Apps - [ ] Linked to SD Card.
    [ ] No Apps2SD Flag File not found.
    [✔] Programs run from SD card
    To run from internal storage, type a2sd remove

    Private Apps - [ ] Linked to SD Card.
    [ ] No Apps2SD Flag File not found.
    [✔] Private Programs run from SD card
    To run from internal storage, type a2sd remove

    Dalvik Cache - [ ] Regular directory.
    [ ] Bound to /data/dalvik-cache via mount.
    [ ] Dalvik to /cache flag file found.
    [✔] Dalvik runs from /cache partition
    To run from SD card, type a2sd cachesd.
    To run from internal storage, type a2sd nocache.

    Swap - [ ] Partition not present or no swap support.
    [✔] Swap does not start.

    ZipAlign - [✔] Not running at boot.
    To activate it, type a2sd zipalign

    Dalvik Heap(MB) - [✔] 48m

    Low Memory
    Killer Settings - [✔] 2560,4096,5632,10240,11776,14848
    Note: Values are in pages.
    1 page = 4KB memory.

    Values represent the following:
    1st number = Foreground App
    2nd number = Visible App
    3rd number = Secondary Server
    4th number = Hidden App
    5th number = Content Provider
    6th number = Empty
     

HTC EVO 4G Forum

The HTC EVO 4G release date was June 2010. Features and Specs include a 4.3" inch screen, 8MP camera, 512GB RAM, Snapdragon S1 processor, and 1500mAh battery.

June 2010
Release Date
0
Reviews
Loading...
Tags:

Share This Page

Loading...