1. Are you ready for the Galaxy S20? Here is everything we know so far!

Accidentally deleted stock home launcher

Discussion in 'Android Devices' started by Demented755, Apr 18, 2012.

  1. Demented755

    Demented755 Android Enthusiast
    Thread Starter

    :eek:
    Stupid me.

    Anyway, does anyone know if it's possible to download the .apk from somewhere and install it again back as a system app? If not, aside from buying Titanium Backup Pro, is there a way to force ADW to /system so I don't have to go through hell getting a launcher on the phone after installing my nandroid backup?

    Thanks.
     



    1. Download the Forums for Android™ app!


      Download

       
  2. SamsungAdmire

    SamsungAdmire Android Expert

    There is a way to push an apk via adb if your usb debugging is on by default
    I THINK ( I said I THINK)
    you push the apk with adb to your sdcard
    the use the command adb install (i havent tryed that tho)
     
  3. viperdink

    viperdink Android Expert

    are you sure you deletedi it. if the phone starts up ,let it go for a while like tyll you would be
    at home screen then hit menu button. if it is around it should ask you if you want to restart launcher say yes and your back if not your on the restore trail...
     
  4. Demented755

    Demented755 Android Enthusiast
    Thread Starter

    The com.android.launcher.apk is still in the /system/app folder, but it can't be installed. Thought I had a Titanium Backup backup of it but I guess that got deleted in the mess of flashing stuff.

    Leaving the phone on for a while and then hitting the menu button doesn't do anything. I usually have to wait 10-30 minutes for the Play Store to recognize my phone before I can download something from my browser to the phone.
     
  5. RedBeansNrice

    RedBeansNrice Member

    this happened to me before. I froze my stock launcher and had my launcher pro linked to my sd card with lin2ksd. What saved me at the time is that i always leave my usb debugging on. if your debugging is enabled boot the phone to the black screen and just put a laucher apk in your platform-tools folder and install with this command:

    adb install nameoflauncher.apk

    this will install it.
     
  6. viperdink

    viperdink Android Expert

  7. Demented755

    Demented755 Android Enthusiast
    Thread Starter

    I don't get it. What does Voice Search and 4share have to do with this?
     
  8. gbiggie

    gbiggie La patience et le pardon

    Pull it out of the admire system pull and push it back to your phone like a few said. That will work:thumbup:
     
  9. Demented755

    Demented755 Android Enthusiast
    Thread Starter

    Trying to but adb isn't wanting to work with me, lol. Had everything set-up right on my virtual Windows box but that's gone now, and either I did something wrong setting it up in Linux or it wont recognize my phone. Kinda want to hit it with a hammer but I'm sure I'll get it...eventually.
     
  10. viperdink

    viperdink Android Expert

    you can get adw there voice search was just to get you there

    and 4shared is another file resource site for the file your looking for.

    then you gotta push it
     
  11. Demented755

    Demented755 Android Enthusiast
    Thread Starter

    Ok. I'm in with adb but can't seem to get the apk to push to the system. Have tried every command that I can think of but am not sure exactly what to type to get it to install.

    ./adb shell
    su
    mount -o rw,remount /dev/block/stl9 /system
    push /sdcard/com.android.launcher.apk /system/app/com.android.launcher.apk

    But it says "push: not found":/

    Edit: Same thing with trying to push ADW to system. Grr.
     
  12. gbiggie

    gbiggie La patience et le pardon

    Or do it with this
    http://androidcommander.com/
     
  13. pmb116

    pmb116 Android Enthusiast

    Easiest thing ever. Go online on your computer sign into google. Download ADW or LP. Email it to your gmail account. Have someone call you. Drag down notification sundown open up gmail and install. Apk.
    You now have a home launcher
     
  14. Demented755

    Demented755 Android Enthusiast
    Thread Starter

    I don't have a windows computer like I stated earlier, and that requires a windows computer. Doesn't help...
    Problem there is, without a launcher installed I can't get into Gmail's options to turn notifications back on.
     
  15. Demented755

    Demented755 Android Enthusiast
    Thread Starter

    So, does anyone know why I can't get the apk to install from ADB? I just want to fix this issue, not rely on a crutch to try and get a launcher on.

    Nevermind, got it.
     
  16. TATALAPO48

    TATALAPO48 Lurker


    This is an old tread but just in case for future reference: if you don't have an email acct set up or internet because you factory reset it, just send to your phone a sms with a link (Google play or others web sites that will host your launcher apk) while the phone is on doing it's never ending loop, open the message and click on the link, the phone then will let you set up a connection (ie WiFi) make sure you open it with the browser not with an app, then download - install - open, that simple.

    Hope it helps
     
  17. viperdink

    viperdink Android Expert

    Have you ever tried a factory reset without a launcher or setting up an email account ?
    I have its nerve racking.
    With out a backup or a PC your in for a sad time.:(

    1St Rule IS "ALWAYS MAKE A BACKUP"
     
  18. Samsung Use i

    Samsung Use i Well-Known Member

    I have and its not that hard if you have a settings icon in the status bar.. If you do not then just send yourself an SMS of a launcher like that guy said
     
  19. reapersenpai

    reapersenpai Lurker

    If there's anyone who can help me. I'll me more than delighted to accept your help. I recently installed superuser and system app remover on my LG P506 Phone. The reason I did this was so I could make room on my internal storage and remove the preinstalled at&t apps and whatever other useless apps a forum advised that I could remove. But I removed my LG home apk. since the forum said that I could do so as long as I had another home launcher which I did. I had the zeam launcher that I got from the playstore. But, for some reason or the other my phone shut itself off and went into factory reset mode. When it came back on the only thing I saw was a black screen with the scroll down notification bar at the top and no I don't have a backup because I realize now that I was very careless. What I'd like to know is, if it can be fixed and if so, how
     
  20. Shri Bhagwan

    Shri Bhagwan Lurker

    First thing first:

    1. You have to Factory reset your phone and then reboot it, most probably it will get switched on. Then you create or login with Google ID (you can as I did it in my old Micromax A76).

    2. Now tap on setting===>app===>Google Play===>launch. (If you have logged in, you can easily launch Google store by only this method if "Home Launcher" is uninstalled in any rooted Android device.

    3. Now install any 3rd party launcher from Goggle like Go Launcher, Solo Launcher or any launcher.
    Enjoy :) You have got your phone back from a Coma ;)

    P.S. Please make sure you are not doing Factory reset again without putting the apk of your current launcher in root folder.

    Feel free to ask anything regarding this post.
     
  21. dileepkumarr

    dileepkumarr Lurker

    im also having the same problem i accidentaly deleted the launcher..
    pls any 1 help me
     

Samsung Admire Forum

The Samsung Admire release date was September 2011. Features and Specs include a 3.5" inch screen, 3MP camera, GB RAM, processor, and 1600mAh battery.

September 2011
Release Date
0
Reviews
Loading...

Share This Page

Loading...