1. Are you ready for the Galaxy S20? Here is everything we know so far!

Acer A500 - Can't connect to WiFi

Discussion in 'Android Devices' started by maver1ick, Apr 21, 2011.

  1. maver1ick

    maver1ick Lurker
    Thread Starter

    Hi All - my first post here.

    I Couldn't resist any longer

  2. Dolmangar

    Dolmangar Android Enthusiast

    First thing to try is changing the channel that the Belkin is transmitting on. Perhaps there is something else that is blocking the signal. In fact, I'd try that on your other router as well. You might find out that you can cover your house with just the one.

    There are some android WiFi apps that will help you find out which channels are congested in your area. Then you can switch to one that doesn't have as much traffic. It can make a large improvement in range and stability.

    After that you should verify that you're up to date on the firmware for your routers.

  3. HeadOffice

    HeadOffice Newbie

    My A500 connected to my wifi network and I'm running a Belkin router with encryption straight away. It also connects to my phones portable wifi hotspot as well as my work's network. How did you go? Did it all end up working for you?

  4. kooa

    kooa Lurker

    Hi there, i am new to this forum and i am having the same problem with my Acer A500 and HTC HD2(can be used as wi-fi router). I can get my 2 HP laptops connected to my HTC HD2 handset, but can not get it work with Acer A500.

    You mentioned "There are some android WiFi apps that will help you find out which channels are congested in your area. Then you can switch to one that doesn't have as much traffic. It can make a large improvement in range and stability"..

    Can you please recommend a android WiFi app(s) that will help me to solve this problem? thanks.

  5. HeadOffice

    HeadOffice Newbie

    Check out wifi analyzer in the android market...

    kooa likes this.
  6. treefq

    treefq Newbie

    I am partial to wifi manager.
  7. kooa

    kooa Lurker

    I have downloaded the "wifi anlyzer". Very handy program. However, I just found out that my HTC HD2 wifi is Ad-Hoc version and ACER A500 pups up a message telling me that Android platform does not suppot Ad-hoc wifi.
    Has anyone experienced this before?
    Any solution to this, please?

    LockSpace likes this.
  8. michaelg1030

    michaelg1030 Member

    Yes stock android does not support Ad-hoc. The solution: Root. You have to install a special file for the android to recognize ad hoc. Last I checked at XDA some people have had success with it and others haven't. Give it a couple more days and they will get it sorted out. But you will have to root your device.
  9. LockSpace

    LockSpace Lurker

    I am having no luck connecting my Acer A500 to my Huawei 8100 cell phone Wifi (G) – all security turned off. The A500 does not list the SSID of the phone. Tried 3 phones so not the phone. Laptop and XBOX work fine. I am interested in collecting names of people with the similar issues to put some pressure on ACER. Contact me - Larry labas@lockspace.com. The Sensitivity of the WiFi seems quite low. It does get better if you remove the foil label off the front. My home dlink wireless n-300 does work but range is poor. Some have suggested A500 does not support the higher end channels. It is a warranty issue if it does not work. Other than that, I do love it.
  10. HeadOffice

    HeadOffice Newbie

    My home wifi network operates on channel 12 and no problem at all. Can see SSID straight away. Can tether to my phone no problem at all too. Perhaps you have a faulty unit? Did you take to store and try it out there?

    If you have a foil label on the front - why would you NOT remove it?

  11. LockSpace

    LockSpace Lurker

    Acer A500 AdHoc WiFi support.
    Use Gingerbreak 2.2 to root. (easy )

    get adb as part of android development kit. You can use a terminal emulator on the device itself, just harder to type.
    - Acer USB driver needed for adb to work
    Place new wpa_supplicant in sdcard/download directory - search
    "Got Ad-hoc wifi working on my Xoom! (binaries inside)" to find it.
    Short usb cable needed. Long one had issues.
    set debug mode to on - tablet settings->applications.
    on pc - via cmd shell , change to directory where adb is located.
    on pc - adb devices (confirm one is listed)
    on PC - adb shell (adb remount did not work for me, or use a Terminal emulator (free) from the the market)
    su ( should see # as prompt after success)
    mount -o rw,remount /system
    cd /system
    chmod 775 bin
    cd bin
    cat wpa_supplicant > wpa_supplicant.old
    ls ( make sure copy exists)
    cat /sdcard/download/wpa_supplicant > /system/bin/wpa_supplicant
    acjohnson likes this.
  12. LockSpace

    LockSpace Lurker

    I leave as much of the original packaging as possible while evaluating the unit, as it can be returned to the store within 14 days. Since I was still not sure how to pick between the Xoom, A500, Asus, or near the future 10.1 samsung. I was planning to wait until the Samsung unit was available, but the Store had a renovation opening special - everything 15% off. - $75 on the 499 32 gig A500 made it a deal too hard to pass up on. The foil was on the frame so I left it there for the first day. With hc 3.1 supporting USB slots the Acer is a good choice for me as a developer. It is easier to move files to a USB key then transfer via a micro SD. I like having my USB key updated with video content attached to a pc, then when ready I just plug it in. In this way I don't have to leave the device teathered to a pc ( those poor Ipad users they are so patient) or have the pad stuck at my house while it loads content via wifi.

    Your phone must support infrastructure mode, mine only does hotspots in adhoc mode. The low sensitivity does have its benefits - I can't see all the wifi signals in the area.

    Now my only worry is when netflix will be ready for human (android) consumption and determining the best mp4 conversion settings for other content.
  13. choppaB

    choppaB Lurker

    Did you root your A500 or is the evo capable of Infrastructure wifi ?
    thanks in advance
  14. bazsh

    bazsh Newbie

    Wow..seems so complicated to setup ad-hoc on a500
  15. agent00

    agent00 Newbie

    I had this exact problem. I could not get a WiFi signal unless I was in the same room as the router, and even then I would lose connection frequently. I found a few posts similar to this one around the web, but nothing to indicate that it was a widespread problem. I returned the device to Best Buy for a new one and am now enjoying WiFi the way it was meant to be: from anywhere in the house!
  16. wshart

    wshart Lurker

    My Acer A500 shows weak and intermittent connection when I am sitting 1 foot from my wireless router. Our other computers have strong constant signal throughout the house. I assume the antenna is bad and will return the unit.
  17. gatekeep707

    gatekeep707 Lurker

    I have a linksys e2000, im on my second replacement. The wifi (wpa) seems to drop every couple requests. I was excited to see the 3.1 update, but problem still exists..

    I tried - for testing - turning off the encryption and switching channels...it reconnects instantly, causing a page not found error while reconnecting.

    Anyone else experiencing wifi drops?
  18. JBERRY

    JBERRY Lurker

    I have a linksys router that has been working great for my A500, till today, now the tab will not connect. I sees the wifi, but says disabled, I his the connect "button" and get a message obtaing ip address...remenbered, but then goes back to disabled. Do I need to reset?
  19. fran76

    fran76 Lurker

    THE SAME for me too. For 2 weeks my acer a500 works gr8 now it just tries to scan endlessly (starting today) , says remembered then disconnects then back to scanning and never connecting. all other wifi devices work perfect in my house btw.

  20. fran76

    fran76 Lurker

    I researched a bit and I did this (after many other suggested it) I used a small pin and did a RESET on the side of the tab and once it re started I was automatically signed in no issues. Some have had to do 2 re sets via the pin hole. Also b4 u do resets u may wanna "forget" your wifi settings and when it resets re scan. IDK but it worked for me.
  21. alienpb

    alienpb Lurker

    I found the one RESET didn't work but another RESET as soon as it boots up did the trick. I hadn't changed any WIFI setting prior to doing it and I was back on the network straight away.
  22. Macromia

    Macromia Lurker

    I'm having all the same problems. SOOOOOOOOO frustrating. works at my office but not home or parents home. other devices work fine, but the tablet is stuck in an "obtaining IP address" loop and then disabled. Some have said have to root the device? What does that mean? If its working in my office but not at home should I still do a reset?
  23. chetzcool

    chetzcool Lurker

    Guys, a Soft Reset should fix the issue
    Insert a small paper clip or a needle in the Reset hole and hold it when the tablet is on. It should restart the tablet. Once that happens, everything starts falling in place.
    You should not lose data by doing this.
    Worked for me.
  24. shadowfax49

    shadowfax49 Lurker

    Hi all, new to forum but just resolved the same problem myself.
    Currently have an desktop PC hardwired to a Huawei Echolife HG521 router and happily communicating with a wifi connected Dell laptop.
    Bought them a new playmate, Acer Iconia A500 with Android 3.0.
    The A500 could see the network but just alternated "connecting/scanning" and refused to connect; even removing all security and running "open" didn't work.
    Tried changing DHCP to static, MAC filtering, different channels, manual entry of SSID/password, all with no success.
    Took it to a friends and it connected to his network with no problem (different ISP & router), then another friends where it connected to his and two other nearby "open" networks.
    I took this opportunity to upgrade the A500 to the latest firmware version and 3.1.
    I got home and when it still wouldn't connect I dug out an old Speedtouch 585 router, set it up bingo! it worked.
    So I did what I should've in the first place, reset the original router and used its default settings. After that it still wouldn't connect until I "manually added" the network (typed in the SSID etc).
    Now, it's fine (at least has been for 36 hrs).
  25. acjohnson

    acjohnson Lurker

    This worked for me on my Android Iconia A500. I actually was needing to connect to an ad hock network created by my windows mobile HTC Touch Pro using an old hotspot app (yeah, yeah, I know winblows!)

    Only difference was that I had already updated to HC 3.1 so gingerbreak is not compatible with it... I actually spent like 3 hours trying to root with gingerbreak but it turns out if you have already ran system update on the A500 then you will need to use a different program called IconiaRoot 1.3 (just google [HOWTO] Root for stock HC3.1).

    Once rooted I was able to use the free terminal emulator from the android market (instead of messing around with the android sdk and adb) which just took some patience with the onscreen keyboard.

    One thing I will note is that it doesn't make sense to run this command:
    Code (Text):
    1. chown system.wifi /system/etc/wifi/wpa_supplicant.conf

    But it does make sense to run this command to restore proper permissions to the new wpa_supplicant binary:
    Code (Text):
    1. chown root.shell /system/bin/wpa_supplicant
    Just my two cents...

Share This Page