1. Are you ready for the Galaxy S20? Here is everything we know so far!

[ACS] Nexus S 4G AIO root & CWM flashable zips

Discussion in 'Android Devices' started by Shabbypenguin, May 25, 2011.

  1. Shabbypenguin

    Shabbypenguin Extreme Android User
    Thread Starter

    updated to version 2.0

    1. Download the Forums for Android™ app!


  2. Angry Gimp

    Angry Gimp Newbie

    Just got my Nexus about 3 hrs ago, just rooted about 5 minutes ago. Thanks a ton, was as easy as could be.
  3. Shabbypenguin

    Shabbypenguin Extreme Android User
    Thread Starter

  4. arcadeguest

    arcadeguest Newbie

    Thank you for posting this. I had my ns4g for about 5 min after I got home before being rooted.
    Shabbypenguin likes this.
  5. handler313

    handler313 Android Enthusiast

    A quick question, and believe me I know this probably stupid but I got to ask anyways. Seeing as people seem to be able to use this one click method for phones out of the box, I am guessing that it works with Gingerbread then? My buddy has a Nexus S4G with Gingerbread 2.3.5 on it and he would like me to root it for him.

    I have an Evo myself (which I rooted using unrevoked) so this is all new to me when it comes to the Nexus.

    Thanks in advance :)
  6. Shabbypenguin

    Shabbypenguin Extreme Android User
    Thread Starter

    this willw ork on all nexus s' on ANY firmware version :)

    we dont have a locked bootloader ;)
  7. oftel101

    oftel101 Lurker

    Having an issue with the MS-DOS Batch File. When I try to run it and key through the prompts it ends with this error:

    Could not find "adb.exe" (have you installed it?)

    I am still trying to figure it out on my own, but any guidance would be much appreciated.

    Nexus S 4G
    Windows XP
  8. Shabbypenguin

    Shabbypenguin Extreme Android User
    Thread Starter

    seems that xp isnt very friendly, are you extracting the whole folder?
  9. nackles

    nackles Newbie

    I was getting the same error and I realized I hadn't extracted the files, I was just trying to run it from the zip file. Boy did I feel dumb when I realized.
  10. Shabbypenguin

    Shabbypenguin Extreme Android User
    Thread Starter

    hey now, no reason to feel like that.. we all start at somepoint :)

    in fact it was only may 2010 that i got my first android device since then ive been scouring the net trying to learn as much as i can about it, im just glad that ive finally learned enough that i can start giving back :)
  11. asaetern

    asaetern Lurker

    I used this to root and then installed rom manager. After I installed rom manager I went to create a backup and then I think it went and downgraded my cwm recovery to 3.x.x.x, how do I get back to the latest version?

    ***Edit*** NVM, I figured it out.
  12. IXDoubleDXI

    IXDoubleDXI Newbie

    Thanks Shabby! This worked flawlessly!
  13. Fooie13

    Fooie13 Lurker

    Hi! First time Rooter, been wanting to root my Nexus S4G. Having a problem im working on it at the moment and my problem is that it is still reading device not found. Ive installed everything according to the video and the Readme. Any suggestions.

    Gingerbread 2.3.5
    PDANet active on phone and laptop
    Debugging On
    USB Storage On
    Windows 7 Pro

    Any help is highly appreciated.
  14. Fooie13

    Fooie13 Lurker

    NM i had to go into bootloader myself. i was under the impression bootloader would auto activate. I just turned off phone, held volume up and power button at the same time and it went into bootload for me. now its rooted but im having problems with the hotspot. It will activate but the 3g turns off when i turn on the hotspot. any suggestions?
  15. Shabbypenguin

    Shabbypenguin Extreme Android User
    Thread Starter

    sorry been busy, disable pdanet and it would have worked.

    assmuing your on 2.3.5

    tethering was blocked, i posted a fix for it
    Fooie13 likes this.
  16. Fooie13

    Fooie13 Lurker

    yeh i figured there was something in the background keeping me from going into bootloader. Tethering works for me, its just wifi hotspot. when i activate wifi hotspot, 10 seconds later 3g would shutdown. I can connect to the hotspot but i cant to the internet.
  17. Dinkis

    Dinkis Newbie

    Just Rooted My gfs ns4g and when i go to bootloader and then recovery I get A triangle with a ! mark in it. from there i can hold volume up and power and it gos in to a form a of recovery but the color is blue not orange also doesnt say cwm. is this normal? i cant find where to do a back up on this so called recovery. New to rooting any advice or sugestions would be great and appreciated!

    Edit: I will try this when she come home
  18. Shabbypenguin

    Shabbypenguin Extreme Android User
    Thread Starter

    OP updated to version 3.0, added cwm flashable zips incase you just want to update cwm without fastboot etc ;)
  19. jkelly0o0

    jkelly0o0 Lurker

    So this will wipe everything? I don't want a custom rom or anything, just root.
  20. Shabbypenguin

    Shabbypenguin Extreme Android User
    Thread Starter

    there is no way around it, the only way to get root is by unlocking the bootloader.. which wipes out everything

Nexus S 4G Forum

Features and specs are not yet known.

Release Date

Share This Page