1. Are you ready for the Galaxy S20? Here is everything we know so far!

Adb help!!!

Discussion in 'Android Lounge' started by Bmarx4, Jan 10, 2010.

  1. Bmarx4

    Bmarx4 Lurker
    Thread Starter

    Ok, I've tried about 10 different tutorials involving step-by-step instructions to get adb functioning properly but I just can't get it to work....I'm so frustrated by now, that I can't even remember why I needed it...Anyways, I'm not one to give up, yet I do need help....Here's what I've done so far:

    Downloaded SDK
    Downloaded Eclipse
    Downloaded USB Drivers via SDK and AVD Manager
    Added the correct folder location in my PATH....I used this tutorial(http://forum.xda-developers.com/showthread.php?t=502010) and placed it in it's own variable named "adb" since "path" wasn't working either.
    This is the location: C:\android-sdk_r04-windows\android-sdk-windows\tools

    When I run the cmds up to here:
    C:\Users\My Username> cd C:\android-sdk_r04-windows\android-sdk-windows\tools

    C:\android-sdk_r04-windows\android-sdk-windows\tools>

    And then I give cmd "adb devices" it just comes back with "devices list attached" and it's blank...So I think there is an issue involved with the whole updating of the drivers because when I go into device manager and point to the proper folder, windows comes back and says that the driver is already up to date so it never installs it. I also uninstalled the drivers and then reinstalled them using the same procedure and nothing seems to be working.....I'm on a Vista 32 Bit with a G1....Any help would be great, I believe I have inputted all information needed for you guys!

    Thanks in advance!
    Brandon
     


  2. gnur

    gnur Newbie

    I used a tool found on XDA forums called relentless rooter. This allowed me to install the correct usb driver. Without relentless rooter I ran into the same issues.
     
  3. mrthundercleese

    mrthundercleese Well-Known Member

    Do you have debug mode enabled on your device (I'm assuming the G1 has such a mode)? This is required.
     
  4. Bmarx4

    Bmarx4 Lurker
    Thread Starter

    Yes....debugging is on.

    I'll try that relentless root later on today and see how it goes.
     
Loading...

Share This Page

Loading...