1. Check out our app, Forums for Android! Download and leave feedback here!

adb in Linux?

Discussion in 'Android Devices' started by mikenick42, Jan 16, 2010.

  1. mikenick42

    mikenick42 Well-Known Member
    Thread Starter
    15

    Nov 25, 2009
    64
    0
    15
    I have android-sdk-linux_86 and can run the emulator. I also have the udev rule for the Behold 2 as well as the debug etc settings on the phone, but I can't get it to come up when I run "$adb devices" Can anyone help me out?
     

    Advertisement

  2. marius

    marius New Member
    5

    Jan 21, 2010
    2
    0
    5
    Hi,

    i am having the exact same problem. I have added rules to udev and gone to settings -> applications -> development -> and checked USB debugging.

    I run archlinux x86_64.

    - Marius
     
  3. dan0zone

    dan0zone Well-Known Member
    38

    Nov 29, 2009
    180
    22
    38
  4. marius

    marius New Member
    5

    Jan 21, 2010
    2
    0
    5
    I have actualy done those steps. But when i run "adb devices" i still get no devices. I have even changed SYSFS{idVendor}=="0bb4" to SYSFS{idVendor}=="04e8" which is the id of the behold2.
     
  5. devrdander

    devrdander Member
    5

    Jan 18, 2010
    5
    0
    5
    Theres a bug in the latest SDK where it won't recognize the galaxy/bh2, download an older version like the one in the thread linked, i am using a patched adb binary from the old 1.5 sdk myself, but the one in that thread looks older and may work for you. If that one doesnt work I can post the patched binary I use.
     
  6. mikenick42

    mikenick42 Well-Known Member
    Thread Starter
    15

    Nov 25, 2009
    64
    0
    15
    I was able to get it loaded under XP with MrAndroid's help last night. I still don't know how to do it in Linux.
     

Share This Page

Loading...