1. Check out our companion app, Forums for Android! Download from Google Play

Support adb issues

Discussion in 'Android Devices' started by sharksfan7, Mar 12, 2014.

  1. sharksfan7

    sharksfan7 Well-Known Member
    Thread Starter

    Aug 8, 2011
    San Diego, CA
    With my HTC Inspire I found that while powered off I could connect it to my computer and adb would still detect the device. I could power it on with "adb reboot" or boot straight to bootloader. While I never actually needed it, it was cool knowing I could in case my power button broke or whatever. But with the One, this doesn't seem to work. I have USB Debugging enabled, but when powered off adb won't see the device attached. So I'm curious, what's the difference in the two systems that allows one to be recognized and the other not? Is there something I can do with the One to enable this functionality?


  2. Rukbat

    Rukbat Well-Known Member

    Jan 16, 2012
    Being retired and writing Tasker tasks.
    Fayetteville, NC, USA
    I tried it with a few other phones. Evidently the Inspire doesn't really turn off when you turn it off, or your phone isn't completely turning off. I didn't find another phone that adb would see with the power off.
    sharksfan7 likes this.
  3. dkonkin

    dkonkin Member

    Jun 12, 2010

    Over the last couple months I have been searching and troubleshooting but still do not have an answer.

    A couple months back I lost the ability to get FASTBOOT USB. After plugging in HTC One (m7ul) to Mac while in boot loader FASTBOOT would not change to FASTBOOT USB. Also, it is not recognized when doing ADB.

    I have tried different cables and numerous other recommendations with no success.

    Interestingly, when I connect my HTC One X (evita) using the same computer and cable it does go into FASTBOOT USB and I can access it via ADB. Which confirms the issue is in the HTC One.

    Recently I tried to connect via USB with Android File Transfer but it did not see my HTC One. I downloaded HTC Sync Manager to my Mac and it does not see the HTC One.

    Has anyone experienced this before? Does anyone have any ideas what could be wrong?

    Thank you for your time,


Share This Page