1. Are you ready for the Galaxy S20? Here is everything we know so far!

adb uninstall failure on Android 4.4.4 (bloatware removal)

Discussion in 'Android Lounge' started by Bimbumbam, Feb 15, 2021.

  1. Bimbumbam

    Bimbumbam Lurker
    Thread Starter

    Hello,

    I am trying adb to remove bloatware, this is the situation:
    • Android 4.4.4, Samsung Galaxy Lite (SM T113)

    • USB cable is connected, can see tablet files

    • USB debugging is enabled on the tablet

    • adb is installed, start-server ok

    ex. package to uninstall com.google.android.apps.books :


    ~$ adb shell pm uninstall com.google.android.apps.books //enter

    Failure //output

    Why can't adb uninstall this package?
     



    1. Download the Forums for Android™ app!


      Download

       
  2. Hadron

    Hadron Smoke me a kipper...
    VIP Member

    Probably because contrary to what some slightly glib tutorials say you cannot completely uninstall everything on all devices without root.

    The closest you can get would be "adb shell pm uninstall user 0 com.google.android.apps.books". That won't remove it from the system partition (but you can't use the space in the system partition anyway, and you wouldn't gain any space if you could remove it), but it should uninstall it for the current user (i.e. you). So just give that a try, and then don't lose sleep about the fact that there's still a copy hidden in the ROM because that makes no difference to you.

    Of course simply clearing the app's data, uninstalling any updates and disabling it will have essentially the same effect as well, so you could just do that.
     
    puppykickr, MrJavi and Dannydet like this.
  3. Bimbumbam

    Bimbumbam Lurker
    Thread Starter

    Indeed I am doing this for the sake of learning, rather than making (little) space on the device.

    Tried your suggestion, same result:
    ~$ adb shell pm uninstall user 0 com.google.android.apps.books
    Failure


    In some other forum there is a comment about 4.4.4 not supporting multi-user yet.
    But the user 0 part of the command did not generate errors.
    It did when I typed --user 0 instead (again, command detail from another forum).

    So the next step in learning, since you mention it, is to see the system partitions in the tablet. :)
     
    MrJavi likes this.
  4. Hadron

    Hadron Smoke me a kipper...
    VIP Member

    I has been a long time since I touched 4.4.

    You probably won't be able to "see" the system partitions without root. They are there, but I doubt you'll be able to look at them.
     
    MrJavi, ocnbrze and Dannydet like this.
  5. why dont you just root the device as u can uninstall the bloatware that way
     
    MrJavi and ocnbrze like this.
  6. Hadron

    Hadron Smoke me a kipper...
    VIP Member

    There are many reasons people might not want to root.

    Also it makes no real difference since even when rooted you couldn't actually use the space freed up in the system partition (OK, Titanium Backup Pro has an option to make an app a system app, but honestly the space it saves is negligible, and it wasn't always reliable the last time I tried it). As long as the app can't run that's enough in reality.

    (And for background, I'm speaking as someone who used to edit custom ROMs to his own taste before installing them, and has edited the bootloader of my first android phone. So not someone who is opposed to root on principle, just someone who recognises that it's not for everyone, and would always recommend that anyone contemplating it making sure they know what it involves, what complications it might cause, and have a clear idea of why they want to do it before they start).
     
    puppykickr, Dannydet and ocnbrze like this.
  7. true point but however you can unroot your device after you have removed the bloatware
     
    MrJavi likes this.
  8. Hadron

    Hadron Smoke me a kipper...
    VIP Member

    But the person who finds root intimidating, or too complicated, isn't going to want to do that. And someone who is worried about warranties (which won't apply in this case) doubly won't want to, especially since unrooting may not help with warranty violation (in many devices it leaves traces which may be hard or impossible to remove).

    I would actually say that bloatware removal is probably not a good enough reason for doing it, unless you are interested in root for other reasons or already comfortable with it. Compared to what you can (in most cases) do without root I'm not convinced it is worth it.
     
    puppykickr and ocnbrze like this.
  9. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!

    MrJavi and Dannydet like this.
  10. MrJavi

    MrJavi Android Expert

    If you have TWRP custom recovery, you don’t need to root. In TWRP go to mount and select system as well. Then go to advanced->file manager, navigate to system/app or system/priv-app and delete the folder containing the app. The app's data should also be deleated (data/data). After that go to wipe, tap advanced wipe and check dalvik/cache followed by swipe to wipe and reboot system.

    20210219_060559.png 20210219_060739.png 20210219_060652.png

    Screenshot_2021-02-19-06-13-00.png


    If you wish to reinstall stock recoery just flash the stock boot.img. using Odin.

    Personally, even as a rooted user for many, many years, I would not choose this route. It's definitely not for the novice.


    https://www.reddit.com/r/androidroo...ooting_is_not_enough_to_remove_bloatware_the/
     
    #10 MrJavi, Feb 19, 2021
    Last edited: Feb 19, 2021
    ocnbrze likes this.
Loading...

Share This Page

Loading...