1. Are you ready for the Galaxy S20? Here is everything we know so far!

ADB working successfully

Discussion in 'Android Devices' started by theperfectpunk, Sep 24, 2011.

  1. theperfectpunk

    theperfectpunk Well-Known Member
    Thread Starter

    Thanks to our friend Sanjeev a.k.a. aptsanju(he discovered it in the first place, so the credit goes to him).

    I found the problem with adb(actually the default daemon server does not detect any other phones besides the known manufacturer).

    adb now works in the Micromax A70.

    All one needs to do is to install the drivers provided by rajapandian, in a thread in this forum. Install 91 PC Suite and let it detect the phone, then try to use adb devices in command prompt.(you will notice that it will not try to start the daemon server as it will use the daemon server provided by 91 PC Suite).

    If any other Problems, please post here
     

    Advertisement

    Sentacy, rahules and aptsanju like this.
  2. insane_subro

    insane_subro Well-Known Member

  3. akshaybz

    akshaybz Android Enthusiast

    I've tried it before already...

    perhaps something went missing :(
     
  4. rahules

    rahules Well-Known Member

    tnx for the tip dude....really helpful
     
  5. songoku

    songoku Newbie

    I have 91 PC suite installed... Tried running adb devices and this is what I got... :(
     
  6. samrox144

    samrox144 Android Expert

    enable usb debugging in phone and connect....and also install usb drivers by google in sdk
    then try again
     
  7. songoku

    songoku Newbie

    i already have... :|
     
  8. samrox144

    samrox144 Android Expert

    update your adb.it looks like it is very old....and did you install jdk and jre
     
  9. songoku

    songoku Newbie

    Yes I have jdk & jre installed.... My adb is updated.. this default daemon server doesn't detect A70.. that's why i'm using the one provided by 91 PC Suite... and this server is out of date... so the default daemon is getting started again... :(
     
  10. samrox144

    samrox144 Android Expert

    i think its problem of drivers....do this
    install the drivers of pda net app ...this contain adb device servers driver install that

    download from here

    Download PdaNet
     
  11. songoku

    songoku Newbie

    I'll try this now... thanks...
     
  12. songoku

    songoku Newbie

    Tried it... PdaNet app show's connected i'm able to see my contacts in SMS option...
    Its only for Tethering :(

    Still getting the same... but now it doesn't even tell server outdated like it did for 91 PC suite daemon server... :(

    C:\Program Files\Android\android-sdk\platform-tools>adb devices
    * daemon not running. starting it now on port 5037 *
    * daemon started successfully *
    List of devices attached

    C:\Program Files\Android\android-sdk\platform-tools>
     
  13. samrox144

    samrox144 Android Expert

    did the android usb driver was installed...if it was then first
    in cmd do this
    platform tool/adb
    adb shell
     
  14. songoku

    songoku Newbie

    yes.... I have already tried it...
     
  15. samrox144

    samrox144 Android Expert

    it should have detected it...try reinstalling pc suite and did you install some drivers by
     
  16. akshaybz

    akshaybz Android Enthusiast

    Make sure that the 91PC Suite is running in background :)
     
  17. songoku

    songoku Newbie

    @samrox144 yes I installed the one provided in 91 PC suite by rajapandian
    @akshaybz yeah its running in background buts what happens is when I run adb devices it kill's the one provided by 91 pc suite telling its an outdated version and runs by default adb provided by google which is latest.... :|
     
  18. akshaybz

    akshaybz Android Enthusiast

    Now i'm in same situation as songoku, I updated the google SDK today and now unable to use ADB :(

    Edit:

    Solution to problem:

    Go to: C:\Program Files\NetDragon\91 Mobile\android\DeviceInterface\Bin

    The androidinterface.exe is the ADB ;)

    use androidinterface in command instead of ADB :)

    Now, you can thank me :D :D
     
  19. songoku

    songoku Newbie

    @akshaybz Good your solution works :)

    Buts here's something I would like to share with everyone...
    I was able to get the adb working with default daemon... using adb devices :)
    Its 10pm now... will be posting it tomorrow... :)
     
Loading...
Tags:

Share This Page

Loading...