1. Are you ready for the Galaxy S20? Here is everything we know so far!

adbwinapi.dll not found error

Discussion in 'Android Devices' started by Trijinx, Aug 30, 2012.

  1. Trijinx

    Trijinx Lurker
    Thread Starter

    I'm trying to unlock my HTC wildfire S* *sry for edit*..Htc dev step 8 run fastboot via CMD..Type it all in. Getting the abdwinapi not found error...Looked at a few post seen what was done Moving platform tools to tools. I also moved the tools folder...Fastboot etc all files needed to run process to folder C:\Android ran fastboot still nothing...I just want to unlock this bugger
     



    1. Download the Forums for Android™ app!


      Download

       
  2. senthamil

    senthamil Well-Known Member

    Hi,

    Have you installed Android SDK on your PC?
    If yes, Go to sdk installed folder, and then to Platform tools folder
    (ex: c:\android-sdk-windows\platform tools)

    there copy those 3 files to your c:\android. That's enough...
    1. adb.exe
    2. adbWinApi.dll
    3. Fastboot.exe

    You dont have to move the complete folder, just copy those 3 files.


    ________________________
    Hope this may be useful..... :)
     
    l3gacy and scoutelicious like this.
  3. praveen_cii

    praveen_cii Lurker

    Hi, How do I find the SDK folder? I had installed only "Eclipse", as suggested in "How to root the Wildfire S with S-ON". I also installed SDK Manager. Still not able to find the folder in Program files. How do I locate this? Can anyone help me with detailed procedure? Thank you.
     
  4. scary alien

    scary alien not really so scary
    VIP Member

    Welcome to our AndroidForums, praveen_cii :).

    You should be able to find the files you need in our mini-sdk .zip file which can be found in this post:

    http://androidforums.com/faqs/443072-adb-guide-updated-2013-05-21-a.html#post5389081

    Cheers and best of luck!

    :)
     
    Kakuncio and BRAINZ2013 like this.
  5. BRAINZ2013

    BRAINZ2013 Extreme Android User

    Yes the mini works wonders and takes up little space but does a big help
     
  6. oneey3dinjun

    oneey3dinjun Lurker

    I think the most common errors are saving the files to the same directory and properly pointing to the right folder in the cmd prompt, I know I made this mistake a few times myself. It's been a few years since I used the cmd prompt for anything, then again I'm a chef and I don't expect a techy to know how to de-vein a fois gras. ;^) Thanks to those in the know or I wouldn't have solved my rooting issues!!
     
    scary alien likes this.
  7. banana_plug

    banana_plug Lurker

    place the downloaded folder to C:\mini-sdk.

    then > left mouse click > cmd here.

    then execute the commands you need.

    thank you guys. this saved my ass.

    god bless :D
     
    scary alien likes this.
  8. Verunka

    Verunka Lurker

    Hi,

    I am trying to root my HTC ChaCha but when entering the fastboot command prompt fastboot oem get_identifier_token (HTCdev step 5), I get a message about a missing adbwinapi.dll file.

    I have downloaded the sdk-tools with all 3 necessary files (adb.exe, AdbWinApi.dll, fastboot.exe).

    I tried to run the command prompt using the Windows\system32 as well as Windows\system32\sdk-tools path - both of these contain the 3 files.

    I've also added the directory containing the "AdbWinApi.dll" to Windows' path under Environment Variables as suggested on another forum.

    I keep getting the 'adbwinapi.dll file not found message.

    Also, most forums refer to a C:\Android folder - I don't have this folder. Everything is in the System32 Windows folder.

    Any help would be really appreciated. I'm not a techie but can follow instructions.

    Thank you.
     
  9. scary alien

    scary alien not really so scary
    VIP Member

    Welcome to our AndroidForums, @Verunka :).

    Let's assume you have a C:\temp folder or can make one or one of your own choosing.

    Download the http://androidforums.com/attachments/sdk-tools-zip.77466/ and extract it's contents to that folder.

    (note: there's an sdk-tools folder inside that .zip, navigate inside that folder and extract those files to your work folder)

    Here's an example where I created the "verunka" folder on my C:\ drive, and then extracted the .zip file's sdk-tools contents into there:

    Let us know if you have other questions :).
     
    Kakuncio likes this.
  10. Verunka

    Verunka Lurker

    Hi scary alien and thanks for the prompt reply.

    I have downloaded the files to a temp folder and then moved to contents of the sdk-tools folder into the system32 Windows folder (I assume that's the work folder you were referring to).

    I then tried to rerun the command prompt and received the same error message 'adbwinapi.dll' file not found.

    Sorry if I'm missing something obvious here...

    I have Windows 10 (not sure if that's relevant).
     
  11. scary alien

    scary alien not really so scary
    VIP Member

    You don't really have to move them to the system32 folder...

    Try doing what I did in the example above, where I cd'd (navigated) into the work folder, then issued the set path="" command so the DOS shell (Windows Command Prompt) would have to look/use the current folder's path as the source location to find files.

    The above example should also work for you...if it doesn't try copying/pasting your session output here for us to see.

    Cheers!

    edit/by the way, I don't have Windows 10 yet, so I'm not sure if that is an issue or not.
     
  12. Verunka

    Verunka Lurker

    Thank you scary alien!

    I followed your example to cd to the C:\temp folder where the sdk-tools are. It seems to have worked!

    Though now it's stuck on 'waiting for device'. When I connect the phone via USB the computer 'sees it' but then during the bootloader unlocking process the connection gets lost. Not sure how to fix that...

    I downloaded the HTC Sync Manager but it doesn't see my phone - I suspect the HTC Chacha is too old to be compatible with it...

    I've read about uninstalling the USB drivers but not sure if that's a solution or how to do it.

    Microsoft Windows [Version 10.0.10586]
    (c) 2015 Microsoft Corporation. All rights reserved.

    C:\WINDOWS\system32>cd \

    C:\>mkdir C:\temp
    A subdirectory or file C:\temp already exists.

    C:\>cd C:\temp

    C:\temp>dir
    Volume in drive C is Win8
    Volume Serial Number is 8625-BC4E

    Directory of C:\temp

    14/02/2016 21:16 <DIR> .
    14/02/2016 21:16 <DIR> ..
    05/12/2012 15:41 1,464 driverinst.log
    05/12/2012 15:41 6,411 printerinst.log
    14/02/2016 21:16 <DIR> sdk-tools
    10/12/2012 14:38 531 vncclipboard (service).log
    05/12/2012 17:55 1,002 vncclipboard (service).log.bak
    14/02/2016 20:44 1,212 vncserver-sservice.log
    14/02/2016 20:42 8,339 vncserver-sservice.log.bak
    6 File(s) 18,959 bytes
    3 Dir(s) 442,505,302,016 bytes free

    C:\temp>fastboot

    C:\temp>cd C:\temp\sdk-tools

    C:\temp\sdk-tools>fastboot
    usage: fastboot [ <option> ] <command>

    commands:
    update <filename> reflash device from update.zip
    flashall flash boot, system, vendor and if found,
    recovery
    flash <partition> [ <filename> ] write a file to a flash partition
    erase <partition> erase a flash partition
    format[:[<fs type>][:[<size>]] <partition> format a flash partition.
    Can override the fs type and/or
    size the bootloader reports.
    getvar <variable> display a bootloader variable
    boot <kernel> [ <ramdisk> [ <second> ] ] download and boot kernel
    flash:raw boot <kernel> [ <ramdisk> [ <second> ] ] create bootimage and
    flash it
    devices list all connected devices
    continue continue with autoboot
    reboot reboot device normally
    reboot-bootloader reboot device into bootloader
    help show this help message

    options:
    -w erase userdata and cache (and format
    if supported by partition type)
    -u do not first erase partition before
    formatting
    -s <specific device> specify device serial number
    or path to device port
    -l with "devices", lists device paths
    -p <product> specify product name
    -c <cmdline> override kernel commandline
    -i <vendor id> specify a custom USB vendor id
    -b <base_addr> specify a custom kernel base address.
    default: 0x10000000
    -n <page size> specify the nand page size.
    default: 2048
    -S <size>[K|M|G] automatically sparse files greater
    than size. 0 to disable

    C:\temp\sdk-tools>fastboot oem get_identifier_token
    < waiting for device >
     
    scary alien likes this.
  13. scary alien

    scary alien not really so scary
    VIP Member

    Excellent! At least access to the fastboot utility is no longer an issue.

    I can only think of two things that might help with what you're currently seeing:

    1. You might not have the proper USB drivers for the fastboot command and am not sure if HTC Sync would help there (it's been a very long while (2010) since I've really been involved with an HTC device (this is probably the most likely issue)

    edit: I do see a few results in a Google search where folks have used the PDANet USB drivers for the ChaCha if the HTC Sync drivers won't work

    2. If you happened to be using a USB 3.0 port, you might want to try a USB 2.0 port--I've had issues w/fastboot when using a USB 3.0 port in the past (this is a longer shot, but still worth checking; also, making sure you've got a good, working cable, too)
     
  14. quarry bodger

    quarry bodger Lurker


    Please would you explain, step by step to a simple novice exactly how to do this? i have downloaded, extracted, and created a work folder, but can i heckers like do anything with it.

    i do so hope that you can help me
     
  15. scary alien

    scary alien not really so scary
    VIP Member

    Welcome to our AndroidForums, @quarry bodger :).

    Okay, assuming you're using Microsoft Windows, let's do this:

    - download our mini-sdk.zip file: http://androidforums.com/attachments/sdk-tools-zip.77466/

    - extract the contents of that file to a folder on your system--say c:\temp

    - after extracting the contents, you'll now see an sdk-tools folder inside c:\temp

    - inside that c:\temp\sdk-tools folder you'll see these files:

    c:\temp\sdk-tools>dir
    Volume in drive C has no label.
    Volume Serial Number is 843C-52A5

    Directory of c:\temp\sdk-tools

    11/11/2014 03:54 PM <DIR> .
    11/11/2014 03:54 PM <DIR> ..
    10/16/2014 12:33 PM 1,318,951 adb-linux
    11/11/2014 03:50 PM 1,324,340 adb-mac
    11/11/2014 03:50 PM 1,009,664 adb.exe
    11/11/2014 03:50 PM 96,256 AdbWinApi.dll
    11/11/2014 03:50 PM 60,928 AdbWinUsbApi.dll
    10/16/2014 12:33 PM 215,626 fastboot-linux
    11/11/2014 03:50 PM 213,404 fastboot-mac
    11/11/2014 03:50 PM 196,608 fastboot.exe
    08/26/2011 03:59 PM 28,160 md5sums.exe
    05/18/2014 11:16 AM 1,414 sdk.sh
    11/11/2014 03:59 PM 83 Version.txt
    11 File(s) 4,465,434 bytes
    2 Dir(s) 282,473,418,752 bytes free

    - be sure that your device is connected to your PC via the USB cable

    - we'll also assume that you've already got the proper USB driver for your device already installed (for either/both fastboot or adb--they can indeed be different and is very device-dependent)

    - if you're trying to use adb, be sure that you've got USB debugging enabled (Settings -> Developer options -> USB debugging (checked/enabled)

    - if you're tring to use fastboot, your device will, of course, need to be booted into fastboot / bootloader mode

    - start up a Windows Command Prompt (DOS Window); you can do this by:

    - Start button, enter "cmd" in "Search programs and files" box
    - Windows key and then the "R" key at the same time, then enter "cmd" in the Open: field of the Run window that appears​

    - from the Windows Command Prompt window, you'll navigate to the folder where you extracted the mini-SDK files to, clear the path environment variable, and then issue the desired command:

    c:\>
    c:\>cd temp
    c:\temp>cd sdk-tools
    c:\temp\sdk-tools>dir fastboot.exe adb.exe
    Volume in drive C has no label.
    Volume Serial Number is 843C-52A5

    Directory of c:\temp\sdk-tools

    11/11/2014 03:50 PM 196,608 fastboot.exe

    Directory of c:\temp\sdk-tools

    11/11/2014 03:50 PM 1,009,664 adb.exe
    2 File(s) 1,206,272 bytes
    0 Dir(s) 282,476,650,496 bytes free


    c:\temp\sdk-tools>adb devices
    List of devices attached
    xxxxxxxxxxxxxxxxxxx device


    c:\temp\sdk-tools>fastboot devices
    List of devices attached
    xxxxxxxxxxxxxxxxxxx fastboot


    c:\temp\sdk-tools>

    Hope that helps--for additional information, see this thread re. adb for adb-related info:

     
  16. quarry bodger

    quarry bodger Lurker

    Hmmmm. Thank you, but i needed even more basic than that. lol. I managed to get the identifier token, but then couldnt do anything afterwards. However... SUCCESS, i have now unlocked my bootloader after a few youtube tutorials on using cmd etc
     

HTC Wildfire S Forum

The HTC Wildfire S release date was May 2011. Features and Specs include a 3.2" inch screen, 5MP camera, 512GB RAM, Snapdragon S1 processor, and 1230mAh battery.

May 2011
Release Date
0
Reviews
Loading...

Share This Page

Loading...