1. Download our Official Android App: Forums for Android!

Support Added Calendar to Google Calendars Not appearing on phone

Discussion in 'Android Devices' started by MommyD, Jan 13, 2012.

  1. MommyD

    MommyD Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Jan 13, 2012

    Jan 13, 2012
    2
    0
    5
    This week I added a new calendar to my Google Calendars connected to my main Gmail account (also what used for my phone). It will not show up on my phone. I have tried several suggestions on many forums, such as:
    1. Creating a new Gmail account, sharing calendar with new account, adding new account to phone - did this, and ended up with new account and the default calendar to that account, but not the shared calendar I created.
    2. The calendar is shared with my husband (a family calendar), so I added his account to my phone (it shows up in his phone). His account and other calendars show up, not the new one I created.
    3. Deleting my Gmail account and readding it -because it is the one I connect to my phone this would reset my phone to factory settings, not worth it.

    I've looked under Settings>Calendars - it just does not appear at all. No green check to check because it's not there. I am not over the limit...the new default calendar and my husbands calendars showed up when adding those accounts.
    So confused? Seems to be related to the Strasophere since my husbands Samsung Fascinate picks it up.
    Any suggestions? Thanks so much!

     

    Advertisement

  2. Scur

    Scur Android Expert
    Rank:
    None
    Points:
    163
    Posts:
    1,394
    Joined:
    May 1, 2011

    May 1, 2011
    1,394
    481
    163
    Male
    Illinois
    What app or widget are you trying to look at your calenders with? Have you tried alternative apps?
     
  3. MommyD

    MommyD Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Jan 13, 2012

    Jan 13, 2012
    2
    0
    5


    I am just using the stock calendar option.
     
  4. cpetersman

    cpetersman Lurker
    Rank:
    None
    Points:
    16
    Posts:
    2
    Joined:
    Jan 16, 2012

    Jan 16, 2012
    2
    3
    16
    We are having the same issue with ours.

    Wife's phone. New calendar on google in her name.

    I have shared my calendars with her, but they do not show up as options.

    I added my account to the phone, but only can sync 2 of my 5 calendars.

    No "application" is being used - it is the calendar app that comes with the phone.

    Anyone with any ideas?

    Craig Petersman
     
  5. cpetersman

    cpetersman Lurker
    Rank:
    None
    Points:
    16
    Posts:
    2
    Joined:
    Jan 16, 2012

    Jan 16, 2012
    2
    3
    16
    A little lucky google searching helped.

    Try this:
    1. From the home screen, click the "menu" button (bottom left corner of phone).

    2. Click Settings

    3. Click Applications

    4. Click Manage Applications

    5. Click All (at top of screen)

    6. Scroll down and click Calendar Storage

    7. Click Clear Data

    8. Exit out and wait for calendar to sync. When I did this, it took only a few seconds and all the calendars were showing.

    This is where I got the answer - it is for the Droid, but worked with the Stratosphere too.

    Droid X: Calendar Doesn’t Sync | Technipages


    Craig Petersman
     
  6. Timidated

    Timidated Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Oct 30, 2014

    Oct 30, 2014
    1
    0
    5
    The problem is that some built-in calendars on phones and tablets don't seem to have the menu options needed to accomplish this!
    This was the case with my Sony Xperia Z3 phone. But this is easily solved. What you do is install the "Google Calendar" app from Google Play and then go to the "calendars to show" menu option, click "calendars to synchronize" and there you'll find the shared calendar. (This is assuming the sharing is already set up in the PC web-browser version of gmail/google calendar)

    When you've accomplished this, you can actually go back to the calendar app you were already familiar with. You only need "google calendar" for setting up the synchronization correctly.
     
  7. RafaelLVX

    RafaelLVX Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Apr 9, 2015

    Apr 9, 2015
    1
    0
    5
    Male
    This did the trick. Thanks!
     
  8. michaeltomiak

    michaeltomiak Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Mar 2, 2013

    Mar 2, 2013
    1
    0
    5
    This didn't work for me.

    I'm still having the same issue as the original post:
    I get my hotmail (Corporate) account, calendar showing up fine, and as an option to select in my calendars on my android, but any additional calendars that I share with partner/family do not appear as a calendar option.

    Really need some help here!

    Michael
     
  9. Bikin

    Bikin Lurker
    Rank:
    None
    Points:
    15
    Posts:
    1
    Joined:
    Jun 22, 2015

    Jun 22, 2015
    1
    0
    15
    Male
    Thanks Craig. I reinstalled the calender app Timidated suggested but that did not help. They I did what you suggested and my wife's shared calender now appears.
     
  10. Aaron Irons

    Aaron Irons Lurker
    Rank:
    None
    Points:
    16
    Posts:
    1
    Joined:
    Nov 2, 2015

    Nov 2, 2015
    1
    1
    16
    Male
    None of the instructions above worked for me, so this is how I got newly created calendars to show on my phone after I have created them on another computer in the browser.

    I had to go in to the settings of Google Calendar and turn on the Sync option for newly created calendars. Apparently it will do this automatically when you first set it up but will not auto-sync new calendars. Even clearing all your app data and cache will not auto-enable these new calendars that are done after setup. Maybe a bug?

    Anyway, just do this:

    1). click the Hamburger on the top left corner in the calendar app,
    2). scroll down to the bottom to "settings",
    3). find your calendar (un-snyced calendars appear at the bottom, and you may need to click "Show More" to see it).
    4) Click the toggle button for "Sync"
    5). Go back to your calendar and refresh (top right, three got vertical line icon, click "refresh");

    Worked for me on my Nexus 6 using Google FI.
     
    squishy79 likes this.
  11. 3005johnm

    3005johnm Lurker
    Rank:
    None
    Points:
    15
    Posts:
    1
    Joined:
    Nov 3, 2015

    Nov 3, 2015
    1
    0
    15
    Male

    This process worked for me too on my new Xperia Z3 Compact having failed with other methods described above - the trouble is the way things display is slightly different on each version of Android. . I was already working with the version of the app downloaded from Google play store. At step 3)I found my calendar listed under "Events". I clicked "show more" and all six calendars I was missing suddenly appeared, and when I went back to the calendar display, there they all were
     
  12. kyaworski

    kyaworski Lurker
    Rank:
    None
    Points:
    15
    Posts:
    1
    Joined:
    Feb 4, 2016

    Feb 4, 2016
    1
    0
    15
    I tried Bikin's suggestion (clear calendar app data and re-sync but it didn't help. Removed my google account and then added again and all good. Since all email, calendar entries etc... stored online nothing was missing.
     
  13. DavidC in Austin

    Rank:
    None
    Points:
    15
    Posts:
    1
    Joined:
    Feb 9, 2016

    Feb 9, 2016
    1
    0
    15
    Male
    This worked for me. I am using the Google Calendar app. I live and breathe with Google syncing. I was not using my calendar on my phone much so I started messing with adding some additional calendars using my PC. When I checked my phone the calendars were not there which I did not worry too much but was curious. On a tablet I seldom use without the Google Calendar app but a generic app that came with the device I did see entries from my other calendars so it made me think I was missing something on my HTC. When I did Craig's steps it worked. On my HTC One M8 the steps were slightly different: Settings -> Apps -> swipe to ALL screen...same steps.
     
  14. navynasa

    navynasa Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Feb 19, 2012

    Feb 19, 2012
    2
    0
    5
    Tech Support Analyst
    Virginia
    I don't know if this is only for my HTC M9, or this is Google calendar for basic Android (I'm updated to Marshmellow 6.0), but here's how I got the list of calendars I'm used to (when I look at the web version of Google Calendar)
    1. Open Calendar
    2. Open menu (3 dots on the upper right)
    3. Select "Accounts (Multi-Calendar)"
    4. Google Account should be there (other choices are "HTC Sync manager" and "people", but don't need those)
    5. Select the 3 dots menu to the right of the Google Account.
    6. Check or uncheck the calendars you would like to see
    7. Press "SAVE" at the bottom right of the list
    8. Give the phone time to sync (drag down while viewing one day forces sync, if you are impatient)

    Hope this helps someone.
     
  15. Megan L

    Megan L Lurker
    Rank:
    None
    Points:
    15
    Posts:
    1
    Joined:
    May 25, 2016

    May 25, 2016
    1
    0
    15
    Female
    I have tried every option here with both the default Calendar app and the Google Calendar app. I've also tried a force-sync app (Synker) as recommended in a different forum, as well as uninstalling and reinstalling, and trying different apps. Nothing works. Any suggestions to just select the calendar to sync aren't helpful, because the calendar is not even displayed in the list (yes, even if I click "show more.") Plus, it still lists old calendars that I deleted.

    There's been plenty of time to sync - I've had this problem for over a week. Pretty certain at this point my only choice is to go with the dreaded factory reset, unlinking my google account from my phone. Any other suggestions before I take the leap? Not sure it's worth it.
     
  16. Bananaktkt

    Bananaktkt Lurker
    Rank:
    None
    Points:
    15
    Posts:
    1
    Joined:
    Jun 26, 2016

    Jun 26, 2016
    1
    0
    15
    Female
    I was struggling with this and I finally solved it in my particular situation. I had more than one Google account on my new Nexus 6p phone...one for personal and one for business. I was trying to sync a new Google calendar that my wife has shared with my personal account. It was working fine on the computer but not showing up on my phone. I tried everything listed here except a factory reset. I thought that having two Google accounts in the phone might be messing with it so I deleted my business Google account from my phone. Everything showed up immediately after that. I was also able to add my business account back to the phone afterwards and everything is still showing up in my calendar app, yay!

    I went to the phone's settings, then to accounts. I clicked on my business account and pushed the 3 dot menu in the corner. I selected remove account. Then I went to the calendar app and was able to see my wife's calendar listed and click the check box to enable it. Then I back to phone settings, then accounts, and added my Google business account back to the phone. Checked the calendar and it now has everything.
     
  17. marko118

    marko118 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Oct 17, 2016

    Oct 17, 2016
    1
    0
    5
    Male
  18. squishy79

    squishy79 Lurker
    Rank:
    None
    Points:
    15
    Posts:
    1
    Joined:
    Oct 26, 2016

    Oct 26, 2016
    1
    0
    15
    Male
    This worked for me! The calendar I was looking for was simply hidden. Clicking the "Show More" option allowed me to select the calendar and turn on the Sync option.
     
  19. zapjb

    zapjb Well-Known Member
    Rank:
     #339
    Points:
    38
    Posts:
    141
    Joined:
    May 17, 2011

    May 17, 2011
    141
    13
    38
    SOLVED for me.

    I had to defrost the default calendar b4 Google Calendar would work fully. Who knew?
     
    #19 zapjb, Dec 7, 2016
    Last edited: Dec 9, 2016
  20. GillianM

    GillianM Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Dec 20, 2016

    Dec 20, 2016
    1
    0
    5
    HELP - this is driving me nuts...
    The calendars are recognised in the app on my galaxy 4 note - but there is no sync option. When I go into settings on the other calendars they have 2 sections about notifications and then an option to change the colour of the calendar items. They only apparent different with the calendars that appear but that won't sync is that there is no option to change the calendar option. The calendar did intially sync but then was not visible on the google calendar online.
    I have tried all install / uninstall options. There is no option to determine which calendars should sync in settings on the app - only the names of the calendars. The google calendar online does not show the options of these calendars - i am wondering if I have somehow hidden them from view online but on the settings it does not show they are there. Can anyone help??
     

    Attached Files:

  21. Matt Greene

    Matt Greene Lurker
    Rank:
    None
    Points:
    16
    Posts:
    1
    Joined:
    Dec 21, 2016

    Dec 21, 2016
    1
    1
    16
    Male
    I didn't see this solution listed yet.

    In my Calendar app (the stock one), a calendar that was shared with me wasn't showing up in the "Calendars to display" list from Settings. It took me awhile to find that the"Calendars to display" screen has yet another menu (top right menu button (three dots)). In there is "Calendars to sync". I just needed to go in to that list and check the calendar that had been shared with me. Then, when I came back to "Calendars to display", it was listed and I was able to check it.
     
    dah123 likes this.
  22. dah123

    dah123 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Jan 11, 2017

    Jan 11, 2017
    1
    0
    5
    Thanks Matt - none of the others worked for me but this did
     
  23. pbz

    pbz Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Jun 27, 2012

    Jun 27, 2012
    2
    0
    5
    My shared calendar with my husband had been set to view only for him, rather than manage and change. I think that's what made the difference. I changed his privileges so he essentially owned the calendar also. Doing this caused an email to be sent to him telling him of the change. Then I clicked on the link in the email, and it gave a message that continuing would open the desktop version on the phone. It asked if I wanted to open the phone app instead. I said NO just in case. On the desktop version, I could see the calendars, just as I could on his PC. I thought maybe I could import this calendar into his phone, so I exported it to a file. I then went into his calendar settings and clicked to refresh, and the calendar which had previously been in the category "Calendars I can only view" went into the "Calendars I can manage" box.
    Then I opened his phone's Google Calendar app, and the calendar was visible in the list you drag into view from the left, but not seen in the daily listings yet. Even though the drop-down arrows weren't visible next to the name of the calendars on the list, if you tap on the right side of the listing, it produced a 2 item menu which included "settings". Under that settings menu, was Sync, and I could toggle it on. Voila! The calendar items now appeared on his phone. I didn't need to import the calendar, and I'm not sure I'd have been able to find a way to do so anyway, so you can skip that step if this way works for you! Good luck! His phone is a Motorola Droid Turbo Maxx HD, so it does things a bit differently than my Samsung.
     
  24. Rich73nj

    Rich73nj Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Mar 23, 2017

    Mar 23, 2017
    1
    1
    5
    Same problem on my Samsung tab and my wife's S7. I just uninstalled the Google Calendar App and re-installed it from the play store. All the calendars showed up. Just needed to turn on the sync for each and then refresh.

    Not the best solution but got me where I needed(for now)

    Hope this works for some of you.
     
    mgg1959 likes this.
  25. BCTRB

    BCTRB Lurker
    Rank:
    None
    Points:
    15
    Posts:
    1
    Joined:
    Nov 25, 2017

    Nov 25, 2017
    1
    0
    15
    Male
    The calendar I wanted to see (shared by my wife) was not listed even after tapping Show More. I cleared the Google Calendar application data cache and resynced but that didn't help. As a last resort, I powered off my phone. When I powered back up, the shared calendar was in the list at the bottom. Then I could tap it and turn the option to SYNC ON.
     

Share This Page

Loading...