1. Are you ready for the Galaxy S20? Here is everything we know so far!

Adfree not working

Discussion in 'Android Devices' started by TeamTJ, Aug 10, 2010.

  1. TeamTJ

    TeamTJ Member
    Thread Starter

    I wiped my phone and installed Darchdroid 2.8 this morning.

    Now when I try to update Adfree Android's hosts, it gives me the following error:
    "Failed to remount system partition read-write"

    It worked on 2.8 before the wipe & flash.

    Anyone know what's up?

    Thanks!
     


  2. ccapasso

    ccapasso Android Expert

    Don't have that app. Does it require root access? If so, have you verified that another app you have that requires root access still works?
     
  3. TeamTJ

    TeamTJ Member
    Thread Starter

    It does require root.

    Forgive my ignorance, but how would I test if I still have root? How would I lose it?
     
  4. dpeeps74

    dpeeps74 Well-Known Member

    to check root, open terminal emulator and type "su". if you get a # prompt, you have root, otherwise it will say access denied or something. if you don't have root, you can just do the adb root method to get root back, at least that worked for me.

    if you still have root, superuser permissions likely needs to be reinstalled. you can search xda for su 2.2.2 and download and reinstall it (i think it's a flash file). i've also seen information saying you may need to delete superuser permission data, but i was just able to reflash the app and it ended up working.

    if all that fails you can try to nandroid back, or try reflashing again, being sure to wipe/factory reset.
     
  5. ccapasso

    ccapasso Android Expert

    You could have lost it by flashing the ROM. There is something with DarchDroid 2.8 where it is possible to loose root. If you did loose it you can always get it back :)
     

HTC Hero Forum

The HTC Hero release date was July 2009. Features and Specs include a 3.2" inch screen, 5MP camera, 288GB RAM, MSM7200A processor, and 1350mAh battery.

July 2009
Release Date
0
Reviews
Loading...

Share This Page

Loading...