1. Are you ready for the Galaxy S20? Here is everything we know so far!

Admire WiFi Issue (no other thread fixed it)

Discussion in 'Android Devices' started by Spitlord, Aug 15, 2012.

  1. Spitlord

    Spitlord Newbie
    Thread Starter

    I am trying to connect to a home network through wpa/wpa2 psk. I know I have the password right, and that the network is available.

    When I connect, it says "Connecting... Authenticating... Disabled..." and it asks me for a PW again.

    I am able to connect to other networks. I have not been able to find a fix for this besides people saying to Reboot the phone, and this does not work for me. Please, please, PLEASE help.

    Thx :p

    1. Download the Forums for Android™ app!


  2. That happen to me too. Its not your phone, its your router (also called a gateway) you need to unplug it for 15 seconds, plug it back in, and see if that works. Depending on your router, doing that may reset it to factory settings. If it didn't work, try finding the reset button on the router and pressing it for 15 - 30 seconds or whenever the lights flash or go off. If that didn't work, try updating your firmware. Also check and make sure a laptop or gaming system can connect to your wifi... And make sure its not on ad-hoc network mode.

    If none of that works, time to get a new router! Hope I helped!

    Edit: make sure you press 'forget' on your phone to make it forget the password first!

    Sent from my Samsung Admire Running OpenAndroid 2.3
    Spitlord likes this.
  3. Spitlord

    Spitlord Newbie
    Thread Starter

    Laptop connects, Ipod touch connects, other people's devices connect. If I reset the router am I risking anything?
  4. enigmadroid

    enigmadroid Android Enthusiast

    If you reset the router you'll only lose your password and any settings you may have set. What ROM are you running on your Admire? Does it connect to other wifi hotspots like coffee shop or Mickey D's? Have you tried toggling airplane mode, data, and wifi?
  5. smokescrack

    smokescrack Lurker

    I am having a somewhat similar problem. The router is fine, all other devices connect and I have reset the phone and router just to be certain. The phone wouldn't even pick up calls when it was activated and I have to be within 20 feet of a wifi source just to get minimal signal.
  6. Spitlord

    Spitlord Newbie
    Thread Starter

    Yes, I have tried all of those. I connect fine at other hotspots. I was running SPBShell3d but I went back to the stock rom. Still nothing. :(
  7. enigmadroid

    enigmadroid Android Enthusiast

    Check your router configuration and see how many clients are allowed. Most routers default is to hand out 50 internal IP's. Also check the channels and type, like a/b/g/n etc. What router do you have? Also make certain the security type, wpa-wpa2, aes, etc. is set on the phone. Hope this helps.
  8. fcm428

    fcm428 Lurker

    I just bought this Admire, and although I have it on WIFI, and have a home router it doesn't pick up wifi AT all, not even hotspots...SOMEONE PLEASE help...it's driving me crazy.... it shouldn't be that hard.
    Everything at my house connects, just not my phone...don't get it.....HELP!

Samsung Admire Forum

The Samsung Admire release date was September 2011. Features and Specs include a 3.5" inch screen, 3MP camera, GB RAM, processor, and 1600mAh battery.

September 2011
Release Date

Share This Page