1. Check out our companion app, Forums for Android! Download from Google Play

Support Adobe Flash Player 10.1 - working on your 8650 ? Any advice please?

Discussion in 'Android Devices' started by lcf1, Aug 24, 2012.

  1. lcf1

    lcf1 Member
    Thread Starter

    Jul 1, 2012
    Hello all

    If anyone can help - I have tried to resolve this myself for 8 weeks. No luck.

    Any of you out there got this tablet and able to watch short (or long!) videos on Youtube and other sites using Flash? I can't. I either get a green arrow, blue cube, blank box or nothing but a still jpeg image. Occasionally I'd get the loading animation circle on a black background but that's stopped too.
    I am using the tablet's default browser which for 1 day showed Youtube videos fine, browser set to Plugins always on, etc. I have also tried Opera etc, no success at all.

    I have a Wondermedia 8650 red/green LED - it is badged as a "Lark Freeme 70.0". When Adobe Player stopped working and there were a few other faults aswell, so the device was sent back under warranty to Lark and they repaired all the faults except the Adobe Player failure.

    When Adobe Player 10.1 stopped loading and I could no longer see Youtube etc, I uninstalled it, rebooted, and tried to reinstall it again from having downloaded the 10.1 apk from Adobe's website (apk file). But whenever I tried to reinstall it, it would commence installation but then say installation failed. I tried installing it from the root of an SD card, no improvement. (This SD card has other files on it too, such as my PDFs, photos etc, but has plenty of space, 500MB empty).

    The repairer reset the device and Adobe Player was again listed under Applications. (In fact, any user can reset the device and Adobe Flash Player will appear again in the Applications list of course, but it still does not load when needed such as to view videos on Youtube etc. Resetting the device means losing all newly downloaded programs and data).

    I read on another thread that 10.1 was an "evaluation copy" and may stop working. Can anyone explain further. If so, why would it not work again at all even from a device reset? How long was the evaluation copy supposed to work? Mine ceased after 1 day but did not tell me anything, ie no message saying "Evaluation - trial over" etc.

    Apologies for writing so much, but I just don't know how to shorten it.

    Main questions are:

    1. I have the Adobe Player 10.1 apk file on the device - how can I get it to successfully install? it won't so far
    2. If I do manage to install it but it still doesn't load again when needed just as before, what do I do? (Repairer and manufacturer take 4 weeks each time it goes to them and they don't fix that anyway and don't say why not.)
    3. If I root my device (not entirely sure what that means) will I have Adobe Flash Player 10.1 again?
    4. How can I back up all the programs I downloaded from Android Market so that if I send it to the repairer yet again I don't lose those programs when they do their reset or reconfiguration there (last time I lost all my downloaded Market programs after the repairer returned the device)


    Specs below - everything is working fine except Adobe Flash Player

    Lark Freeme70.0 which is a rebadged Wondermedia 8650

    red/green LED, 7" TFT LCD screen 800x480 px
    CPU VIA 8650
    Android 2.2
    256MB RAM, 2GB flash mem
    access to Google Android Market (but not Play)
    Box says "plays video files MP4, ASF, WMV, AVI, DIVX"

    From About Device:
    Model Number Wonder Media WM8650
    Android version 2.2
    Kernel Version
    Build number generic-eng2.2 Froyo Ver1.5.5-20110920.083830

    No problems with it except the usual failry short battery life, and lack of a working Adobe Player 10.1 and now the inability to reinstall it for a reason I don't understand

    PS This thread http://forums.adobe.com/message/4087256
    says that the tablet only ever came with Flash 10.1 evaluation version but that it doesn't stop working, it just nags. My tablet never had that nag, but then Flash 10.1 stopped working after just one day. Anyone even know where I can get Adobe Flash 10.1 Evaluation version from in case that one installs and works?


  2. lcf1

    lcf1 Member
    Thread Starter

    Jul 1, 2012
    OK, I have found the solution myself, or near as I can to one.

    One of you on another thread here tipped me off that it should be an evaluation version of 10.1, not just 10.1

    Therefore, did a search and this page shows you how to install the evaluation version (someone in the UK has kindly set up a page for retailers to refer to, a big thank you to them!)

    8 weeks of frustration ended, and hopefully others Googling the web will find this solution fast.

    Test and mine is now playing most Youtube videos (probably won't play all of them if they are too new, I'm not sure)


    Spoke too soon, not resolved. It played two videos then back to square one, even with those same videos. Getting blue cubes again. Will try uninstalling it, rebooting and reinstalling. If that doesn't work, will look for caches/data to clear in either the browsers or other software and see if clearing those works, like it does when I clear the cache for Market to re-enable the ability to download apps. Will update here if any progress.

    update 1 (all testing using stock browser called My Browser as don't have any other Flash-capable browsers available to download, Youtube HQ off)
    Got it working on some videos again by doing a force stop on My Browser via Manage Applications. Certainly won't play all videos, perhaps if they were made for newer Flash versions. Not sure how a user can tell which Youtube videos will play other than by trying them.
    (Note - when it does play a video can take at least 7 seconds to start playing it)

    update 2
    Some videos on Youtube - clicking for them to start results in them loading and then without any user intervention they do not play and the page reverts to YouTube Home.

    update 3
    Using the force stop method, managed to play another shorter video from YouTube, loading time was 4 seconds. However, it would not then play again when I pressed for a replay. Refreshing the page then led to a blank window of blue in the browser. Seems very ropey at the moment.

    update 4
    Getting "invalid response received" or "Taking too long to load?" messages presumably from Youtube on occasion

    update 5
    Best results for getting a video to load from Youtube
    i. Close My Browser and do a Force Stop via Applications->Manage Applications
    ii. Start My Browser again
    iii. Go to Youtube, search for the videe you want via text search and select it from the thumbnail, pressing the arrow on the screen if your Plugins are set to "On Demand"
    iv. If it won't play, try another user's upload of the same video

    Must stress that at the moment I can't say it's solidly reliable, and it is tedious to keep going and doing a Force Stop all the time and reloading My Browser. It might be that clearing the cache/data on My Browser would also work or help more, but that also clears bookmarks etc from My Browser. I was unable to find a program that worked and memorised my bookmarks so I try not to use Clear Cache etc (also accessed from Manage Applications)

    Am also wondering if I get more reliable Player use/activation with the battery nearer full charge or plugged in to the mains power.

    Note the videos play completely jerk-free, smooth, no problems at all, when they play.
    EG Just played Timbalake/Carey/Rosette's "Amnesia" from two different uploaders - absolutely fine. [uploader: Dragseba99] 4/5 videos I got playing didn't even stop to continue downloading - which is better than my laptop!! Weird, it's the same connection except my laptop uses ethernet and the tablet wi-fi.

    But then the very same video then won't play!

    So either the Force Stop does some good, or it's perhaps a case of the device not having enough memory to reliably work continually between loads of data. I recall that usually erratic results are sometimes low memory issues.

    update 6
    Have just done another Force Stop and going back to Amnesia (appropriately named!) to see if the same video that played before then didn't play will now play again. No, Dragseba99's didn't this time, but another upload of Amnesia by someone with a name in Cyrrillic letters did ('TV' in a circle logo top right of screen).
    However, Lana Del Rey's Videogames (her own upload and the vevo ones) won't load and sometimes when I click for it I am returned to the home page automatically - that's even with the Force Stop technique.
    Then Amnesia wouldn't play again, etc!

    So it is a bit of a head scratch. Might be something to do with the cache or memory.

    Lot of patience needed - or just buying a better tablet. In which case, a thorough test in the shop on their wifi viewing lots of videos, closing the browser, then viewing more - all necessary before sinking your money into another tablet. And of course, something else might then be wrong with the new one. On the plus side, this does most things quite well and my home wi-fi works faultlessly with it since it came back from the repairer. Videos play very smoothly. I guess for a cheap device, I will stick with it for now as its eccentric behaviour is usually just limited to the Flash Player side of things and it performs well on the rest.

    If I find out how to get Flash 10.1 to always work without hassle, I will post.

    update 7
    Cleared the browser cache and date, has NOT helped.
    A clear of the cache etc means the UA string and other options reset.
    (The UA string should be set to "Android", Plugins on.)
    Tried Skyfire 2.3 and 4 - it hangs, and won't start
    NextVid won't play any YT videos although as a program seems good
    Tonight I have been unable to get the device to play ANY YT videos!
    Sort of kinda back to square 1 or 1A!

    Did a Force Stop again and got some videos to play - the same videos
    that wouldn't play earlier. However, some videos such as Videogames on
    YT still don't play.

    Am thinking it might be a case of the hardware being short of the necessary spec - memory or chip. It could be that when there is enough memory available, Flash will load. Otherwise not.
    Closing as many other programs as possible might be they key to getting Flash to work.
    I'm not sure the 256MB RAM DDR2 in this unit is enough. Not sure if it can be done, but a swap file to boost the memory may help. If I get anywhere, I'll update again. Right now, the best I have is erratic results - sometimes it works and sometimes not.

    AFAIK Android is Linux-based, so these might be the minimum requirements for Flash 10.1 Evaluation (or 10.1) to work reliably on a device, info from Adobe's website


    • 2.33GHz or faster x86-compatible processor, or Intel Atom 1.6GHz or faster processor for netbooks
    • Red Hat
  3. lcf1

    lcf1 Member
    Thread Starter

    Jul 1, 2012
    Might be worth mentioning, got my ZTE MF112 dongle to connect to this unit through the adaptor, using the Play network. Easy. (Screen might say something like 'broser cannot connect as no network connection' when you use the dongle and open the browser, but it still works if you go to a website.)
  4. lcf1

    lcf1 Member
    Thread Starter

    Jul 1, 2012
    Tried a tablet with 512MB (different brand) in a shop. Couldn't get any VEVO Youtube video to load! Seems some on YT won't play even on a tablet with more memory. Perhaps they need 1GB RAM!

    A friend suggested it could be that a mobile device needs to login to YT before viewing VEVO content, guessing really, don't know. If anyone finds out, please post.

Share This Page