1. Download our Official Android App: Forums for Android!

Ads not showing

Discussion in 'Android Development' started by 23tony, Aug 15, 2019 at 8:24 PM.

  1. 23tony

    23tony Well-Known Member
    Thread Starter
    Rank:
     #137
    Points:
    83
    Posts:
    183
    Joined:
    Mar 26, 2019

    Mar 26, 2019
    183
    67
    83
    Programmer
    Raleigh, NC
    I just changed my ad unit key from the test key to my real one. On the emulator I get a log message "request sent from test device" and then "App not loaded". That's not surprising on an emulator.

    But when I generate an APK and install that on my phone, I get a blank space, no ads loading.

    How do I test that REAL ads are working correctly?
     

    Advertisement

  2. mcpixel

    mcpixel Newbie
    Rank:
     #659
    Points:
    15
    Posts:
    13
    Joined:
    Jul 13, 2019

    Jul 13, 2019
    13
    0
    15
  3. 23tony

    23tony Well-Known Member
    Thread Starter
    Rank:
     #137
    Points:
    83
    Posts:
    183
    Joined:
    Mar 26, 2019

    Mar 26, 2019
    183
    67
    83
    Programmer
    Raleigh, NC
    It seems that the problem isn't just one phone. Half dozen devices, no ads.
     
  4. 23tony

    23tony Well-Known Member
    Thread Starter
    Rank:
     #137
    Points:
    83
    Posts:
    183
    Joined:
    Mar 26, 2019

    Mar 26, 2019
    183
    67
    83
    Programmer
    Raleigh, NC
    Just found this:
    https://forum.unity.com/threads/admob-no-fill.644416/

    Relevant part
    I found some debugging steps that I followed that also led me to a similar conclusion. Looks like I need to wait for my app to be approved before seeing anything.
     

Share This Page

Loading...