1. Download our Official Android App: Forums for Android!

After Lollipop Update: Exchange server contacts not synchronising

Discussion in 'Android Devices' started by Hopk1ns, Nov 27, 2014.

  1. Hopk1ns

    Hopk1ns Lurker
    Thread Starter
    Rank:
    None
    Points:
    6
    Posts:
    9
    Joined:
    Feb 24, 2014

    Feb 24, 2014
    9
    2
    6
    A new, more specific thread, following my original query:

    http://androidforums.com/threads/af...r-lollipop-contact-phone-numbers-gone.884035/

    After updating my Nexus 4 to Lollipop, the phone seems unable to sync contacts with an Exchange server. I have only one Exchange server account, sync'ing Calendar, Contacts and E-mail. The phone reports that all three are synchronising and I receive no error messages. The Calendar and the E-mail appear to be working fine - it is only the Contacts which are not sync'ing. All of the names remained on my phone (perhaps because WhatsApp created a field of its own with a copy of the phone number). However, all details stored on the exchange server, including the Telephone Number fields, have disappeared from all contact names. Creating a new contact either on Exchange or on the phone does not sync to the other.

    Any suggestions?
     

    Advertisement

  2. mvd_mvd

    mvd_mvd Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Nov 28, 2014

    Nov 28, 2014
    2
    0
    5
    here same issue.
    Also no exchange contacts in whatsapp.

    Anybody with a solution?
     
  3. mvd_mvd

    mvd_mvd Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Nov 28, 2014

    Nov 28, 2014
    2
    0
    5
    here same issue.
    Also no exchange contacts in whatsapp.

    Anybody with a solution?
     
  4. Hopk1ns

    Hopk1ns Lurker
    Thread Starter
    Rank:
    None
    Points:
    6
    Posts:
    9
    Joined:
    Feb 24, 2014

    Feb 24, 2014
    9
    2
    6
    Glad it's not just me! Does anyone use Exchange for contacts and *not* have this problem?
     
  5. Hopk1ns

    Hopk1ns Lurker
    Thread Starter
    Rank:
    None
    Points:
    6
    Posts:
    9
    Joined:
    Feb 24, 2014

    Feb 24, 2014
    9
    2
    6
    I appear to have worked around this problem by removing the Exchange account, restarting the phone and adding the Exchange account again. When I did so, I synchronised contacts first, then turned on calendar sync, then e-mails. It appears to have worked. I do not know if the restart or the sequential activation of contact/calendar/mail sync was necessary. I will keep an eye on this and report back if there is any further unusual behaviour.
     
    peanut1965 and codesplice like this.
  6. peanut1965

    peanut1965 Lurker
    Rank:
    None
    Points:
    15
    Posts:
    2
    Joined:
    Jan 12, 2015

    Jan 12, 2015
    2
    0
    15
    Male
    Luton
    I done the same as you mate...no help from google support. They had no idea how to put it right.
     
  7. Societech

    Societech Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Feb 3, 2015

    Feb 3, 2015
    1
    0
    5
    Hey Guys,

    I have the same problem using Exchange with Nexus 4 Lollipop. But in my case, changes of contacts are synchronised from Exchange to my phone. But when I change a contact on my phone, the change is not synchronised to exchange. Does anybody face this issue too?
     
  8. shayesbrownstonepark

    Rank:
    None
    Points:
    15
    Posts:
    1
    Joined:
    May 5, 2015

    May 5, 2015
    1
    0
    15
    I just upgraded to Lollipop and it wiped all my contacts out. not just from the phone but on my exchange server also. It didn't delete them from the server because we would see that, the server thinks they have been moved but we cant find them. 500 CONTACTS GONE. can anyone help?
     
  9. NPC

    NPC Newbie
    Rank:
    None
    Points:
    26
    Posts:
    10
    Joined:
    Mar 20, 2015

    Mar 20, 2015
    10
    2
    26
    Male
    Any luck fixing this? This is exactly what is happening to me. Exchange syncs no problem down to phone, but creation/edits of contacts are not synced back up to the server. Deleted/recreated account and still happens.

    Android 5.1, Droid Turbo.
     
  10. LunaRhyane

    LunaRhyane Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Oct 5, 2015

    Oct 5, 2015
    1
    0
    5
    Your issue may be that when adding contacts to your phone, it is adding them to the phone or other account by default and not your exchange.

    I was having the no contacts syncing at all, but maybe this will fix your back to server issue....

    Was having the same issue, Exchange 2003 and android turbo.
    We upgraded to Exchange 2013 and the problem persisted.
    My steps to fix it:
    1. Remove account from phone
    2. shut phone off
    3. log into owa
    4. Owa settings - remove phone from list of devices.
    5. turn on phone
    6. Add account back to phone.
    7. Contacts synced.

    I had tried removing the account from the phone, and then adding it back and still had same behavior with exchange 2003 and 2013. I think the key for me was removing the device from the owa and shutting phone down (not the exchange upgrade).

    Hope it helps!
     
  11. NPC

    NPC Newbie
    Rank:
    None
    Points:
    26
    Posts:
    10
    Joined:
    Mar 20, 2015

    Mar 20, 2015
    10
    2
    26
    Male
    Still having the issue, but I will try your fix. I am in the process of upgrading to Exchange 2013 this week actually.

    I also wondered if there could be some corruption on the phone, as this user had the Verizon store transfer all his settings from a really old Droid 4 to this new phone. There are corrupted calendars on there too. My plan was to do a factory wipe of his phone, and connect everything from scratch. I will make sure to delete the device partnership in OWA as well. Thanks for the advice!
     
  12. Maximillian

    Maximillian Newbie
    Rank:
    None
    Points:
    15
    Posts:
    11
    Joined:
    Aug 19, 2011

    Aug 19, 2011
    11
    0
    15
    Seattle, WA
    Thank you SO MUCH for taking the time to post this. I was having this problem and it was driving me NUTS because after the upgrade, a whole bunch of contacts in Outlook were no longer showing up on my Droid Turbo. I had done all the steps except 3 & 4. Now that I did those steps, all of the contacts are back on my phone and it looks like things are syncing again. THANK YOU!
     
Tags:

Share This Page

Loading...