1. Download our Official Android App: Forums for Android!

Support alarm clock failed me again today!

Discussion in 'Android Devices' started by rainmanne, Feb 24, 2010.

  1. lekky

    lekky Lover
    Rank:
    None
    Points:
    413
    Posts:
    5,231
    Joined:
    Oct 29, 2009

    Lol sorry, get lots of people blaming the phone for things like that :p
     

    Advertisement

  2. MindTrainer

    MindTrainer Newbie
    Rank:
    None
    Points:
    18
    Posts:
    33
    Joined:
    Feb 3, 2010

    Feb 3, 2010
    33
    11
    18
    My Hero woke me an hour early this morning. Unfortunately I didn't realize the time was wrong until I got to work an hour early (5:00 AM) ouch!

    It happened only once before (clock was off an hour last night too). Both times I shut off the phone removed the battery and rebooted and the time was corrected.

    No Task Killer installed here. But I did install this new app yesterday "Floating Image" it's very cool and will float pictures across the screen. I think maybe this program used up all my cache memory.

    If anyone has any suggestions please let us know. We all want to be able to use and TRUST our phone alarms. Thank you.
     
  3. MindTrainer

    MindTrainer Newbie
    Rank:
    None
    Points:
    18
    Posts:
    33
    Joined:
    Feb 3, 2010

    Feb 3, 2010
    33
    11
    18
    I found my problem. Had to call HTC 3 times twice they told me to do a hard reset (would not have helped). The problem was that the time zone on the computer didn't match the time zone on the phone. When synced the phone added an hour and kept it.
     
  4. stevemorton

    stevemorton Lurker
    Rank:
    None
    Points:
    6
    Posts:
    1
    Joined:
    Jan 20, 2010

    Jan 20, 2010
    1
    1
    6
    Re: alarm staying 'silent', I suffered this for the past 3 weeks, tried everything above except factory reset (wanting to avoid many hours reloading software, customizing phone etc); then I found this advice on another site, and cured the problem!
    Fixing a Silent Alarm on HTC Hero Chris Bunney

    I had *not* expected the alarm to have its own volume setting; when I adjusted the volume control while selecting the alarm ringtone it came up from 'no sound' (but not 'silent') and then worked fine.

    Overall I like my Hero but sometimes it's too clever for its own good...
     
    Jille likes this.
  5. Dem

    Dem Well-Known Member
    Rank:
    None
    Points:
    56
    Posts:
    213
    Joined:
    Aug 15, 2009

    Aug 15, 2009
    213
    5
    56
    Sales Manager - Automotive Systems
    London
    Mine still randomly decides when to work and it's not the alarm volume or taskiller.
     
  6. rainmanne

    rainmanne Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    47
    Joined:
    Dec 22, 2009

    Dec 22, 2009
    47
    1
    16
    Oops, it did it again! Actually it happened two days in a row. The clock stops during the night and the alarm does not go off. I think that it is a combination of running a paused audiobook player and probably silent email notifications. Maybe something else. I've recently updated to 2.1 and hoped that this problem would be gone. Apparently not.
     
  7. noddle

    noddle Member
    Rank:
    None
    Points:
    16
    Posts:
    81
    Joined:
    Feb 5, 2010

    Feb 5, 2010
    81
    2
    16
    UK
    I had the same problem yesterday for a reminder of my tablets and I don't kill my apps. I checked the sound and seems fine and also tested the alarm and seems to work. On 2.1 and thought that this would have not been a problem anymore.
     
  8. rainmanne

    rainmanne Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    47
    Joined:
    Dec 22, 2009

    Dec 22, 2009
    47
    1
    16
    I'm now pretty much sure that the problem is caused by a combination of a paused audiobookplayer and a silent email notification arriving when the phone is locked. For some reason it makes the clock stop. When I unlock my phone this morning the clock (not the widget but actual clock in the upper right corner of the screen) was showing 1.34am. It got updated in a couple of second.
     
  9. Darkplek

    Darkplek Member
    Rank:
    None
    Points:
    16
    Posts:
    61
    Joined:
    Jul 11, 2010

    Jul 11, 2010
    61
    4
    16
    I have this exact problem with the Samsung Galaxy S... The clock stops updating overnight, when the phone goes to sleep, so my alarm never goes off :( Then it updates after a couple seconds when you turn the screen back on.

    I don't use a task killer. Nor do i have a paused audiobook. And my phone is on airplane mode overnight so there are no email notifications. I think the problem is somewhat deeper, and android related, not phone-specific =\

    If anybody can find a fix for this i will love you forever (figuratively).
     
  10. rainmanne

    rainmanne Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    47
    Joined:
    Dec 22, 2009

    Dec 22, 2009
    47
    1
    16
    Interesting. I always blamed sound management problems. I think the clock works on the hardware level (like in BIOS in a PC). Probably the alarm is set on the software level (unlike in Nokia phones for example where it goes off even if the phone is switched off). The thing is it does not look like a wide-spread problem. Probably some other appication causes it. I've got Advanced Task Killer installed but it does not kill anything automatically. Is there any way to identify the cause of the problem? Something like looking in some logs?
     
  11. Darkplek

    Darkplek Member
    Rank:
    None
    Points:
    16
    Posts:
    61
    Joined:
    Jul 11, 2010

    Jul 11, 2010
    61
    4
    16
  12. Diamond-Geezer

    Rank:
    None
    Points:
    15
    Posts:
    25
    Joined:
    Nov 8, 2009

    Nov 8, 2009
    25
    0
    15
    United Kingdom
    Every night before bed you need to go into the alarm and set the ringtone and press ok. It will then tell you when in hours it will ring. Don't mess about with the volume (i.e. mute) after it has been set.

    I do this every night and the alarm never fails me.

    I don't use a task killer.
     
  13. noddle

    noddle Member
    Rank:
    None
    Points:
    16
    Posts:
    81
    Joined:
    Feb 5, 2010

    Feb 5, 2010
    81
    2
    16
    UK
    I was just wondering do you have the date and time on automatic?
     
  14. tool

    tool Lurker
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    Jun 14, 2010

    Jun 14, 2010
    4
    0
    5
    everyone is quick to blame task killer apps but i dont trust the phone alarm and i dont use a task killer.
    i have posted prev about my alarm not going off and i think its a genuine bug not a person fault.
    at the mo im using a back up alarm as i cycle to work and its a 40 min ride,so cant afford to sleep in.looks like we'll have to keep fiddling for a solution.
     
  15. Darkplek

    Darkplek Member
    Rank:
    None
    Points:
    16
    Posts:
    61
    Joined:
    Jul 11, 2010

    Jul 11, 2010
    61
    4
    16
    I'm kinda with tool on this one... because I really can't think of any volume or setting that could be wrong with my setup. Although why most people have no problem at all is beyond me, in this case.

    noddle, nah I've tried it with it on automatic, and then tried it without. Both failed to set off the alarm.

    Diamond-Geezer, thing is, since it keeps failing, every time i do set it up it is directly before i go to bed :p and it says how long until it should go off. And the (alarm) volume is set near max so i cant imagine that would be the issue either.
     
  16. Darkplek

    Darkplek Member
    Rank:
    None
    Points:
    16
    Posts:
    61
    Joined:
    Jul 11, 2010

    Jul 11, 2010
    61
    4
    16
    Has anybody else noticed the time lag, from when you turn it on in the morning after it being on all night? Like the time is wrong for a second or two, then updates.

    Or if you haven't noticed, look out for it tomorrow morning and report back? :p
     
  17. tool

    tool Lurker
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    Jun 14, 2010

    Jun 14, 2010
    4
    0
    5

    yep.i seen this..how is an alarm set for blah blah blah supposed to go off when the phone thinks its still 1.30 am?
     
  18. noddle

    noddle Member
    Rank:
    None
    Points:
    16
    Posts:
    81
    Joined:
    Feb 5, 2010

    Feb 5, 2010
    81
    2
    16
    UK
    Would be best If the time is updated every 15 min and don't wast allot of battery because it sounds like it works most of the time and could get stuck.
     
  19. rainmanne

    rainmanne Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    47
    Joined:
    Dec 22, 2009

    Dec 22, 2009
    47
    1
    16
    I have added my star to the issue. In the meantime I have updated to 2.2 (using FroydVillain ROM) so we'll see if the issue persists.
     
  20. Laharl

    Laharl Newbie
    Rank:
    None
    Points:
    36
    Posts:
    47
    Joined:
    May 9, 2010

    May 9, 2010
    47
    9
    36
    I use digital alarm by notes from the market place it never lets me down and its a free app and you can set ringtone or set mp3 as the alarm sound.
     
  21. justinclarke

    justinclarke Newbie
    Rank:
    None
    Points:
    15
    Posts:
    23
    Joined:
    May 26, 2010

    May 26, 2010
    23
    0
    15
    There is this bug report too for the same issue:

    Issue 9524 - android - [Alarm Clock] Alarm doesn't get triggered as per scheduled, triggered only when phone gets turned on manually after alarm set time! - Project Hosting on Google Code

    It's definitly not a problem with a task killer killing the service / app as the majority of users don't have them installed as you can see from reading the 2 bug reports. If however, you do have a task killer then not adding the Clock to the ignore list will cause the same symptoms! But this issue is an issue with Google and the Clock app or their OS.

    It's been happening for a year and still no solution / work around from Google. It's a pretty annoying bug! C'mon Google..!!
     
Tags:

Share This Page

Loading...