1. Check out our companion app, Forums for Android! Download from Google Play

Aldiko / SD problem

Discussion in 'Android Devices' started by Hemmers, Sep 11, 2010.

  1. Hemmers

    Hemmers Guest
    Thread Starter

    Having a bit of a confusing issue with Aldiko and eBooks.
    I've got an apad, although I can't lay my hands on the spec just now. Pretty sure it's a VIA CPU not the RockChip. It's got a resistive screen and is running 1.7.4.

    Anyway, two issues.

    The first is that when I wake it up from hibernate, it tells me the SD card has been removed unexpectedly and tells me off for not unmounting it properly.
    This is annoying, but I can just take it out and put it back in, or just reboot and it fixes it. But it's a bit annoying, so is this a known problem and is there a work around?

    Secondly, and this may or may not be related, I mainly use it for eBook readeing, and have been using Aldiko.
    I've been getting a lot of books off Feedbooks, which is fantastic.

    Unfortunately, sometimes I download a book, and even though it's definitely visible in the file browser, and I've maybe read a few pages, when I come back to it, after a reboot or even just after the screen has shut off (power save, NOT going to full hibernate), I get the "book not found, please check your SD card", and lo and behold, the file has disappeared from the card.

    The immediate reaction would be a hardware issue with the card or port, but it's more complicated than that. Some books sit quite happily and don't "self-destruct", but then most - even by the same author - seem to self-delete. The file is gone. The SD card is behaving normally and no other data seems to be missing - as you would expect if it were a hardware or OS problem. It's select Aldiko books.

    For instance, I had an HG Wells book there. I downloaded another, and the file appeared - as it should - in the HG Wells folder next to the first book I downloaded. I read a couple of chapters, turn it off, come back to it later, and the file's gone, along with with 2 other books I downloaded. But the original HG Wells books is still there :thinking:
    I'm just baffled.

    Can anyone explain why some books are being deleted? They're still present in the Aldiko bookshelf (i.e. the db listing hasn't been edited, which suggests it's not Aldiko deleting them), just the files themselves deleted from the eBook folder on the SD card. Plenty of space on the card. It's really confusing. They're there - I check after each download and the files are there. Then later on they're gone :thinking::thinking:

    EDIT: I gather there can be issues with SD cards corrupting. Wouild it be worth ripping the contents of the SD card to USB/my laptop, and reformatting the SD card in case it's just a bit of corruption, then restoring my files back to it. Would that likely solve this issue of new files randomly disappearing? Is it possible they're all being written to a corrupt sector or something?


  2. Podivin

    Podivin Well-Known Member

    Nov 29, 2009
    Jacksonville, Fl
    I believe I'd start with uninstalling and reinstalling Aldiko. I use Aldiko a LOT (I have about 300 books on my phone) and I've never had it do this kind of thing to me. I'm currently using the paid version of the app, but I used the free version for several months - they both have worked just fine for me.

    Next thing I'd try is to mount you phone to your PC and do a windows search on the drive that is your SD card, to see if Windows can find the missing file. I'm wondering if they have been moved to someplace they shouldn't be. I can't imagine why this would happen, but it can't hurt to check.

    If neither of those things works, then reformatting the SD card is the last thing to try (or try using a different one if you have one available to you). I'm not sure that SD cards can have a bad sector like a regular hard drive can. Lacking a hard drive's platters, they also lack sectors - but there could be a digital equivalent.

    Slightly off topic, Aldiko can read any epub file, so you can download books from places other than those sites built into the app. You may also want to look into a PC program called Calibre for converting ebooks into epub format for use in Aldiko.
  3. Hemmers

    Hemmers Guest
    Thread Starter

    Cheers for that. Having googled, I'd guessed it wasn't Aldiko or there'd be a lot more people howling on forums.
    I've got Calibre, and will be putting some PDFs and other books I've got across to ePub.

    I only have the one microSD card available (it came with the tablet), but as it's only 128MB, I've got an 8GB card coming, which comes with an SD adaptor, so I'll be able to plug it into my card reader and browse on my desktop.
    Not sure why it would move these files to another folder - as I say, when it downloads, it puts them in the correct place and they sit there until it goes to power-save or I turn it off. With the amount of times I've re-downloaded stuff, the card would probably be full by now if it was just moving files rather than deleting! I'll have a hunt through though and make sure.
    I'm thinking more likely that it's hit on a corrupt point on the SD drive and as I've not tried to put anything else on, it keeps saving material to the one corrupt block and not moving on past it to fully functional memory. Odd, but I can't think of anything else.

    Sector is perhaps the wrong word, but I was under the impression the storage space on a flash drive was still organised into some sort of block structure, and individual areas can fail without failing the entire flash chip (i.e. corruption of individual cells or blocks).


Share This Page