1. Download our Official Android App: Forums for Android!

General All my contacts lost and won't recognize contacts via Gmail synch

Discussion in 'Android Devices' started by miamicuse, Jan 14, 2014.

  1. miamicuse

    miamicuse Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    21
    Joined:
    Aug 29, 2013

    Aug 29, 2013
    21
    2
    16
    Miami, FL
    Phone: HTC ONE S
    Android 4.1.1
    HTC Sense 4+
    Software Number 3.14.531.17710RD

    I had all my phone contacts entered manually in phone memory, was going to save to SIM and backed up but never got around to it. My bad.

    Last week my phone had an alert for some security update. I was home and said why not, and when the update was completed all my contacts except two were gone.

    After that I decided may be I need to do a better job of managing my contacts. I decided to do it via gmail. I noticed that gmail allowed contact importing via CSV files.

    So I created a Microsoft Excel spreadsheet of all my contacts. Name, phone, email etc...and I exported it to a CSV file with the first row acting as labels. Logged into my gmail and imported the CSV file. They came in just fine under My Contacts as a separate folder named "Imported 1/14/14". So question #1 is, is there a way to move these imported contacts under "My Contacts" and not nested one level below? I am thinking this may be part of my problems.

    Now once these contacts are in gmail. I went to my phone and drilled down to Settings -> Personal -> Accounts & Sync -> Google, then select my gmail account (I have a Google Voice account which I wish to keep the contacts totally separate). Once the synch was completed if I go into the phone's "Contacts" I see the full list of contacts I had in gmail. So that good news.

    However, the phone doesn't seem to want to recognize these contacts.

    I had call history, text messages, whatsapp conversations and the phone numbers on these did not "revert" to show the contact names these numbers were associated with prior to my losing all my contacts. Right now all the calls still showed the numeric phone number.

    I had one of my contacts called me, I do not see the contact name showing up, only the 10 digit phone number. So these contacts from gmail are not recognized by the phone.

    I went into the "Contacts" app again, and if I am on the "People" tab I see all my contacts listed. If I go to the "Groups" tab I see a group called "Imported 1/14/14" and all the contacts are under there. Is this why these contacts are not recognized?

    Do I need to go to Manage Contacts on the phone, to export these contacts to the phone storage or SIM card before they are recognized? What am I doing wrong?
     

    Advertisement

  2. iowabowtech

    iowabowtech root@android:/ #
    Rank:
    None
    Points:
    1,493
    Posts:
    12,183
    Joined:
    May 2, 2010

    May 2, 2010
    12,183
    8,681
    1,493
    Making the Establishment nervous
    Iowa|USA
    It's been a long time since I've had to do this since my last 2 phones have used Google contacts as the default. So I'll give my best recollection until another One S user can come along and set things straight. :D

    I think if you get that .csv file onto your phone's sdcard, you can then go into your contacts app and import that, and I think there's an option to "convert to Google contacts" if I remember right. Or choose that as the default contact type if prompted upon the import.

    I don't think the One S has a physical sdcard, that's fine. Just put that .csv on the chunk of internal memory that serves as your sdcard.

    If all that works, you may end up with duplicate google contacts. If so, logon to your Gmail account via a PC if possible (easier to manage things), click on the "contacts" button there and I think there's an option to remove duplicate contacts. That may not even happen, not positive.
     
    agentc13 likes this.
Tags:

Share This Page

Loading...