1. Download our Official Android App: Forums for Android!

Support Always enable WiFi - Hanging issue

Discussion in 'Android Devices' started by Wyctafitrti, May 29, 2011.

  1. Wyctafitrti

    Wyctafitrti Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    May 13, 2011

    May 13, 2011
    4
    0
    5
    I am new to the Android family. Maybe someone here can show me how to debug the following problem I have with my Android enabling and keeping the wifi switched on.

    I have myself a Samsung Galaxy ACE s5830 which I got just few days back and had found this problem where the phone just displayed error while switching on wifi. I then restarted the phone and found that wifi was working fine. After this I began noticing that the phone occasionally (two or three times a day) got hung up with a blank screen while the keypad is locked. This happens while the phone is getting charged and during idle time. When I tried unlocking the keypad, the phone do not respond. I would then have to disconnect the battery or press and hold the power key for 10 seconds to bring my phone back to life. However, I can see that if I switch off wifi, the phone does not get hung up in this manner.

    I appreciate any help to get this issue resolved. What I basically need is to always enable wifi at my home so that I will be connected at all times.
     

    Advertisement

  2. aktifit

    aktifit Member
    Rank:
    None
    Points:
    18
    Posts:
    99
    Joined:
    May 24, 2011

    May 24, 2011
    99
    10
    18
    to fix the dead screen, just never let wifi go into sleep mode, there doesn't seem to be any other solution for now. to do that go settings->wireless & networks->wi-fi settings, press menu there->advanced->wi-fi sleep policy->never
    i read that this bug will get fixed in gingerbread update but i guess we'll find out soon

    i don't know how to fix the wifi error problem though and i have it too, so anyone else got an idea?
     
  3. Wyctafitrti

    Wyctafitrti Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    May 13, 2011

    May 13, 2011
    4
    0
    5
    Hi aktifit,
    Thanks for the tip, but for me, it seems to be occurring even after putting it to 'Never'. I guess the only option is to upgrade from froyo to gingerbread.

    I am afraid, this might indicate also a hardware issue but I dont know how to diagnose.
     
  4. bansalanshul

    bansalanshul Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    May 29, 2011

    May 29, 2011
    1
    0
    5
    I have exactly the same issue with my new Samsung Galaxy Ace. Are there any ways to debug this? Or are there any solutions available?

    -Anshul
     
  5. pujitjuneja

    pujitjuneja Well-Known Member
    Rank:
    None
    Points:
    53
    Posts:
    234
    Joined:
    Apr 9, 2011

    Apr 9, 2011
    234
    72
    53
    Developer-to-be ;)
    Delhi, India
    When you get this error with your WiFi, just dial *#526# on your dialer and you will see a screen saying 'loading driver'
    On completion the screen will show driver loading successful, after that just switch on your Wifi and it will work fine.
    If it shows unsuccessful, then i'm sorry you will have to restart..
    Don't worry, thi9s is going to be fixed in the gingerbread update.
     
    smsgAce likes this.
  6. smsgAce

    smsgAce Newbie
    Rank:
    None
    Points:
    36
    Posts:
    30
    Joined:
    Jun 28, 2011

    Jun 28, 2011
    30
    3
    36
    Thank you pujitjuneja! It worked for me:D. I seen it somewhere else as well but it was longer. Anyway that one was not recognised by the phone. This was one of the most annoying bugs I had with my phone
     
  7. malick30

    malick30 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Jun 30, 2011

    Jun 30, 2011
    1
    0
    5
    does this fix also works on galaxy tab?
     

Share This Page

Loading...