1. Are you ready for the Galaxy S20? Here is everything we know so far!

Am I right in thinking my phone is not rooted properly

Discussion in 'Android Devices' started by spiderplant0, Sep 5, 2013.

  1. spiderplant0

    spiderplant0 Newbie
    Thread Starter

    If my phone is properly rooted should I be able to write a file to anywhere on the phone?

    When I launch Total Commander and try to write a file in eg /
    it asks for su permission, which I grant.
    But when it try to save the file it reports: Error writing to target file! /newfile.txt
     



    1. Download the Forums for Android™ app!


      Download

       
  2. Hadron

    Hadron Smoke me a kipper...
    VIP Member

    With root you'll be able to write a file in any partition (though some may need mounting r/w first). But you aren't writing to any partition there - you are trying to write to the root of the tree! The problem there isn't root access, it's an invalid destination.

    If it's let you grant root access I'm sure you're fine. Install Titanium and take a backup - that will confirm that it works and do something useful at the same time ;)
     
    spiderplant0 and funkylogik like this.
  3. Rxpert83

    Rxpert83 Dr. Feelgood

    What phone do you have?
     
  4. funkylogik

    funkylogik share the love peeps ;)

    im having problems with writing to /system on this 4.3 rom im using and cant find a solution. Ive mounted system as writeable and set ES to r/w. Titanium lets me delete system apps though :thinking:
     
  5. spiderplant0

    spiderplant0 Newbie
    Thread Starter

    Here are the results of trying to add a file to various places ...
    /acct/ - fails
    /config/ -fails
    /data/ - OK
    /etc/ - fails

    I have tried this with Total Commander and ROM toolbox and Terminal Delux

    Superuser and busybox apps are installed.
    If I open up superuser it says all these apps have been granted superuser access
    When I run SuperOneCLick to rootify the device it says everything is fine

    I have a samsung galaxy GTi5500

    The reason I'm asking this is I am having problems with some apps that require root access.

    I rooted it a while back an I think everthing wa find. then I re-applied the Clockwork Mod recovery which might have caused the problems. I have re-applied superOneClick.

    Any idea what could be wrong and what I could try?
     
  6. Doit2it

    Doit2it Android Expert

    If you've been prompted for SU rights, you should be rooted.

    Best way to tell if you have root is to install a Terminal emulator. When you start it up you will see a $ prompt. Type su and enter. You should see a pop up to grant the program Super User rights. Once you agree to the popup you will see a # prompt. You have root. You can close the terminal program with the X in the right corner.
     

    Attached Files:

    spiderplant0 and funkylogik like this.
  7. palmtree5

    palmtree5 Sunny Vacation Supporter!
    Moderator

    spiderplant0 likes this.
  8. spiderplant0

    spiderplant0 Newbie
    Thread Starter

    Thanks for all your replys. I reinstalled the stock rom and re-rooted and it seems to be working now. (and I can write to /etc, /system etc)
     
    Hadron likes this.

Samsung Galaxy Europa Forum

The Samsung Galaxy Europa release date was August 2010. Features and Specs include a 2.8" inch screen, 2MP camera, GB RAM, processor, and 1200mAh battery.

August 2010
Release Date
0
Reviews
Loading...

Share This Page

Loading...