1. Are you ready for the Galaxy S20? Here is everything we know so far!

Amazon AppStore unable to install apps

Discussion in 'Android Devices' started by echristopherson, Dec 31, 2013.

  1. echristopherson

    Thread Starter

    I am unable to install any app from Amazon's Appstore. It seems that everything I try to install (and this includes both things that I already had in Amazon's "cloud" and things I newly chose) downloads successfully but then it gets stalled in the "Installing..." phase (that is, on the "Cloud" screen that lists all the apps I've downloaded or purchased; if I tap on the specific app, it brings up a detail screen that shows "Install pending...").

    I've tried clearing Appstore's data and even uninstalling and reinstalling it (I think I've done that three times now). If I don't at least clear the data, the app to be installed still shows up as "Installing..." each time I open Appstore.

    I'm running the stock, unrooted ZTE 4.1.1 ROM.

    Does anyone have any advice for me to get Appstore to work?

    :thinking:

     


  2. Best Answer:
    Post #18 by BroBryceAndroid, Nov 28, 2016 (4 points)
  3. dontpanicbobby

    dontpanicbobby 100% That Guy
    VIP Member

    Look in Settings from the Home screen page for Security and make sure Unknown sources: Allow installation of apps from sources other than the Play Store is checked.
     
  4. echristopherson

    Thread Starter

    Oh, I meant to mention that I did that. (I think it's required before you can install the Appstore itself.)
     
  5. survivalman

    survivalman Lurker

    yeah I seem to have this same problem and it's driving me mad because all my games that cost money were purchased through the amazon appstore.
     
  6. echristopherson

    Thread Starter

    I wonder if we should contact Amazon support. I've never dealt with them, so I'm not sure how responsive they are to things like this.
     
  7. pa_cap

    pa_cap Member

    I will check my set up 'cause I think I did d/l previously acquired Clean Master now on Valet and 2 Android tablets. I am running an older version of the Amazon store app as I don't like bigger, less friendly recent versions (yes, I do get bugged to upgrade every time I open it and its a pain as I have to clean out the apk from a cache location).
    It is possible that I installed the Clean Master from a backup apk from App Backup and Restore folde on my pc so I'll check the version.

    Update-Yes, my Amazon store app (ver 4.55.51.0C_546100010) and my account sync and I just d/LD Zombie Tsunami, one of the featured apps and games of today. Clean Master was copied from another of my androids but an available update shows along with the just installed Zombie game.
     
    echristopherson likes this.
  8. echristopherson

    Thread Starter

    Luckily, I just realized I had a backup of Appstore from May 2013. I was able to install its apk on my phone and, sure enough, it works fine! It does however seem to stall out -- the download meter showed on the first app I tried, but for each additional app it never shows up. Appstore just finally pops up the install dialog when it's ready (and that takes a while to run, too).

    The seeming stalling out of the downloads makes me wonder if maybe the same thing was happening with my newer version of Appstore, but the UI made it look like it was stalling in the installation phase rather than the download one.
     
    Capt Pete likes this.
  9. catapp

    catapp Newbie

    I had this problem on my LG Gpad. Found out one of my installed apps (from Google Play) -Screen Filter - was causing it. Had to turn off Screen Filter to get Amazon apps to install. Then turn it back on.
    So check that it may be one of your apps is the culprit.
     
    fractallinda likes this.
  10. Capt Pete

    Capt Pete Lurker

    Installing an older version of Appstore worked for me too!
     
  11. echristopherson

    Thread Starter

    I had hope that the seeming download stalling was just a badly-designed UI, but that doesn't seem to be the case. I decided to give newer versions of Appstore a shot again a week or so ago, but since then every time I open Appstore it still shows that it's trying to download the same app. It's been so many days, I don't think there's any chance it was ever going to finish. Now I have to track down my old version again, if I still have it.
     
  12. 2BitGary

    2BitGary Newbie

    I use es file explorer, but any should work. Once Amazon gets stuck on installing, browse to sdcard, Android, data, com.amazon.venezia,files,apks. There you will find what you just downloaded, tap and it should install no problem. Tried with two apps already, both were free or a free app of the day, no problems. I made the folder a favorite in es so I can get to it quickly.
     
  13. Williamb62

    Williamb62 Lurker

    Thanks very much, I had the same problem. This solution worked great for me:)
     
  14. fractallinda

    fractallinda Lurker

    SO helpful. thanks for saving my hair ... thought I was going to pull it all out.
     
  15. cangst

    cangst Lurker

    I am running stock Samsung S5 Active, android v 5.1.1. I couldn't get any of my Amazon apps to update until I "Force Stopped" CM Lite (CleanMaster Lite). I didn't even need to uninstall it, I just stopped the app and immediately the Amazon apps began to update.
     
  16. Stiggur

    Stiggur Lurker

    I was able to fix this by doing the following.
    1) Close any app that has a screen overlay. For me that was Twilight.
    2) Turn off "allow unknown sources" and turn it back on.
    3) Close the Amazon app completely and restart it. Don't just minimise it, press the square and swipe it away.
    4) Go to my apps in Amazon and it should start installing, but you may have to re download it.


     
    rodeoinjoliet and raydb like this.
  17. raydb

    raydb Lurker

    Thanks Stiggur! That worked for me. After trying so many other "fixes". This was the answer
     
    Stiggur likes this.
  18. rodeoinjoliet

    rodeoinjoliet Lurker

    Thank you. This worked for me.
     
  19. So here was my solution on my LG G5 -- and it worked! #1, Force stop the app, and clear the data (this is important!). #2, Disable or uninstall the app. #3, make sure you have "Unknown Sources" (see above replies) checked in settings. #4, Go to AMAZON.COM and download the app from there (not the Play Store). Install it using the standard package installer. Worked like a champ. Upgrading the app from the app, or from the Play store did not work.
     
    reg2dwnldsux likes this.
  20. reg2dwnldsux

    reg2dwnldsux Lurker

    I know this post is almost three years old but I want to confirm this is what finally worked for me. Thanks alot!
     
    Unforgiven likes this.
  21. Unforgiven

    Unforgiven ...eschew obfuscation...
    Moderator

    Thanks. Contemporary confirmation that old solutions are still valid helps the next guy.
     
  22. tube517

    tube517 Android Expert

    The Amazon App Store is still around?

    I thought it was integrated into the regular Amazon app?
     

ZTE Valet Forum

Features and specs are not yet known.

unknown
Release Date
0
Reviews
Loading...

Share This Page

Loading...