1. Are you ready for the Galaxy S20? Here is everything we know so far!

Andriod not sending or receiving texts

Discussion in 'Android Carriers' started by michelegutz, Oct 23, 2018.

  1. michelegutz

    michelegutz Lurker
    Thread Starter

    Just switched from an Iphone to an Android (LG Q7 plus), and switched from FreedomPop (That uses the Sprint network) to Metro by Tmobile.

    1. I am not able to send or recieve texts through any apps including:

    Messaging
    Android Messagers
    Chomo SMS
    FB messenger

    I tried setting my default messaging app to each of these to no avail.

    2. Also factory reset my phone. Still not working.

    3. I have a Google Voice account so I've been using my GV number to send and recieve texts, but I want to do this through my default messaging app on my official cell phone number and I want to make sure I dont miss texts from people texting my cell phone number.

    4. Also changed my APN network settings but still not working.

    What else can I do? Anyone else have this problem? How did you fix it?

    Very frustrating. Please help 😐

    Thanks in advance!
     


  2. svim

    svim Extreme Android User

    Basic texting apps work through the phone number tied to your cellular carrier service so just to confirm, are you able to send/receive phone calls on your phone? (that is, excluding Google Voice and specifically through your MetroPCS phone number).
     
    michelegutz likes this.
  3. michelegutz

    michelegutz Lurker
    Thread Starter

    Thanks for the reply! Yes, I am able to make and recieve calls on my MetroPCS number just fine.
     
  4. tube517

    tube517 Android Expert

    Can you screenshot your APN settings and post here?
     
    michelegutz likes this.
  5. svim

    svim Extreme Android User

    In your LG Q7+ Settings >> Apps menu is there a 'Default apps' sub-menu? Is the texting/message app listing show the messaging app you want to use?

    You initially stated you were using your phone with FreedomPop, a MVNO that contracts with Sprint (CDMA, LTE) and with AT&T (GSM, LTE). Are you sure that you were using Sprint's cellular network and not AT&T's? T-Mobile's cellular network also being GSM-based I have to wonder if this has anything to do with the problem. Still, the fact that phone calling isn't a problem clouds the issue. I'd re-check your APN settings:
    https://support.t-mobile.com/docs/DOC-2090
    You might also want to try just re-seating your SIM card.
    You mentioned doing a Factory Reset and that didn't solve the problem but a more specific thing you might want to try is Network Settings Reset. Read the caveats though, as this also wipes a lot of things but limited only to networking:
    https://www.theandroidsoul.com/reset-network-settings-android-o/
     
    michelegutz and tube517 like this.
  6. tube517

    tube517 Android Expert

    Did you disable and deactivate imessage on your iphone before you switched your number to the LG?
     
    michelegutz, svim and today like this.
  7. michelegutz

    michelegutz Lurker
    Thread Starter

    Yes i did disable imessage. Thanks for checking.
     
  8. svim

    svim Extreme Android User

    Just to add:

    Messaging

    Not surprisingly, Apple's iMessage system doesn't play nicely with non-Apple platforms. But that doesn't mean it's impossible to leave; you just have to take the right set of steps to avoid missing-message misery.
    First, go into Settings on your iPhone, tap "Messages" and then toggle "iMessage" to off. While you're in Settings, you'll probably want to look for the "FaceTime" option and toggle it to off, too, since you presumably won't be active on that platform anymore.
    Second, open Apple's "Deregister iMessage" web page and scroll down to the section labeled "No longer have your iPhone?" Put in your phone number, click the link to send a confirmation code and then type the confirmation code you receive into the page.
    Both of these steps are critical; if you don't complete them, Apple will likely intercept at least some of your incoming text messages, and you'll never even know you missed 'em.
    [​IMG] Apple
    Get your phone number out of the iMessage system or forever wonder if Apple is snatching your messages.
    If you want to keep all of your existing text messages and bring them over to your new phone, an app called iSMS2droid can get the job done. The process is a bit gnarly and involves manually backing up your iPhone to a computer, then finding specific files and transferring them onto your Android phone — but if you really need to save all your old messages, it's about the best option you have.
    The silver lining is that once you're on Android, keeping your messages synced and available on any device can be thought-free. Just be sure to pick a messaging app that automatically backs up and restores data from the get-go, and you'll be fine as wine.

    The above copied from:
    https://www.computerworld.com/artic...ch-from-iphone-to-android-ultimate-guide.html

    https://selfsolve.apple.com/deregister-imessage/
     
    tube517 likes this.
  9. michelegutz

    michelegutz Lurker
    Thread Starter

     

    Attached Files:

  10. svim

    svim Extreme Android User

    P33r33z602 likes this.

  11. Are you resolve the problem?
     


  12. I can't guarantee that this will fix your problem but it's something you can try. So go into Settings>About Phone and scroll down to where you see your Build Number and tap that box repeatedly (for my phone it was 15 taps) until it says that Developer Options enabled then go into the Developer Options and scroll down until you see Cellular Data Always Active and turn that option on then restart your phone and for me my problem was fixed!
     

MetroPCS

Loading...

Share This Page

Loading...