1. Are you ready for the Galaxy S20? Here is everything we know so far!

Android 2.3 & 4.0 WiFi Internet HD 1080P HDMI Google TV Box ARM Cortex A9 Firmware

Discussion in 'TV & Video' started by unknown26, Apr 13, 2012.

  1. unknown26

    unknown26 Lurker
    Thread Starter

    Updated 6 September2012

    Android 4.0.4
    - Google Android 4.0 ARM Cortex A9 1GHz WiFi HD 1080P HDMI Internet TV Box Black
    Older Version(c03ref)

    Latest Version Updating...

    Android 4.0.4 - Google Android 4.0 ARM Cortex A9 1GHz WiFi HD 1080P HDMI Internet TV Box Black
    Older Version(f16ref)

    Latest Version Updating...

    Check you device model with this apk

    Android 2.3
    - Google Android 2.3 ARM Cortex A9 1GHz WiFi HD 1080P HDMI Internet TV Box Black (Tested on ATV-108 device.) Flash to 4.0 and then flash to 2.3. You will see failed to write ethernet mac address which is completely fine. Just reboot the device and it should be working. (Not sure if this is the latest
    latest 2.3 firmware.rar

    2.3 Board is ATV-101
    4.0 Board is ATV-108 There is a Rev1 (c03ref) & Rev2 (f16ref)

    1. Download the Forums for Android™ app!


  2. jmcuts

    jmcuts Lurker

    Thanks for the info Unknown26 and Hansmaiser. I too have the above android box. I have tried both firmwares and they both work OK (mine was shipped with ICS 4.0.3)

    ICS is definately alot quicker and smoother. Youtube is fantastic. The only issue i have is with flash player in browser. I cannot load any streaming video via the any browser. Opera browser gets close but doesnt play.

    I downgraded to 2.3 to test the flash issue, it worked better on 2.3 but still not great (nearly unwatchable), in fact i went back to 4.0 because this rom is so much smoother.

    hopefully the next update will fix these issues.

    Unknown26 where are you getting your info about the updates from? lets make this thread into all firmware updates etc.

  3. gicapp

    gicapp Lurker


    About this box, could i make the box load a streaming video before all options appear?

    Have any way to make this work?
  4. superdanny

    superdanny Lurker


    I also have this box, but can't upgrade firmware.

    Could someone tell me more precisely what is the procedure?

    For the moment, I keep the reset button pressed, unplug power supply, plug it back, and when I see the light blinking three times, I release the reset button, and plug the SD card.

    Result is that I see the message "can't mount /dev/sda1", and the factory reset is performed.

    I have the image files on my sdcard.

    What might be wrong in what I'm doing?
  5. zuluman

    zuluman Lurker

    for this device cmw avalible?
  6. garfo77

    garfo77 Lurker

    I have this box with the 2.3 rom but it is not rooted. How do i root it? Z4root didn
  7. superdanny

    superdanny Lurker

    I am still in trouble to update firmware of my atv-101 box.
    I tried to upload ROM with several SD cards, in fat16 and fat 32.
    None were recognized.
    I tried to upload update.zip with adb without success.

    Does someone know how to flash a recovery image that will detect update.zip on sdcard or anywhere else?

    When I try to run fastboot with any update.zip, system simply does a factory reset.

    Any help?
  8. zuluman

    zuluman Lurker

  9. zuluman

    zuluman Lurker

    does android 2.3 succesfull mount sdcard ?
  10. icyfire001

    icyfire001 Lurker

    Recently received the ATV-108 with 4.03 ICS28FEB. My question is if anyone has checked the CPU speed? Mine was maxed at 750 MHz and the sys check app says its an A7. But MBX ICS VS-2.

    Also, has anyone successfully rooted this. Instructions available? Thanks.
  11. matinaki

    matinaki Member

    Hi guys
    Recently received the ATV-108 with 4.0 but..not possible to find in menu subtitles language adjustments.
    Now, on all videos subtitles are..chinese..!! :stupido:
    Someone to help me?
    Thanks in advance
  12. 2pac

    2pac Lurker

    the title description is Android TV Box 4.0 ARM Cortex A9 WiFi HD 1080P HDMI Internet TV Box DDR II 512M 2GB+3D+Flash 10.1
    I bought this product which arrived today. It looks like the android tv atv108 from visson ( same box, external appearance...etc)
    When I plugged in, it picked up straight away my wifi but cannot maintain the connection, it keep cycling through:
    getting IP addresses
    connect (briefly)
    saved status
    When I click on the network to connect, nothing happens and remain in "saved" status.
    Although my home network works well with my dasktop, laptop, tablet Galaxy Tab, android phones...I did tried on
    different channel ( Auto-> 11 -> 1) no improvement.
    I tried several disconnect, no change...
    I even reset to original manufacturer .. no change

    one guy wrote ell, in between time, the vendor has provide me with a new firmware (4 23 3.0 firmware) and it works!:D
    so now the details are:
    model: MBX ICS VS-2 --> MBX.VISSON 2.0 Board
    Android version: 4.0.3 (Unchanged)
    Kernel version: 3.0 -->3.02
    Build number: ICS-MBX.20120225 -->ICS-MBX.20120422

    somebody knows from which website can i download this firmware ????? please heeelp
  13. cuhullainn

    cuhullainn Lurker

    akaman likes this.
  14. shoht1

    shoht1 Lurker

    I used the instructions above, my device is dead!
    Any suggestions?
    Please ... Help ...
  15. dosiki

    dosiki Lurker


    have you any experience about bluetooth pairing between a wii Remote and a Geniatech Enjoy TV - (Android 2.3 MyGica 20111104 fw)

    Bluetooth dongle is OK, discovering OK, but pairing is failed, i don't know what is the code. Normally Wii Remote has no code, but this situation I need to input someting to...

    Thanx in advance.
  16. icyfire001

    icyfire001 Lurker

    Can you upload to mediafire please. thanks :D
  17. cocopera2k

    cocopera2k Lurker

    i upload the new firmware, in 3 days the atv-108 is bricked,i active de MNT with the Pc and does not start when I rebooted.

    I tried reinstalling the firmware from the SD, but does absolutely nothing to update. The TFT screen is black. Also when I turn both lights are always fixed and not blink.

    My question would be, I can flash the rom from my pc? or is it not a rom problem?. It has broken something?

    If I had to flash the rom? As you would.
  18. ArthurH

    ArthurH Lurker

    Can it play music (airplay) from a iPhone? Or is there a app for it?
  19. todorjan

    todorjan Lurker

    I made update ATV-108 for these queries and all works perfectly. Corrected some bugs, flash works, youtube also. On Vimeo is a video can not open or hear the sound but no picture. Over Imediashare applications (for TVs with DLNA protocol) you can browse Engadget and many other videos. The device now works much better and more stable.
  20. turbopropello

    turbopropello Lurker

    did u update to Android 4.0 and flash works?
    have u tested DTS sound?
    what update did u use?

  21. matinaki

    matinaki Member

    Hi guys
    How to change subtitles on ATV-108 with 4.0.3?
    All are chinese..
    I do not find such option on settings.
    Anybody knows?
  22. todorjan

    todorjan Lurker

  23. maxsim

    maxsim Lurker

    Anyone successfully getting Wireless Mouse with USB dongle to work on the android box.

    Mine seems to work for a while and stop or at times, does not work at all.
    Using wired mouse is fine.

    I am having
    MBX VISSON 2.0 Board
    Android 4.03
    Kernel 3.02

  24. todorjan

    todorjan Lurker

    I use RII mini wireless keyboard and works great.

Share This Page