1. Download our Official Android App: Forums for Android!

General Android 4.3 in Galaxy S4 - Lagging

Discussion in 'Android Devices' started by Sdahe, Nov 15, 2013.

  1. Sdahe

    Sdahe Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    56
    Posts:
    135
    Joined:
    Oct 5, 2010

    Oct 5, 2010
    135
    4
    56
    Puerto Rico
    Hello,

    I updated my Galaxy S4 (ATT) to the new Android 4.3 and now I notice more lagging than before. Wasn't this new update suppost to give the phone more performance?... Before you say anything, yes I did a fresh install. Yes, I turn off the animations in developer options...

    Is there something else I could do to make it smooth...

    Thanks
     

    Advertisement

  2. GuitarG20

    GuitarG20 Clueless Senior Member
    Rank:
    None
    Points:
    253
    Posts:
    2,067
    Joined:
    Jun 23, 2012

    Jun 23, 2012
    2,067
    972
    253
    Male
    Texas
    There were originally issues with the original OS that came on the phone where all the features (air view, smart stay, etc) would slow the phone down. The only solution then to fix lag was to turn some of them off.

    Although I also heard it was supposed to speed up the phone, it's possible that you still need to disable some for more speedy performance.

    I'd say it's possible, if not likely, that all of AT&T's bloatware is keeping your phone slow, and absent rooting and getting rid of it, you'll have to turn off some of those other software features to ditch the lag.
     
  3. Sdahe

    Sdahe Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    56
    Posts:
    135
    Joined:
    Oct 5, 2010

    Oct 5, 2010
    135
    4
    56
    Puerto Rico
    I turned off must of the bloatware... and the most of the features. I see now that it has an antivirus software running all the time... maybe that's what is slowing the phone.

    This is the software - "AntiVirus & Security | Lookout"
    https://play.google.com/store/apps/details?id=com.lookout
     
  4. SebaKL

    SebaKL Android Enthusiast
    Rank:
     #206
    Points:
    113
    Posts:
    746
    Joined:
    Oct 4, 2011

    Oct 4, 2011
    746
    226
    113
    Interactive Designer/Developer
    Kuala Lumpur, Malaysia
    I never used antivirus, from what I read it has no use in Android environment. So I can't comment whether it's the cause of your lag or not.

    I suspect if it's not antivir, then it's your ATT, because I use LTE32 international Unlocked and it's blasting fast.
    It was always fast before the update, and even faster after it. ( I did factory reset tho).

    I have turned all the Samsung features ON, connected to Galaxy Gear and to my Harman Kardon SoundSticks via Bluetooth. I have sync ON, I stream audio, run the phone at full brightness to let it consume as much power as possible, and that's how it works here:

    https://www.dropbox.com/s/lqg2s8wq10qxr2p/S4_LTE32.mp4

    Also, I do have few widgets which constantly update weather, calendar events etc... I can't think of other things I could add to try to make it slower.

    It's been like this out of the box.
     
  5. Petrah

    Petrah Psychotic Female
    Rank:
    None
    Points:
    333
    Posts:
    4,086
    Joined:
    Jun 13, 2011

    Jun 13, 2011
    4,086
    1,468
    333
    Female
    Annoying my X-Husband
    Hanover Park, IL

    When you say you did a fresh install, do you mean you did a factory reset after the OTA install was complete? If not, you would more than likely benefit from it.
     
  6. Sdahe

    Sdahe Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    56
    Posts:
    135
    Joined:
    Oct 5, 2010

    Oct 5, 2010
    135
    4
    56
    Puerto Rico
    Yes... that's what I did... I turn off the phone and turn it on pressing the volume up, power and home button until the little robot came into the screen... then I had a menu where I performed a factory reset
     
    GuitarG20 and Petrah like this.

Share This Page

Loading...