1. Download our Official Android App: Forums for Android!

Support Android 6 Update Contact Storage Permission

Discussion in 'Android Help' started by Ak de Edge, Mar 15, 2016.

  1. Ak de Edge

    Ak de Edge Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Mar 15, 2016

    Mar 15, 2016
    2
    0
    5
    Hello people,

    Sorry for the lengthy post. Please bear with me!

    After upgrading my Moto G2 to Marshmallow, I faced the same issue as a lot of other users with the contacts. They had disappeared and yet showed up in WatsApp. I fixed that issue after deleting all contacts, clearing the cache partition and then syncing with my Google contacts.

    However, the default Google contacts doesn't allow me to view, add or delete any contacts. Using another app helped view the contacts but I still can't add a new contact. I have to add on Google contacts and then sync.

    The error message says "You have disabled a required permission". The contacts storage app's permission section is disabled. So I cant change any permissions. The other sections such as storage are accessible.

    What is the resolution? Is factory reset the only solution?

    Thanks!
     

    Advertisement

  2. Michel Desjardins

    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Apr 15, 2016

    Apr 15, 2016
    1
    0
    5
    Male
    I have the same problem, with a new Moto G 3rd gen. I've tried different Contacts apps, which all work, but don't allow me to add new contacts. I'm back to the "You have disabled a required permission" note. When I go to Settings --> Apps --> Contacts, all the required permissions are checked. Any help would be appreciated.
     
  3. Ak de Edge

    Ak de Edge Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Mar 15, 2016

    Mar 15, 2016
    2
    0
    5
    Hi Michel,

    The issue lies in the contacts storage and not the contacts app. They are two different apps. You'll see that the permissions is grayed out in the contacts storage. All external contacts app read from this service and so are useless since the source is messed up.

    Add another user and you'll see that it works fine with the permissions open.

    I had no choice but to factory reset(since I don't like multi-users) and now everything is fine !
     
  4. Benjamin Senatro

    Rank:
    None
    Points:
    15
    Posts:
    1
    Joined:
    Sep 27, 2016

    Sep 27, 2016
    1
    0
    15
    Male
    Go to settings/Apps/Contacts, locate permissions and turn on sms messaging
     
  5. shanghaisage

    shanghaisage Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Oct 9, 2017

    Oct 9, 2017
    1
    0
    5
    In my case different thing solved it. I got that error while importing a vcf file to transfer contacts from my Samsung Galaxy to One Plus 5.

    Went to Apps/Contacts and turned on permission for storage and it allowed importing the stored file
     

Share This Page

Loading...