1. Download our Official Android App: Forums for Android!

Support Android devices not reading SD card

Discussion in 'Android Help' started by Don B Hayten, Apr 25, 2016.

  1. Don B Hayten

    Don B Hayten Lurker
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    1
    Joined:
    Apr 25, 2016

    Apr 25, 2016
    1
    0
    15
    Male
    I have quite the strange problem. I bought a PNY brand 64GB sd card in February and it had been working fine up until a few days ago. Then, it suddenly was ejected for seemingly no reason. No trauma such as dropping or anything like that. I put it into my computer with a USB3 card reader, and lo and behold, the card is being read just fine. So I tried inserting it into my GPad to see if my phone was starting to crap out on me. Same issue. The card is not being read, but this time, the GPad recognized that the card had been removed, which was very strange, as it did not recognize the card being inserted. None of the Android devices I'm inserting the card into read the card, so I tried using other SD's which I know work. The same thing is happening with all of them! They're all not being read by Android, but when I insert them into my PC with the adapter, they work fine! Back to my 64GB card. I have a micro USB to female USB adapter so I could use USB flash drives with my Android devices. I plugged in the card reader adapter into said micro to usb adapter to see if it would work, and it did! I'm not getting this at all! I wanted to see if formatting the SD card while it was in my phone this way would work, and it did not work that way either. I am beyond bewildered!
     

    Advertisement

Share This Page

Loading...