1. Check out our companion app, Forums for Android! Download from Google Play

android.graphics.Matrix.mapPoints = fail?

Discussion in 'Application Development' started by lms5400, Sep 9, 2010.

  1. lms5400

    lms5400 Member
    Thread Starter

    Apr 28, 2010
    I noticed I had some very inconsistent results with API level 6 or higher using the mapPoints method on the Matrix object. I have no idea what the method really does, but I'm assuming its a simple matrix multiplication that can be obviously use for transformations.

    With correct input, I ended up with results that after days of testing, seemed to be somewhat random. The results always worked in lower API levels (5 and down), but in 6, 7 and 8 they only mostly worked in in debug mode - which made it very hard to test. Otherwise they were mostly incorrect and the resulting vectors from mapPoints were identical to the input - perhaps I don't understand what map points is supposed to do but that was not the result I wanted. To fix this I simply wrote my own matrix transformation method, but I would like to understand how I can get such strange behavior from a method especially across platforms. Has anyone else had unusual experience with this method?


Share This Page