1. Are you ready for the Galaxy S20? Here is everything we know so far!

android loop reload when there are apps on sd

Discussion in 'Android Devices' started by fadol, Dec 20, 2011.

  1. fadol

    fadol Lurker
    Thread Starter

    my phone boot loop if i move many apps to sd card


    i tried fully wipining more than twice with different rom and the same problem happens

    tried 2 diffrent sd card same problem and also just bought a samsung 32 gb class 10 but it happend again as soon as i moved extra apps
    its a very weird bug , if i plug the sd card to pc move the apps to my pc and format the card and put them back some times the phone will boot just fine

    and even if i plug the card to pc and remove 4~5 apps apps it will work fine sometimes

    the phone boots okie without sd card but whenever i plug it in it will start then after a2 min it will restart it self and keep bootlooping

    i dont really know what to do now as i like this rom and dont really wanna switch

    some times removing apps that are not in the sd card will solve the problem too

    but i'm sick of this problem , whenever i install new apps it will come back again

    i thought its the cause of an app , so i started wiped my phone reinstalled my back up startsed installing apps one by one and after each install i would reboot my phone and check if it will bootloop after starting but found out its completely random , i move an app restart the phone and it caused a bootloop , i boot with out cd , remove that app but still phone is bootlooping i dleete random selected apps from teh sd 5~7 and it will work fine again

    the problem is i have to move some of the apps to my sd because the 1.8 app storage is full

    i use checkrom v4 and and even other versions didnt solve that , its not caused by he rom cuase other have this problem with stock rom also , but none has a solution for it expect not using appto sd

    ps tried formating fat 16 and fat 32 , different kernels , many other stuff
     



    1. Download the Forums for Android™ app!


      Download

       
  2. fadol

    fadol Lurker
    Thread Starter

  3. fadol

    fadol Lurker
    Thread Starter

  4. Kie

    Kie Android Expert

    That 'up' thing is kind of annoying.

    What apps are you moving to the sd card? What sd card are you using (brand, size, etc) because the SGS2 is very picky with sd cards (even Samsung ones!). If it ain't Sandisk, you're likely to have things deleting themselves on the card. Could be corrupted apps causing the bootloops.
     
  5. fadol

    fadol Lurker
    Thread Starter

    Samsung 32gb sd card class 10 also has a nokia 2gb card that works fine my my galaxy s1 but also cuase reboot
     
  6. Kie

    Kie Android Expert

    So what apps are you copying? Does you phone bootloop when the external sd card is removed as well?

    Edit: Sorry I didn't read your OP properly before I asked these questions :p
     
  7. fadol

    fadol Lurker
    Thread Starter

    without sd it boot fine, im sure its not caused by an app, becase sometimes just copying android_secure folder to pc and deleting it and recopy it may fix it sumtimes
    alsoi tried moving a singling app at a time to sd and restarting after each move but it was completely random and removing an app that the phone got bootlooped after moving it to s card wont fix the problem
     
  8. daniver

    daniver Lurker

    I've got exactly the same issue. Move more than about 70 applications to the SD card and the next phone restart causes "reboot" loops where the phone displays the launcher for a minute or two and then restarts. While in the launcher you can start applications, look at settings, etc but the phone will restart no matter what you do.

    Looking the logcat output the watchdog class seems to think there is a deadlock, a timeout happens and it kills and restarts the main system process. My guess is that the process that sets up the loopback encrypted mounts for all the applications on the SD card is taking longer than the "deadlock timeout" and the watchdog thread is restarting the android system. The kernel isn't being restarted only the android system - but that doesn't make a difference because the phone is unusable in this state.

    The temp fix is to move some of the encrypted applications out of the .android_secure directory. No permenant fix yet. Currently trying to get app2sd working by using a 6GB ext4 partition on my SD card for all applications but I haven't worked out how the odd SGS2 boot sequence works yet to plug in the app2sd script.
     
  9. fadol

    fadol Lurker
    Thread Starter

    let me know if u figured out the app2sd script
     
  10. daniver

    daniver Lurker

    After a lot of research I now know a lot about how the Android boot sequence works and the steps involved to make changes to the root filesystem so I could plug in an app2sd script at boot up. There is an application available that unpacks the kernel and compressed root filesystem but the copy I found, compiled up for a Galaxy Tab, crashed every time it tried to unpack the root filesystem. So, being too lazy to download the source and compile my own version, I looked for another way...

    ... and my solution was to replace the vold application, stored in /system/bin, with a script that mounted my ext4 sdcard partition and set up symbolic links up for /data/app and /data/app-private to point into the new partition and then finally run the original vold which I had renamed.

    I left application data and the dalvik cache behind on the internal data partition. I also edited the vold.fstab and swapped around the internal and external sdcards so /sdcard initially had 56GB or free space and /sdcard/external_sd had 11GB. With this arrangement I now have 400+ applications installed, with 3GB+ of free application space, 1GB free of application data and all the Gameloft games available for the Galaxy S2 installed together with their Gigabytes of sdcard data and still have loads of free space available in /sdcard.

    Finally have my SGS2 the way I wanted it and the soft reboots have gone. :D
     
  11. fadol

    fadol Lurker
    Thread Starter

    would be good if u posted step by step on how to do that so me and others can get ride of that problem
     
  12. octogunsalata

    octogunsalata Lurker

    Same problem here. No idea through what event that happened. Just flashed stock and stock beta FWs recently. No CyanogenMod or some other Rom that changes the cards. It just happened suddenly. When I remove the external card, it says there is not enough free space on sd-card when trying to move an app. But the USB-Storage is empty. It only accepts the external card for installing apps suddenly. And after moving some, I get the boot loop.
    Card: Samsung 32GB Class 10

    Found some infos about editing the vold.fstab file, but only developer conversations of which I understand nothing.

    Edit: it got even worse... Now the external sd unmounts itself automatically right after booting.
    And the boot loop continues though it's not even mounted...
    Wouldn't have any problem just throwing the card away, but first i have to solve the usb-storage problem or else i have just the small phone storage left...
     
  13. Russell Ng

    Russell Ng Android Expert

    External micro SD storage is located in external_sd folder and not the USB storage. Without the microsd, move to sd will give you the error you see. The real problem seems to be your sd card. Try with another sd card. If that doesn't work, will have to look deeper to figure the reason for the problem.
     
  14. octogunsalata

    octogunsalata Lurker

    Yeah, I know.
    There are 3 storages
    Phone storage (about 2GB) path: /mnt
    internal sd/usb-storage (11.5GB) path: /mnt/sdcard
    external micro sd-card (card size) path: /mnt/sdcard/external_sd

    But normally, if you don't have a micro sd, then the internal 11.5GB usb-storage is used for moved apps.
    It was like this since i bought the phone. The usb-storage was used by default. It switched just a few days ago.
    And this definitely is not normal. I got several changes since then. Before this happened, i had all the moved apps inside "mnt/sdcard/android/data/" but now it don't uses this folder anymore. When trying to move an app, it says no free space. But there's plenty of it.
    I also can't mount the usb-storage inside cwm recovery and it won't save the nandroids to usb-storage anymore. When removing the micro sd, i have just the 2GB phone storage left for all of my apps!! Moving apps to the internal sd card was an everyday task, i've done this hundreds of times. The external card i was using for music and videos.
    All of this happened just suddenly...
     
  15. Russell Ng

    Russell Ng Android Expert

    I remember the move 2 sd also move to USB storage when I first got the phone and not have any micro sd. But ever since got a micro sd, move to sd only works as mentioned earlier.
     
  16. octogunsalata

    octogunsalata Lurker

    I was assuming this before i've bought the card, but it wasn't possible to move apps to it. I was quite disappointed by that fact.
    Only some app-folders could be moved to the micro sd, like the data folder of Navigon Select. But for applications it always used the usb-storage only.

    But this seems to be normal at all, why would there be custom Roms that support this if it's supported by default?
    For example the Cyanogen Rom.
    Also with the app Rom Manager there is an option: "Partition sd-card to enable installing apps to it, with a Rom that supports it."
    There are also forums with tutorials, how to edit the "vold.fstab" file to enable install to micro-sd.

    But for some people this seems to be enabled by default. It's quite confusing... :thinking:

    However, after removing the micro sd it definitely should use the internal card again. But it don't. That isn't normal.
    If i had a guarantee that with another card the phone will be stable, i would even appreciate the card swap. It's much more space for apps after all.
    But I've bought one of the most expensive cards i've found in web, just because i had much trouble with cheap cards in past with other phones.
    Don't want to spend another 50$ or more just for a chance...
     
  17. octogunsalata

    octogunsalata Lurker

    Found out something. I have an old cheap 16GB micro sd, so i thought i try this one. After connectiong to pc windows asked if it should repair the card. I let it repair.
    After that i've formated it using the program "SD Formatter v3.0" on pc.
    I think i found this prog on panasonics page, but not sure. There isn't any about button.
    I've checked the options:
    Full (overwrite)
    Size Adjustment: On

    The formating took about an hour, but it seems to have worked.
    I've moved more than 50 apps, and it booted fine!
    I should try this procedure with the 32GB samsung card too, but right now i'm just happy to have a working phone again. @fadol: You have the same samsung card. So if you try this, please let me know the outcome!
     
  18. Russell Ng

    Russell Ng Android Expert

    But I suspect you won't be able to install the whole app in the microSD card unless you use a custom ROM. Regardless, it seems obvious that for some/most cases, the problem lies with the microSD card, or at least the SGS2 don't work well with some cards.

    Cheers
     
  19. octogunsalata

    octogunsalata Lurker

    That's exactly my problem. Through some event i can install apps ONLY to the external micro sd. That shouldn't be possible.
    You could say my phone is broken, but i didn't do anything wrong.
    Hadn't any failure while flashing, and i did not mess around with files i don't know. Have not the slightest idea what's the cause of this. Now i'm trying to find a way to fix it. It's just wrong paths after all. It should be possible. But flashing a 5 part firmware DID NOT helped... so i have a bad feeling about this.
    Like i wrote the post before, i've tried another sd card. Don't have a boot loop anymore now, but it also don't feels very stable. Had 1 freeze already. I think micro sd's are just not meant for whole apps, and because of this it's unstable. Still hoping i can avoid samsung service. Have lost my warranty through the flashing...
    But thanks for your time.
     
  20. Koolbabu3795

    Koolbabu3795 Lurker

    For ****s sake, it's been almost 4 months now.GOOGLE please please please address this issues as soon as possible.Is this what someone expects for being a die hard android fan for so darn long?!?!
    BOOT LOOP, PHONE KEEPS REBOOTING AFTER START ON READING SD CARD, IT'S DUE TO THE AMOUNT OF APPS ON SD CARD/THE SPACE OCCUPIED BY THE APPS ON THE SD CARD. I USE A SAMSUNG GALAXY ACE I HAVE 158 GODDAMN INTERNAL MEMORY, YOU DON'T EXPECT ME NOT TO USE THE EXTERNAL SD CARD AS A MEDIUM TO STORE APPS, NOW DO YOU?
     

Samsung Galaxy S2 Forum

The Samsung Galaxy S2 release date was April 2011. Features and Specs include a 4.3" inch screen, 8MP camera, 1GB RAM, Exynos 4210 Dual processor, and 1650mAh battery.

April 2011
Release Date
0
Reviews
Loading...

Share This Page

Loading...