1. Download our Official Android App: Forums for Android!

Android: Solution for the device not compatible with the Google Play Store

Discussion in 'Android Development' started by Chandananalin, Sep 8, 2017.

  1. Chandananalin

    Chandananalin Lurker
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    2
    Joined:
    Sep 8, 2017

    Sep 8, 2017
    2
    0
    15
    Android: Solution for the device not compatible with the Google Play Store
    I have Android mobile application. It given error with same android version with different phone models.

    I need run my application for any device with out any compatible issue.
    Below is my manifest file

    <?xml version="1.0" encoding="utf-8"?>
    <manifest xmlns:android="http://schemas.android.com/apk/res/android"
    package="com.smartmetro.prime"
    android:versionCode="17"
    android:versionName="5.1" >

    <uses-sdk
    android:targetSdkVersion="23"
    android:minSdkVersion="19" />


    <uses-permission android:name="android.permission.INTERNET" />
    <uses-permission android:name="android.permission.ACCESS_FINE_LOCATION" />
    <uses-permission android:name="android.permission.ACCESS_COARSE_LOCATION" />
    <uses-permission android:name="android.permission.ACCESS_NETWORK_STATE" />

    <uses-feature
    android:name="android.hardware.location.gps"
    android:required="true" />

    <supports-screens
    android:largeScreens="true"
    android:normalScreens="true"
    android:smallScreens="true"
    android:xlargeScreens="true" />
    <application
    android:icon="@drawable/logo"
    android:label="@String/app_name" >
    <activity
    android:name=".LauncherAppregisterMenuActivity"
    android:clearTaskOnLaunch="true"
    android:launchMode="singleTask"
    android:theme="@android:style/Theme.NoTitleBar" >
    <intent-filter>
    <action android:name="android.intent.action.MAIN" />
    <category android:name="android.intent.category.LAUNCHER" />
    </intent-filter>
    </activity>
    ......
    </manifest>


    Please help me resolve Device not compatible problem
     

    Advertisement

    #1 Chandananalin, Sep 8, 2017
    Last edited by a moderator: Sep 8, 2017
  2. andMego

    andMego Android Enthusiast
    Rank:
    None
    Points:
    133
    Posts:
    604
    Joined:
    Aug 9, 2015

    Aug 9, 2015
    604
    161
    133
    How can a device be not compatible? Can't you just install them in a custom recovery if the phone doesn't come with it?
     
  3. Chandananalin

    Chandananalin Lurker
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    2
    Joined:
    Sep 8, 2017

    Sep 8, 2017
    2
    0
    15
    Yes but it need download and update via play store
     
  4. codesplice

    codesplice Elite Recognized Moderator
    Moderator
    Rank:
     #14
    Points:
    1,563
    Posts:
    8,777
    Joined:
    Oct 29, 2013

    Oct 29, 2013
    8,777
    10,146
    1,563
    Male
    SysAdmin
    Huntsville, AL
    Hi @Chandananalin and welcome to AF :)

    I've merged your threads since there's no need to have duplicates strewn about the place. And since you're talking about manifests, this Android Development subforum is probably the best place for the discussion. :thumbsupdroid:

    Is this your app (that you built) or one which you're trying to install on your phone? What is your device?
     
    andMego likes this.

Share This Page

Loading...