1. Are you ready for the Galaxy S20? Here is everything we know so far!

Android-x86 Installation

Discussion in 'Computers' started by sisare, Dec 28, 2020.

  1. sisare

    sisare Lurker
    Thread Starter

    hi, I tried to install Android-x86,
    Downloaded some ISO from https://www.android-x86.org/
    And has been successfully installed all of them.

    But then after booting, it gives me Android symbol only, and nothing else,
    sometimes, after waiting for quite long time, Android symbol become blank page, with mouse only.
    So, please help me, anyone know, what maybe wrong ?

    Do we have to format the partition disk, with specific file type ?
    Like ntfs, fat32, ext4, but I don't have that options.

    Attached is the Android symbol I see after installation and booting.
    Also the list of file type available for me to format the partition disk.

    [​IMG]
     



    1. Download the Forums for Android™ app!


      Download

       
  2. mikedt

    mikedt 你好

    Are you trying to install it on a laptop that the devs built it for, and tested Android-x86 on? https://www.android-x86.org/ If not, you may have incompatible hardware in your laptop.

    From the Android-x86 project website:
    Tested Platforms

    The tests are done by the project members and others from android-porting group.


    • Microtech e-tab Pro (2018)
    • ASUS Eee PCs/Laptops
    • Viewsonic Viewpad 10
    • Dell Inspiron Mini Duo
    • Samsung Q1U
    • Viliv S5
    • Lenovo ThinkPad x61 Tablet
     
    Dannydet likes this.
  3. sisare

    sisare Lurker
    Thread Starter

    Hai, yes, I install it on a Laptop, but on a VM.
    I see, so Is it limited to several platforms above only ?
    So, it means hardware incompatibility.

    Also I tried to install Bliss OS, but it gives me Bliss' symbol only.
    Anyone know the reason ?

    [​IMG]
     

    Attached Files:

    #3 sisare, Dec 30, 2020
    Last edited: Dec 30, 2020
  4. kate

    kate Dreaming of Bugdroid.
    Moderator

    They have instructions to run Android-x86 inside VirtualBox:
    https://www.android-x86.org/documentation/virtualbox.html


    If you're using VMware I found this:
    Issues
    VMware
    You have to change your virtual disk type to be IDE because the default type in VMware is SCSI, and Android-x86 kernel is not configured to support SCSI. You can follow these steps:

    1. Create a virtual machine.
    2. Edit virtual machine settings after the virtual machine created.
    3. Choose the hard disk and remove it.
    4. Add a hard disk to create a new virtual disk, then you can choose IDE as your virtual disk type.
    5. When finished, you can install android-x86 normally.
     
Loading...

Share This Page

Loading...