1. Check out our companion app, Forums for Android! Download from Google Play

Support Another Possible Solution to MTP Driver issue on Windows 7 64

Discussion in 'Android Devices' started by dswalen, Oct 27, 2010.

  1. dswalen

    dswalen Member
    Thread Starter

    Oct 7, 2010
    I'm posting this on the chance that maybe there are others out there like me who had run into this particular manifestation of the MTP driver issue on Windows 7.

    I had successfully installed Samsung Kies and the Captivate Drivers on my Windows 7 64 bit system and used it to upgraged to JH7. After three failed attempts at doing OTA upgrading to JH7 and reading about phones bricking after OTA updates I decided that Kies would be the safer route to go. I don't make much use of Kies otherwise. I wouldn't be considered a "power" Captivate or Kies user. I don't root. I don't even have an external Micro SD card installed in the phone yet. Haven't needed the space yet.

    Anyway, JH7 was installed and things were functioning just fine. When I heard that 2.2 was going to be pushed out to the Captivate soon I decided to hook the phone up to Kies. As usual Kies said there was an update available. Here's where things get convoluted.

    I installed the latest version of Kies but now Kies would just sit there and scan the phone but not connect, whereas it had connected about 30 minutes earlier with the older version of Kies. I thought maybe something from the Kies install had stomped on the driver (my job is SQA so bug hunts are my thing). So I uninstalled the driver and reinstalled it.

    Now the phone can't even connect to the computer properly. When I select a Kies connection from the phone, Windows 7 starts to connect but then throws an error that the "MTP Device Driver" failed to start.

    I uninstalled the driver and reinstalled. No luck. I reverted Kies back to the previous good version. No good. I wiped everything Captivate related off the system and re-installed. No good. I just couldn't get past this MTP Driver issue.

    I jumped on Google and started looking to see if this was a fairly common issue. You know it's a wide problem when Google autocompletes the phrase "Samsung Captivate MTP Driver" before you finish typing "MTP".

    I saw a lot of posts on the subject but not a lot of solutions that appeared to fit my particular situation. Some involved the Micro SD card, but as I already mentioned I don't have a Micro SD card. Another involved some particular issue concerning very long file extensions. I grabbed the utility that was written to look for long file extensions and did fine one such file on the phone. I deleted it. But I still couldn't get past the MTP issue.

    At this point I was starting to become resigned to the idea that I was going to be getting 2.2 OTA. But I had one last idea. I installed the driver and Kies on my parents 32 bit XP system and managed to get a connection with the Phone on Kies. This told me two things: 1) I could at least do an update via their system if absolutely necessary and 2) the problem wasn't on the phone, it was on my Windows 7 system.

    Then today I was poking around here and found a link to this driver page...

    Download Samsung MOBILES drivers - page 1 - sorted by date - Softpedia

    What made this interesting is that the Galaxy S drivers listed here are not the same drivers I got off the Samsung site. The drivers I had been using were dedicated Captivate drivers.

    The Samsung site drivers were these: SGH-i897_Captivate_USB_Drivers_5_02_0_2

    But the drivers on the above site were a different package designed for the Galaxy S class as a whole. Deciding at this point that it couldn't hurt, I decided to download the 64 bit version of the Galaxy S driver and install it.

    I installed it and then, with Kies uninstalled, I connected the phone to the computer and selected a Kies connection. This time I didn't get any MTP crapola. So then I installed Kies, the latest version I had.

    During the Kies installation I left the phone connected to the PC. What I found interesting is that Kies does its own driver install during software installation. This was a surprise discovery to me, though I don't know how significant. Previously I had always installed Kies with the phone not connected so the driver install occurred off my radar screen because there was no outward indication that a driver install occurred (why would there be since no phone was connected?)

    Another interesting aspect to this is that the Kies driver install goes out to Windows Update to look for a driver (and finds one!). Again I don't know how significant this is but this, like Kies doing a driver update, was previously an unknown scenario to me. All these unknown scenarios just add more complexity to debugging a problem since if you don't know about them you don't know to check.

    Anyway, very long story short, I now have Kies connecting to my phone again on Windows 7 64. Switching drivers apparently stomped out the MTP driver issue. Just a thought for anyone else out there who might be as frustrated as I once was.


  2. pfrobinson

    pfrobinson New Member

    Nov 9, 2010
    Just a quick ?; what is a "Kies Connection"? As in started a...
    Thanks, I have been wrestling with this for two weeks.
  3. abelovedwolf

    abelovedwolf New Member

    Jun 25, 2011
    I have been going through this problem for weeks, today i found the solution, apparently the cords are weak and half way die, try using a different cord and or ordering a new one, this worked for me after installing uninstalling all day long no work around worked, changed cables and instantly got a connection. happy connecting :D

Share This Page