1. Are you ready for the Galaxy S20? Here is everything we know so far!

Another Return to S-On and Stock

Discussion in 'Android Devices' started by NorthernNoel, Dec 29, 2011.

  1. NorthernNoel

    NorthernNoel Member
    Thread Starter

    Looks as though my Desire needs another return to HTC for repair :mad: (flashlight issue) and I'm trying to restore it to stock. It's a Vodafone branded Desire so I've downloaded this RUU and run it. Shipped ROMs

    On rebooting after running it I have the HTC logo with a black bar on the top/bottom. If I then press the power button it makes the HTC boot noise and the screen goes black.

    If I go into the bootloader it still appears to be S-Off. I used Revolutionary to S-Off it and the H-Boot is 6.93.1002. I've done a bit of searching about and found that I may need to run a downgrade.img? Although I've struggled to find where I can get it from and if that's what I actually should be doing.

    Any ideas would be much appreciated cheers :D
     



    1. Download the Forums for Android™ app!


      Download

       
  2. shauny13

    shauny13 Android Expert

    NorthernNoel likes this.
  3. NorthernNoel

    NorthernNoel Member
    Thread Starter

    Thanks Shauny. I've now got that installed so the bootloader is Alpharev with HBoot 6.93.9999. Next step is trying to get an RUU installed. I've run the exe as before but as I can't get it to boot it can't find the phone to install. I've now downloaded the zip from here http://liveimage.htc.com/OTA_Bravo_Vodafone_UK_1.19.161.5_1.15.161.4_release_P2q1fwy34gicxsiqaq.zip

    I then copied this to the sd card, renamed it to PB99IMG.zip and it installed but it's still no different. Any ideas what I should try next?
     
  4. NorthernNoel

    NorthernNoel Member
    Thread Starter

    I've got a bit further, managed to get the RUU to run but am now getting a bootloader version error with the Vodafone RUU. Is there something I'm missing or do I need another RUU?
     
  5. shauny13

    shauny13 Android Expert

    I think you need one that starts with a 2. 1 is eclair I believe. You could try the HTC official upgrade from htc developers site.
     
  6. SUroot

    SUroot Extreme Android User

  7. NorthernNoel

    NorthernNoel Member
    Thread Starter

    Thanks SUroot. Upon coming back to it the phone now will not boot at all. I can get it to vibrate and it looks as though it can get into hboot as I get android bootloader interface listed in drivers on my pc. The last thing I had done is run the ruu in the first post that wouldn't install which is an Eclair one. When running the Froyo one now I get 170: usb connection error.
     
  8. NorthernNoel

    NorthernNoel Member
    Thread Starter

    Reading a bit more looks as though i've created an SLCD brick :mad:

    It won't interact with adb but I can get to it via fastboot.

    If I run 'fastboot oem gencheckpt' I get the following:
    Code (Text):
    1.                               ... INFOsetup_tag addr=0xA0000100 cmdline add=0x8E
    2. 07D944
    3. INFOTAG:Ramdisk OK
    4. INFOTAG:smi ok, size = 0
    5. INFOTAG:hwid 0x0
    6. INFOTAG:skuid 0x26A12
    7. INFOTAG:hero panel = 0x0
    8. INFOTAG:engineerid = 0x0
    9. INFOMCP dual-die
    10. INFOMCP dual-die
    11. INFOTAG:mono-die = 0x0
    12. INFODevice CID is not super CID
    13. INFOCID is VODAP001
    14. INFOsetting->cid::VODAP001
    15. INFOserial number: REMOVED
    16. INFOcommandline from head: no_console_suspend=1
    17. INFOcommand line length =425
    18. INFOactive commandline: board_bravo.disable_uart3=0 board_bravo.
    19. INFOusb_h2w_sw=0 board_bravo.disable_sdcard=0 diag.enabled=0 boa
    20. INFOrd_bravo.debug_uart=0 smisize=0 userdata_sel=0 androidboot.e
    21. INFOmmc=false  androidboot.baseband=4.06.00.02_2 androidboot.cid
    22. INFO=VODAP001 androidboot.carrier=VODA-UK androidboot.mid=PB9920
    23. INFO000 androidboot.keycaps=qwerty androidboot.mode=recovery and
    24. INFOroidboot.serialno=REMOVED androidboot.bootloader=0.80.0
    25. INFO000 no_console_suspend=1
    26. INFOaARM_Partion[0].name=misc
    27. INFOaARM_Partion[1].name=recovery
    28. INFOaARM_Partion[2].name=boot
    29. INFOaARM_Partion[3].name=system
    30. INFOaARM_Partion[4].name=cache
    31. INFOaARM_Partion[5].name=userdata
    32. INFOpartition number=6
    33. INFOValid partition num=6
    34. INFOmpu_nand_acpu_rw 23A 1000
    35. INFOjump_to_kernel: machine_id(2457), tags_addr(0x20000100), ker
    36. INFOnel_addr(0x20008000)
    37. INFO-------------------hboot boot time:886676 msec
    38. FAILED (status read failed (Too many links))
    39. finished. total time: 7.497s
    40.  
    I've then tried to push the update using the following command 'fastboot update PB99IMG.zip'

    This gives me the following:

    Code (Text):
    1. Whoops: didn't find expected signature
    2. read_central_directory_entry failed
    3. error: failed to access zipdata in '
     
  9. NorthernNoel

    NorthernNoel Member
    Thread Starter

    Well I think I've taken it as far as I can so looks as though i've got a brick :(

    Yesterday went and purchased myself an Orange Monte Carlo from Argos for
     
  10. SUroot

    SUroot Extreme Android User

    Yeah you need to steer clear of eclaire ones.

    Fixing an SLCD brick is easy. You just need to put the (Correct) PB99IMG.zip on SD card and boot to hboot. There are threads on this all over.
     
  11. NorthernNoel

    NorthernNoel Member
    Thread Starter

    Ok I'm going to try and sit down with it again soon and get it up and running. After reading several guides I think this is what I need to do as listed below. Does this sound correct? The only thing that I'm not sure about is that the PB99IMG.zip file that I've downloaded will not open on the PC. Should that be the case? I get an error saying that 'The compressed (zipped) Folder ... is invalid.

    Thanks as always :D

    Create a Goldcard
    Following this guide: http://androidforums.com/desire-all-things-root/117710-goldcard-tool.html

    Download the PB99IMG.zip file
    Get that from here: Shipped ROMs

    Install the PB99IMG.zip file
    From XDA here: [GUIDE] How to Unroot an HTC Desire - xda-developers

    Press Vol- , then w/o releasing it, press Power button + Vol
     
  12. SUroot

    SUroot Extreme Android User

    You still need to sort the hboot out.

    Yes you shoudl be able to open the zip.
     
    NorthernNoel likes this.
  13. NorthernNoel

    NorthernNoel Member
    Thread Starter


    What do I need to do to fix hboot? Does anyone have a link to a working zip? I've tried it on different computers/internet connections but still can't open the zip.

    Thanks again
     
  14. SUroot

    SUroot Extreme Android User

    Not sure what your facination with zips is.

    the downgrade image is on the alpharev website and you fastboot flash it useing command line as per my "adb and fastboot faq" (skip the adb stuff as this is not relevant).

    Download the latest unbranded RUU from HTCdev.com (HTC Still gifve warranty, even though you were branded) and run that .exe from your windows PC whilst the phoen is on teh fastboot screen. You must do the downgrade image first.

    Zips are crap ergo they should be a last resort.
     
  15. Rastaman-FB

    Rastaman-FB Extreme Android User

    and make sure you check the md5 of the downgrader before you fastboot flash. if your zips are getting corrupt then the hboot might too. you cant want to flash corrupt hboots or hboot zips. it will brick you
     
    SUroot likes this.
  16. NorthernNoel

    NorthernNoel Member
    Thread Starter

    Ok had another go with it tonight. Fastboot shows the device connected but I get the following:

    C:\android\tools>fastboot flash hboot c:\downgrade.img
    sending 'hboot' (512 KB)... OKAY [ 0.094s]
    writing 'hboot'... INFOsignature checking...
    FAILED (remote: signature verify fail)
    finished. total time: 0.156s
     
  17. Rastaman-FB

    Rastaman-FB Extreme Android User

    you are not booted to fastboot, you are booted to bootloader
    when you are in that menu select fastboot
     
  18. NorthernNoel

    NorthernNoel Member
    Thread Starter

    Ok think i'm in fastboot now but get another error:

    C:\android\tools>fastboot flash hboot c:\downgrade.img
    sending 'hboot' (512 KB)... FAILED (status malformed (1 bytes))
    finished. total time: 0.000s

    Cheers for all you help with this btw.
     
  19. SUroot

    SUroot Extreme Android User

    Should say fastboot on the screen if you are?
     
  20. NorthernNoel

    NorthernNoel Member
    Thread Starter

    I haven't got the display working yet so doing it blind. I'm holding the Vol down button and pressing power on. At that point I know I'm getting into hboot as I get Android bootloader interface in my device manager. If I press the power button after a few seconds then I get the driver changing to my htc. I tried pressing the trackball to select fastboot instead to get my last error. If I type fastboot devices the phone is listed
     
  21. Hadron

    Hadron Smoke me a kipper...
    VIP Member

    Trackpad selection doesn't work on the hboot screen.
     
  22. SUroot

    SUroot Extreme Android User

    Indeed.

    Back and power from off goes straight to fastboot. Does Back button work?
     
  23. NorthernNoel

    NorthernNoel Member
    Thread Starter

    I'll give the back button a go tonight cheers.
     
  24. NorthernNoel

    NorthernNoel Member
    Thread Starter

    I've tried back plus power tonight and no further i'm afraid. I get the remote: signature verify fail again. In device manager it's listed as My HTC
     
  25. SUroot

    SUroot Extreme Android User

    when you type "fastboot devices" what does it say?
     

HTC Desire Forum

Features and specs are not yet known.

unknown
Release Date
0
Reviews
Loading...
Similar Threads - Another Return Stock
  1. Loco95
    Replies:
    9
    Views:
    474
  2. Biffos
    Replies:
    13
    Views:
    506
  3. Alex Ethridge
    Replies:
    14
    Views:
    1,033
  4. satimis
    Replies:
    8
    Views:
    1,407
  5. Rgarner
    Replies:
    23
    Views:
    2,936
  6. Bagrov
    Replies:
    5
    Views:
    1,814
  7. Kharl
    Replies:
    1
    Views:
    745
  8. markdoc
    Replies:
    1
    Views:
    1,275
  9. louis2008
    Replies:
    7
    Views:
    3,462
  10. Sunny Rio
    Replies:
    12
    Views:
    4,016

Share This Page

Loading...