1. Are you ready for the Galaxy S20? Here is everything we know so far!

Answers for USB connection issues

Discussion in 'Android Devices' started by ogami_ito, Aug 12, 2010.

  1. ogami_ito

    ogami_ito Newbie
    Thread Starter


    I'm starting this thread because I DON'T have the answer to the USB connection issues my phone is having - how to attach USB in such a way that I can do an upgrade. But, instead of asking again about if anyone has an answer, I'm preparing all that I have learned in this thread.

    1. How to select USB mode.
    There are different USB modes. To access the most common, go to Sttings>About Phone> USB Settings. I select "Ask on Connection" so I have a choice when I connect, although for me, the only mode that currently works is Mass Storage mode. When you plug the phone in, go to the home screen and you will be asked which connection mode you want.

    There is also a "Debugging" mode, which is usefull for somethings, like Panda PC Suite. Go to settings>applications>development>check USB debuging. There are some esoteric uses of this; I only know that Panda PC Suite (which I don't use actually) works in this mode. SOME DRIVERS may be necessary in this mode (more on that later)

    There is also "Download" mode and "Recovery Mode". These are not USB modes, but I'm detailing them here anyway. Recovery mode is achieved by starting the phone while holding volume up+power+home key. This will activate a menu, which you can use to select an "update.zip" file, which will "Root" your phone. Download mode is achieved by starting with volume down+ power+home. This is used to flash a new firmware on the phone. However, I cannot connect to my phone with the drivers I have installed.

    2. How to connect in mass storage mode.
    This will allow you to connect in such a way that your computer will see the Galaxy as a USB storage device, so you could put (or take from) music and pictures on the device. Some people have problems with this, but I suspect that most of the time, people just don't know the steps. To connect this way, connect with USB cable to PC. If you set the USB mode to "Ask", then it should have a pop-up in the home screen where you select "Mass Storage". Now here is a step I think some people may miss. Go to the status bar. There will be a message saying USB Connected. In THAT message (if you connected in mass storage mode, it will say "Select to Copy Files to/from computer". You need t oselect this. Then push the button that says "Mount". Then wait 5 seconds.

    3. USB Drivers / How to connect to Kies.

    I don't know how to connect. But here are some answers I found...none of which worked for me.

    -First Install the drivers. This can be done when you install Kies. This can be done by installing from other sources. Here is a link for a place that has Kies, and also stand-alone drivers, and generic drivers from the Android development tool kit:
    https://www.wuala.com/Samsung Galaxy S/Drivers & Software?key=AfzUZSU4SpKU

    Another link address:samsungdriver.rar

    Another: ROOTING Samsung Galaxy S HOW-TO - www.hardwarezone.com.sg

    Another: Samsung Galaxy S Windows Driver - download tag - Softpedia

    You can download Kies, tell it to re-download the drivers, and then manually install the drivers from the USB drivers folder which is inside the Kies application folder.

    Note that if you manually install drivers and use Windows XP, use the ".86" version of drivers.

    If you are like me, there may be problems when you connect and not all the drivers will load. Or the MTP (whatever that is) will not load. Here are some possible solutions.

    -Reformat SD card. This. May. Work. for some people. Its easy to do. It just gets rid of part of the info on the card... the part that you could see in USB mass storage mode. So everything there could be backed up by simply first connecting in Mass Storage mode (above) and then copying the files onto your computer. To reformat the SD card, go to Settings> SD Card and Phone Storage? Unmount SD card (wait 5 seconds) >Formate card. Then you need to "Mount SD card". Some people claim that some improperly named files on the card interfere with drivers.

    -"I've had no issues whatsoever to connect, after installing Kies and the x64 drivers a few posts up, (Kies also updated itself), I connected the phone in mass storage mode, it loaded some drivers and I could access it from Windows. Disconnected, enabled USB debugging mode, reconnected, it installed more drivers. adb works fine. Unmounted and disconnected again, and turned off USB debugging mode. Reconnected and this time chose Kies. Again installed more drivers (MTP drivers), I started Kies, it found the phone, connects with no problems and all functions work fine.
    adb, mass storage, debug, kies, you name it, it all works great.
    Windows 7 x64, XXJF3 firmware. (just got it today, so happy)" (I 'm not sure if I tried this exactly this way but I will try again)

    -"I finally managed to figure out what is going on... the Windows MTP driver cannot handle the extra sd-card-partitions. Several people report they have to unmount/remove their external sdcard, but I have to unmount my internal sdcard to get it to work (I don't have an external sdcard.). What may be of influence is that I have the "special" version of Galaxy S which has 16GB internal memory, instead of 8GB. After unmounting the internal sdcard Samsung Kies could suddenly connect properly to the phone."

    -Use Regedit to delete all references to Nokia software. This is dangerous for your computer. In Windows XP, go to run> type "regedit", then open find box and type in Nokia. If you used another software suite, try deleting registry entries to that .

    -More things (I have not tried but will report back if it works)... cleaning internet cache.

    -try another USB jack. I have not done this because sometimes when I wiggle the back of my computer my computer explodes

    -Sacrifice chicken to Satan. To use this procces, first draw a pentagram on the floor to protect yourself. Wear safty goggles and use a sharp knife.

    -[from snapper.fishes]"1) Install the Windows Mobile Device Centre (or Micrsoft Activesync if you are using XP). Kies is missing a vital driver which can be obtained through WMDC.
    2) Turn off your wifi and bluetooth before plugging in your phone in."

    4. Here are links to other posts on this topic:

    Samsung Galaxy S Problems - Android @ MoDaCo

    5. Can Firmware be updated without connecting?

    Assume you don't have over -the-air installation of firmware. I read this thread ([RECOVERY] ClockworkMod Recovery for Galaxy S i9000 (FINAL! SAFE!) - xda-developers) about Rom manager and clock-work recovery. I'm wondering if this could be used to avoid needing Odin.

    [edit on August 22,2010]

    Unfortunately, I'm still having the same problem. But... I think this may be TWO problems:

    1. MTP software initialization
    2. Samsung USB Android Modem installation.

    MTP is something that runs on your phone... but only when the computer tell it too. I didn't have this running before. I unmounted my internal SD card AND changed to the default Samsung TouchWiz launcher, and my phone will go into MTP mode. Kies sort of sees the phone, and tries to
    "Connecting to Device...please wait" mode for ever. I think this is because the damn Android USB Modem driver still does not install properly. I tried deleting it. Didn't work still.

    Next I will follow the advice on this thread:

  2. snapper.fishes

    snapper.fishes Android Expert

    Here's two facts that no one ever freaking remembers. Dunno why.

    1) Install the Windows Mobile Device Centre (or Micrsoft Activesync if you are using XP). Kies is missing a vital driver which can be obtained through WMDC.
    2) Turn off your wifi and bluetooth before plugging in your phone in.
  3. ogami_ito

    ogami_ito Newbie
    Thread Starter

    Huh. I did not see anywhere else the activesync advice. Question is ... is this neccessary for SGS, or just for SGS+Kies. I will download activesync and see if this helps.
  4. DroidRick

    DroidRick Android Enthusiast

    Thanks Og for your comprehensive post!

    You've done a lot of homework, but all for naught it seems. :(

    I've had my phone for a few days now but still can't connect it to my Win XP computers!

    I had been avoiding installing KIES because of the space and resources it takes up.

    I shifted to my netbook and was able (one time) to actually make a connection. I don't know what it was that worked, because now I can't do it anymore. I didn't load any software, drivers onto the netbook.

    My desktop has never made the connection.
    Yesterday I broke down and installed KIES.
    The .exe was around 145M.

    It took more than 30 minutes to install. It was downloading stuff from the net during the install. I did the full install.
    When it was complete it took up more than 2G of space!
    I still couldn't connect, even using KIES!

    I have just 25G space for my c: drive so I can't spare 2G on software that doesn't work. I uninstalled KIES but it didn't free up more than 1.5 G!
    So I actually re-imaged my c: drive to get rid of it!

    I'm back to square one. I'd simply like to get the drivers required to recognize the I9000 in Win XP (SP2).

    There are so many confusing issues:
    -you can mount by going into Settings, but you can also mount before/after that by swiping down from the top of the screen and choosing mount/unmount.
    - plus a bunch of other very confusing issues...

    Please help me someone!!!
    This is so frustrating!
  5. ogami_ito

    ogami_ito Newbie
    Thread Starter

    In spite of all which I have written, I still can't get Kies to recognize my phone.

    About this quoted above...That's interface issue. There are more than one way of doing things. Follow the method I said above, to me, is easiers.

    1. set USB mode to ask
    2. After plug phone in to usb, select mass storage mode
    3. in the notification area (when you slide from top down), click where it says USB.
    4. Select mount.
    CdnGoose and melll like this.
  6. ogami_ito

    ogami_ito Newbie
    Thread Starter

    deleted post
  7. melll

    melll Android Enthusiast

    O M G.... I have been having issues with this for 2 days now and nothing I tried worked. When I connected my phone to USB it would just flash the "Connecting status" and would never connect.

    This worked like a charm. Thanks so much for this awesome post :D
    skippergeoff and teis1 like this.
  8. ogami_ito

    ogami_ito Newbie
    Thread Starter

    If there are any computer people out there who can help, it would be appreciated.

    I followed instructions about MTP issues. For one, I completely downgraded windows media player. I found a pdf file about MTP issues, which I have attached here ( I think.) Unfortunately, I still have MTP problems. Now when I try to reinstall the MTP, I get some error about WPD failure.

    I found this document on the web about MTP and WPD... but I don't understand it... its way too technical for me... but I'm putting the link here for anyone who may be technically inclined.

    PlaysForSure portable media players are not automatically upgraded to MTP when you install third-party media device applications

    Attached Files:

  9. DroidRick

    DroidRick Android Enthusiast

    I've tried everything, including installing KIES, just the drivers, etc.
    Nothing is working.
    Bummer. I just got the phone on Monday.
  10. ogami_ito

    ogami_ito Newbie
    Thread Starter

    You are not able to connect in Mass Storage mode, using the above procedure, or not able to connect via Kies? What happens?
  11. DroidRick

    DroidRick Android Enthusiast

    Maybe we can brainstorm together on this one?
    A few pieces of starter info. I'm trying to connect on both desktop (Win XP Media Center Edition v5.1 SP2) and netbook (Win XP Pro v5.1 SP2).

    I installed KIES (full install) and couldn't connect after selecting KIES on the phone).
    I am not able to connect using Mass Storage mode either.

    I was able to connect ONE time on the netbook and get into the phone folders. I believe this was after installing Samsung New PC Studio 3.
    But after that, no dice.

    When I first started trying to connect on the desktop and netbook I would get the typical Windows USB connection messages: unknown USB device, would you like to install drivers from this location? etc. etc.
    That was good! It showed promise.

    Then after a few times I stopped getting those messages from both devices. During that period, I made a partial connection on each device.
    I could see two new drives (internal and external SD). But when I clicked on them it showed no space available. Braindead basically.

    Something possibly related that I can't figure out at all.
    When I go into 'My Files' /sdcard/ will only show SD internal IF my external SD card is not inside the phone. If my SD external card is inside the phone then it shows the SD external only, not the SD internal! Why?

    Also very confusing: When I pull down the menu from the top on home screen and select Ongoing: USB connected: Select to copy files to/from computer, then it asks to Mount.
    I choose Mount, go to 'My Files' and it says "Your phone does not have an SD card inside!" WTF? (It says that with or without an external SD card inside).

    Also strange, when I chose Mount, it then starts to sever the USB connection with messages scrolling by at the top.

    So to summarize (this is strictly from the phone's side)
    when I connect via Mass Storage it seems to indicate that a USB connection is made. But when I select Mount, the USB connection is terminated!
  12. ogami_ito

    ogami_ito Newbie
    Thread Starter

    I assume you mean you connected in Kies mode one time. Could this be because you put stuff on the SD card which blocked MTP on the phone? As I said in previous post, there seems to be TWO issues which may be interconnected.... MTP running on the phone, and PC driver installation, which may be blocked by the MTP issue. It sounds that you have both problems.
    I think the answer to the MTP on-the-phone problem is clear though. I think we don't have to actually reformat the SD card (which was one of the options mentioned above), but rather, just unmount the card. AND make sure you go back to the Samsung TouchWiz launcher while connecting in Kies mode. Yes, I figured out that Launcher Pro and other launchers can block MTP on the phone.

    This won't solve the PC driver issue though.

    So, I don't know about this. But lets first categorize and summarize. This is a Mass Storage Mode problem. What you are seeing is:
    -you are not seeing the internal card if the external is attached (have no idea about this)
    -When you mount in USB mass storage mode, and then go to browse files on the phone, it does not see the card (I have a feeling that's because the card is now used by PC, not by phone... note that this "mount" in USB mass storage mode is mounting for the PC, not for your phone)
    -When you mount in USB mass storage mode, the USB connection gets severed. I assume that the PC does not see the SD card then?

    Some of this I'm not sure are really problems. But lets assume these are problems. My advice:
    1. Try connecting with TouchWiz on. Close wifi and bluetooth. See if this helps.
    2. If your attempting to connect in mass storage mode, you have other options. Bluetooth file transfer. There are wifi file transfer methods that work just a well too I believe... better than USB connection because you won't have to mount / unmount anything.

    3. This may be a USB mass storage Driver issue on your PC. In addition to putting phone in TouchWiz launcher mode, turning off wifi, etc...
    Go into your PC device manager. Turn view to show hidden / unconnected devices. See if you have a lot of greyed-out USB Mass Storage Devices on there. While there, see if you have a lot of other USB garbage like USB drivers for Nokia phones and Nokia PC suite. Delete the garbage.
  13. DroidRick

    DroidRick Android Enthusiast

    I installed KIES very briefly on my desktop. Could not connect with it.
    Not sure what MTP is all about.

    I did reformat the internal SD card a few times, for the heck of it, it didn't help. As I mentioned I no longer have Kies (and won't be installing it again)
    so that isn't an option anymore for me.

    This has been the only way I have been trying to connect.

    I thought of trying Bluetooth last night actually. I just tried it now and it works, although my Pocket PC side is very slow. So at least I have one method to fall back on while we work this out.

    I just checked and the USB device list is very clean. No Nokia or other junk there.
  14. ogami_ito

    ogami_ito Newbie
    Thread Starter

    edit: never mind... you have been *trying* to connect, but cannot connect this way.

    So... you cannot connect in mass storage mode. BUT, you can "mount" your SD card when you plug in to the USB.

    Just to be clear here (and sorry for drawing this out / being pedantic)... you understand the difference between mounting in your phone and mounting when doing USB, right? The former is done in settings and is so the phone sees the SD card. The latter is done when connected to PC, so that the PC can see SD card. I also assume you tried this after removing the "external" SD card, right?
  15. DroidRick

    DroidRick Android Enthusiast

    Almost. And this is pretty important actually. I have been able to connect ONE TIME on my netbook (near the beginning). I think I had just installed a Samsung New PC 'something' V3.0. I could connect and see the files on my phone from my netbook and access them.
    But now my netbook (and desktop) can't even see the phone when I connect the cable. There was a period when they did see the phone, but the two phone drives they saw were inaccessible.

    Yes, I cannot connect in Mass Store mode. Well I am not clear yet on this whole mounting aspect (so I don't mind your being pedantic).

    First, my SD card/s shows it/they is/are mounted when I go into settings.
    Next when I plug in the USB cable I am asked how I'd like to connect.
    I choose Mass Storage. Then it goes through motions of 'connecting'.

    On the home page I pull down the quick access menu and tap on the connection and it shows Ongoing/USB connected (select to copy files to your computer). I tap on that and then chose 'Mount'.
    after I chose 'Mount' nothing happens on my PC side (no recognition of the phone) and when I tap on 'My Files' on the phone, it tells me I don't have an SD card inserted.

    Yes I tried it after removing the SD card but got the same results each time.
  16. toureiffel

    toureiffel Lurker

    I do not know if this is to help you, but I understand that your problem is related to bug the phone that Samsung has officially recognized ... (link of French Gizmodo post: Google Traduction)
  17. DroidRick

    DroidRick Android Enthusiast

    Thanks for your post Toureiffel!
    It really doesn't help though, as my situation doesn't involve files with long file names.

    What is interesting though, is that I have a French version of the Samsung I9000. I purchased it from a U.S. distributor (who didn't tell me he was sending me a French version). I thought I'd get a standard U.S. version.
    So it has a European power adapter etc. etc.
  18. lotreaglesfan

    lotreaglesfan Well-Known Member

    i am having the same problems that droidrick is experiencing. i have my mountain, on touchwiz, and being powered by my laptop. the phone says that it is plugged into my laptop and mountain, but it is not showing up AT ALL on my Windows 7 Professional 32 bit OS....

    something interesting is that it was letting me add stuff to my phone memory, but I installed KIES and after I did that it quit working... turning off my computer now to restart it and i will check back here tomorrow....
  19. lotreaglesfan

    lotreaglesfan Well-Known Member

    bump? please help? thanks
  20. psychocandy

    psychocandy Well-Known Member

    Why do you need to disable wifi? Whats that got to do with it?
  21. DroidRick

    DroidRick Android Enthusiast

    Change is good! Some progress?

    This time, for whatever reason, when I connected my phone to my Win XP system I got the new hardware found message etc.

    I went into my Win XP Device manager and found the following:

    -Network adapters
    Samsung Android USB Remote NDIS Network Device (with yellow exclamation point before it, which means there is a problem)

    It's using these old drivers which obviously don't work:

    Any idea how I can get the KEY drivers needed and point my system to them, so I can change the current drivers which don't work?
  22. DroidRick

    DroidRick Android Enthusiast

    Some more on this.
    The reason why the Samsung was showing up in Network adapters was because on connection I chose PC connection instead of Mass Storage.

    This time I changed to debug mode and then connected choosing Mass Storage.
    The result: Samsung Android USB composite device showed up under USB controllers, albeit with the yellow exclamation point again.

    So I'm getting somewhere slowly. Still need to find JUST the drivers for this I9000 and Win XP (not 2G of KIES bloatware).
  23. DroidRick

    DroidRick Android Enthusiast

    Success, finally!

    I wish I could tell you exactly what the magic bullet was, but it happened gradually. You know how you change something and it seems to help a little. So you change something else and it seems to be getting better? (see previous posts above)

    Here are the key steps that I can remember:

    -I went back and re-installed SAMSUNG_USB_Driver_for_Mobile_Phones_x86.exe.
    There are no messages given after the install completes, they're just drivers, not a program.
    -I put the I9000 into debug mode for USB connections (not sure if I need this now).
    -After connecting the phone to WinXP I went to phone's home screen, notification window and selected the USB connection and chose to Mount the drive(s).

    I can now see and access both the internal SD and the external SD! WOW! (no 2G of Kies needed)
  24. psychocandy

    psychocandy Well-Known Member

    It defines believe how Samsung could make such a mess of USB connection to their phone. For me it completely spoils what is otherwise a decent phone.
  25. Sanciman

    Sanciman Lurker

    Here is the key.
    USB mode works fine in debug mode.
    You can find it at settings/applications/development/
    (Hope, I remember well, my phone is in hungarian language)


Samsung Galaxy S Forum

Features and specs are not yet known.

Release Date

Share This Page