1. Check out our companion app, Forums for Android! Download from Google Play

Support any help appreciated... my phone is bricked.

Discussion in 'Android Devices' started by myerrod, Oct 30, 2010.

  1. myerrod

    myerrod New Member
    Thread Starter
    5

    Jul 18, 2010
    1
    0
    5
    so i was trying to flash a new spl to my eris when it turned off and now wont turn back on. the only sign of hope i have is the fact that when i plug my phone into charge without the battery in and then insert the battery the orange charging light comes on and sometimes when i push down on the end/power button it vibrates like its about to start up but never does. any help is greatly appreciated!
     

    Advertisement

  2. erisuser1

    erisuser1 Well-Known Member
    223

    Nov 11, 2009
    1,644
    759
    223
    Well, "new spl" is a little vague, but assuming that you mean the "hboot" or "ipl/spl" portion of the phones' firmware, I would assume that means you now have a shiny little brick. It can be sold on eBay "for parts" for $40-$60.

    Flashing the "hboot" (or IPL, or SPL) area of the Eris is the single most dangerous operation you can perform.

    The reason for this is that all other activities on the phone, including:

    - booting the normal OS
    - booting the recovery
    - entering fastboot, RUU, or hboot modes

    require that the 512 Kbyte bootloader firmware be in good shape. If you screw up the bootloader, you simply can not get to anything else, because the bootloader must execute first for anything else to happen.

    You can try all the standard button combinations to see if you can get something to happen:

    Vol-Down+End/Power (Hboot mode)
    Vol-Up+End/Power (Recovery mode if hboot is 1.49.xxxx)
    Send+End/Power (Fastboot mode)

    If nothing happens in any of those combinations, your phone is definitely a brick.

    It is embarrassing when something like this happens, but for the education of others, please consider providing some details, e.g.:

    - what is the exact file size in bytes of the file you tried to flash?
    - what is the MD5 checksum of the file you tried to flash?
    - If the file was located on your SD card, did you verify the above values for the copy of the file on your SD card before starting?
    - what method of flashing did you use?


    eu1
     

Share This Page

Loading...