1. Download our Official Android App: Forums for Android!

Root Any help with Rooting a Droid 2 Global?

Discussion in 'Android Devices' started by Altius, Feb 17, 2011.

  1. Altius

    Altius Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Feb 17, 2011

    Feb 17, 2011
    1
    0
    5
    I tried yesterday with Z4root, and I downloaded a rom that completely disable my 3g, and wouldn't let me turn off airplane mode, no matter what I changed the ROM to, nothing worked, not even a hard reset,


    I have one in the mail from Asurion, and I would love to successfully root t:)
     

    Advertisement

  2. NiceGuysFinishLast

    NiceGuysFinishLast Android Enthusiast
    Rank:
    None
    Points:
    73
    Posts:
    472
    Joined:
    Dec 11, 2010

    Dec 11, 2010
    472
    73
    73
    FL
    A. You should have SBFd your phone, it would have saved you the trouble of mailing in your phone. B. You say you tried yesterday, which implies that Z4root didn't work.. But then you say you installed a ROM, which you can only do if you're rooted so... Z4 must have worked? C. There is only one stable ROM for the D2G right now and that's Fission 2.5.3. Or you can flash D2 ROMs and use the ROMer tool made by Team Get R Done. If you flashed anything else, you're lucky you didn't brick your phone. D. Z4root is the best app for rooting the D2G. It's one click root and unroot. If it doesn't root the first time, just restart your phone and try again, it doesn't always work the first time.
     
  3. jeaucamom

    jeaucamom Member
    Rank:
    None
    Points:
    15
    Posts:
    31
    Joined:
    Feb 27, 2011

    Feb 27, 2011
    31
    0
    15
    I just got my d2g yesterday... it was a cpo from vzw... it actually came with 3g mobile that was working.. I guess they got wise cuz when I try to connect now, it takes me straight to the sign up for hotspot page.... and that was the whole reason I got this phone....

    So.. I have rooted an HTC Eris with oneclick and it was easy... but I can't figure out 2 things:

    1. Is there ANY way to wireless tether with d2g without root?

    2. Is there an EASY way to root AND unroot d2g.. that even a dufus could do???? I can not find z4root on app market. Is it something you download on web?

    Thanks for any help..
     
  4. NiceGuysFinishLast

    NiceGuysFinishLast Android Enthusiast
    Rank:
    None
    Points:
    73
    Posts:
    472
    Joined:
    Dec 11, 2010

    Dec 11, 2010
    472
    73
    73
    FL
    1. Not that I know of.
    2. Go to forums.xdadevelopers.com and browse around, it's available for download there. You download it to your SD card and find it in your file manager and open it. You'll have to change a setting to allow non-market applications, it will prompt you. You want to use the permanent root option, as the temporary root goes away when you reboot, and is often reported to not work properly. The app can take a minute or so, but if it takes longer than that, just exit it, reboot your phone, and try again. Sometimes these programs just don't work the first time, but z4root has worked the first time for me 99% of the time I've used it.
     
  5. jeaucamom

    jeaucamom Member
    Rank:
    None
    Points:
    15
    Posts:
    31
    Joined:
    Feb 27, 2011

    Feb 27, 2011
    31
    0
    15
    Thanks.. Got it done!! But I used the temporary one.. It worked on third try...

    I used the temp one cuz I didn't know if the permanent one is Unrootable. Is it? If it is.. I will switch to that in a jiffy.. thanks
     
  6. NiceGuysFinishLast

    NiceGuysFinishLast Android Enthusiast
    Rank:
    None
    Points:
    73
    Posts:
    472
    Joined:
    Dec 11, 2010

    Dec 11, 2010
    472
    73
    73
    FL
    Yeah, after you root, when you run z4root you get the options to re-root and unroot.
     
  7. Bugly

    Bugly Android Expert
    Rank:
    None
    Points:
    143
    Posts:
    1,057
    Joined:
    Jan 30, 2011

    Jan 30, 2011
    1,057
    104
    143
    Male
    VW mechanic
    Tacoma, Washington
    Tip to remember: when using Z4, always reboot your device just prior to running the program, it doesn't like to run unless it is a fresh start.
     
  8. superspiderman

    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Apr 25, 2011

    Apr 25, 2011
    2
    0
    5
    will the z4 root work on the d2g with system version 2.4.330 and android version 2.2
     
  9. stephejo

    stephejo Member
    Rank:
    None
    Points:
    36
    Posts:
    59
    Joined:
    Dec 27, 2009

    Dec 27, 2009
    59
    1
    36
    Atlanta, GA
    Yes.

    I am running stock 2.2 / v2.4.330 on a Droid2Global and it installed and rooted just fine.

    Remember to do a full reboot before running it. Also, the root exploit is very slow so let it run. It is not stuck and will complete the root.
     
  10. threadreaper

    threadreaper Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Apr 20, 2011

    Apr 20, 2011
    1
    0
    5
    I had many problems trying to get my d2g rooted and get a custom rom installed. However, the biggest problem was that I had a hard time finding good information. A lot of what is here is either outdated or does not apply to the d2g.

    As others in this thread have suggested the z4root app does work on a fully updated stock d2g. After getting root through z4root, you should download ROM Manager from the Market as well as d2/dx bootstrapper. Flash ClockworkMOD Recovery from ROM Manager, and then use the bootstrapper to bootstrap your recovery. Search these forums for a download of Fission 2.4.3 (please note that's 2.4.3, not 2.5.3 as previously mentioned in this thread) and copy the .zip to your SD card. I had trouble getting ROM Manager to flash it, so I would suggest booting your phone into recovery (easiest way is to tap "reboot recovery" from the bootstrapper app) and then flash Fission 2.4.3 manually from there. Any other d2 rom besides Fission 2.4.3 will lock your phone in airplane mode, screw up your keyboard, and lots of other neat stuff.

    Hope this helps.
     
  11. NiceGuysFinishLast

    NiceGuysFinishLast Android Enthusiast
    Rank:
    None
    Points:
    73
    Posts:
    472
    Joined:
    Dec 11, 2010

    Dec 11, 2010
    472
    73
    73
    FL
    You don't need to flash ROM manager with a D2G, and this is actually not recommended. Koush's D2 bootstrapper installs Clockwork Recovery. Installing ROM manager is an unnecessary step, and ROM manager has proven unstable with D2s and D2Gs.
     
  12. stephejo

    stephejo Member
    Rank:
    None
    Points:
    36
    Posts:
    59
    Joined:
    Dec 27, 2009

    Dec 27, 2009
    59
    1
    36
    Atlanta, GA
    I have rooted and customized before on my Droid original. It is a critical work phone so I don't need any reliability issues.

    If I only want to overclock using SetCPU, is there any reason to run d2/dx bootstrapper (e.g., backing up)?

    I am not interested in any custom ROMs.

    If so, can someone offer a step by step on d2/dx bootstrapper and whatever else I need to do.
     
  13. NiceGuysFinishLast

    NiceGuysFinishLast Android Enthusiast
    Rank:
    None
    Points:
    73
    Posts:
    472
    Joined:
    Dec 11, 2010

    Dec 11, 2010
    472
    73
    73
    FL
    D2 bootstrapper will be necessary for nandroid backups (it flashes clockwork recovery, which lets you make them)

    You also can't use JUST SetCPU to overclock. SetCPU can set profiles, but it can't overclock. You'll want to use quickclock or Jrummy's Overclock app or droid overclock to increase your speed, and then possibly setCPU to change your profiles (screen off, charging, low battery, etc)
     
  14. stephejo

    stephejo Member
    Rank:
    None
    Points:
    36
    Posts:
    59
    Joined:
    Dec 27, 2009

    Dec 27, 2009
    59
    1
    36
    Atlanta, GA
    Where can I find Koush's D2 Bootstrapper available (and safe)?

    Thanks!
     
  15. NiceGuysFinishLast

    NiceGuysFinishLast Android Enthusiast
    Rank:
    None
    Points:
    73
    Posts:
    472
    Joined:
    Dec 11, 2010

    Dec 11, 2010
    472
    73
    73
    FL

    He's since pulled it from his website. If you google hard enough, you'll find your own answers.
     
  16. stephejo

    stephejo Member
    Rank:
    None
    Points:
    36
    Posts:
    59
    Joined:
    Dec 27, 2009

    Dec 27, 2009
    59
    1
    36
    Atlanta, GA

    I would rather get my information here where I trust the source. I apologize if my question was a bother.
     
  17. NiceGuysFinishLast

    NiceGuysFinishLast Android Enthusiast
    Rank:
    None
    Points:
    73
    Posts:
    472
    Joined:
    Dec 11, 2010

    Dec 11, 2010
    472
    73
    73
    FL

    It's not that it's a bother, it's that it's against forum rules to post links to pirated apps, or to discuss the pirating of paid apps. That's the most helpful I can be, according to the forum rules.

    Edit: I'm assuming you already knew you can get D2 Boostrapper on the market, and were asking where you can get it for free.
     
    stephejo likes this.
  18. stephejo

    stephejo Member
    Rank:
    None
    Points:
    36
    Posts:
    59
    Joined:
    Dec 27, 2009

    Dec 27, 2009
    59
    1
    36
    Atlanta, GA
    Actually no. I bought the paid version ($2) of Droid X Bootstrap on the Android Market. I support the devs financially often and never (intentionally) use pirated apps. I do know that I have sent Koush support several times.

    This forum is awesome and the knowledge here is great. Sorry for the misunderstanding.

    Thx
     
  19. stephejo

    stephejo Member
    Rank:
    None
    Points:
    36
    Posts:
    59
    Joined:
    Dec 27, 2009

    Dec 27, 2009
    59
    1
    36
    Atlanta, GA


    With that said, I am having problems getting Droid X Bootstrapper (DXB) to Flash Recovery.

    DXB installed ok. It asks for and I granted root access ok.
    When I select "Reboot Recovery" I get a Motorola reboot icon, but instead of getting Recovery, I get a black screen.
    When I pull the battery, it boots normally and not into Recovery.
    Every time I try DXB, the same process repeats.

    Thoughts?

    Honestly, I am just interested in overclocking my Droid 2 Global and not ROMs and I have seen no easy ways to OC the D2 yet. All of them involve long terminal commands. Maybe I'll wait until there are custom overclocking kernels?? Any overclocking advice?
     
  20. stephejo

    stephejo Member
    Rank:
    None
    Points:
    36
    Posts:
    59
    Joined:
    Dec 27, 2009

    Dec 27, 2009
    59
    1
    36
    Atlanta, GA
    See above and sorry for the multi-question...

    Do I have to SBF to use Droid X Bootstrap? I did SBF on my Droid 1 months ago but I really don't remember how I did it. Is there an "easy way" to get there (like z4root was for root)?
     
  21. NiceGuysFinishLast

    NiceGuysFinishLast Android Enthusiast
    Rank:
    None
    Points:
    73
    Posts:
    472
    Joined:
    Dec 11, 2010

    Dec 11, 2010
    472
    73
    73
    FL
    You need Droid TWO bootstrapper... not Droid X. They're different files.
     
    stephejo likes this.
  22. Bugly

    Bugly Android Expert
    Rank:
    None
    Points:
    143
    Posts:
    1,057
    Joined:
    Jan 30, 2011

    Jan 30, 2011
    1,057
    104
    143
    Male
    VW mechanic
    Tacoma, Washington
    true story, the DX one only works on the DX in FroYo, not GB, and the D2 will work on both DX and D2 in FroYo, and possibly D2 if GB comes to it.
     
  23. thevelveturd

    thevelveturd Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Dec 20, 2011

    Dec 20, 2011
    1
    0
    5
    I've been trying to root my d2g with z4root with no success. It gets to the point where it should be complete then the program crashes(not frozen) it just goes away and when I try to restart the brogram it says that quit unexpectedly. But it wont let me restart it unless I reboot the phone. But the same thing keeps happening every time. All I want is to do use wireless tether. Any help would be eternally appreciated.
     
  24. UncleVanya

    UncleVanya Member
    Rank:
    None
    Points:
    36
    Posts:
    39
    Joined:
    Dec 5, 2011

    Dec 5, 2011
    39
    2
    36
    Charlotte, NC
    Did you resolve this? Z4Root isn't for GB as I understand it. I used a different tool / process. I can find it if you need it.
     

Share This Page

Loading...