1. Download our Official Android App: Forums for Android!

Root Any Lollipop ROMs support Link2SD or Similar Solutions?

Discussion in 'Android Devices' started by hapworth, Feb 25, 2016.

  1. hapworth

    hapworth Newbie
    Thread Starter
    Rank:
    None
    Points:
    18
    Posts:
    29
    Joined:
    Feb 19, 2016

    Feb 19, 2016
    29
    11
    18
    Hey All,

    So after my rooting adventures, my next goal was to get Link2SD or something similar working. I don't feel like I have a lot of apps but my phone seems to disagree. I don't even play games on this thing.

    I'm currently using CarbonROM.

    I tried several apps, repartitioned, different filesystems, reformatting from both the apps2sd app, a several laptop using gparted, and the twrp (which never worked, it can't seem to locate the SD Card in the first place), I gave up. I thought, well Lollipop is supposed to be better about letting you move apps, right?

    I loved seeing Amazon Shopping without a grayed out Move to SD... as well as a ton of other apps. Unfortunately, I get the same error... not enough storage space.

    I have an empty 32gb SD Card, currently formatted to FAT32. The card can mount successfully now (there was a long stretch where it would be stuck in "Preparing SD Card; Checking for Errors" but reformatting on a separate machine did the trick).

    My understanding is because of the way Lollipop names the folders for SD Cards (now internal memory is sdcard0 and a true one is sdcard1) some apps are confused and "Move to SD" may just have you moving the app around Internal Memory (I believe I read this in the CarbonROM Thread). Someone vaguely mentioned that link2sd may work.

    Does anyone have any positive experiences setting this up or an alternative? I'm not a game player (though I'd like the option). I read about FolderMount as well.

    I'm also willing to drop down to a different type of ROM as long as it's not a battery suck and works fairly snappy.

    And taking a noob shot, why can't a ROM setup some sort of link from the old naming conventions and link them to the new sdcard1, etc?. I understand there is always the mistake some people make of trying to move system apps or things with widgets, but barring that, is this still a bad idea?

    Thanks!
    -h
     

    Advertisement

  2. hapworth

    hapworth Newbie
    Thread Starter
    Rank:
    None
    Points:
    18
    Posts:
    29
    Joined:
    Feb 19, 2016

    Feb 19, 2016
    29
    11
    18
    Also, update... I was looking through apps and AppMgr III said it supported up to Android 5.

    After installing it, under the Move Apps option, when I go over to SD Card, I see...

    "This device doesn't enable users moving apps to the SD card.

    Usually, it's because of the manufacture removes the function of moving apps to SD from Android, or a SD card is not inserted."

    The SD Card is definitely in there and mounted to /storage/sdcard1. I've also copied some files manually to the card itself and that seems to work too.

    What gives?

    -h
     
  3. umadzbro

    umadzbro Newbie
    Rank:
     #438
    Points:
    26
    Posts:
    32
    Joined:
    Sep 1, 2012

    Sep 1, 2012
    32
    7
    26
    Male
    You manually copied apps to your sd and it worked? man i tried everything i could. Even formatting the sd to different partitions of fat ext2/3/4 etc. Nothing would allow me to move apps to the SD or make a partition the new "internal" for apps to be installed. Even wasted money on link2sd.
     
  4. woodgaser

    woodgaser Well-Known Member
    Rank:
    None
    Points:
    53
    Posts:
    115
    Joined:
    Mar 11, 2013

    The new Cyanogenmod 13 rom gives this option to format your sd card as internal storage and move apps......BUT....you have to have a quality sd card...not a cheap skandisk ect...and it has to be FAST....my LEXAR 32gb( @ $25.00 made for digital cameras) that moves at 3mb per second...is too slow as my phone warned me while formating, said probably work but apps will stutter or stall while in use...recommend a faster SD card....you are also going to loose your mobility for the card...just a heads up.
     
  5. bcrichster

    bcrichster ROMinator
    Moderator
    Rank:
     #20
    Points:
    1,063
    Posts:
    7,067
    Joined:
    Jan 23, 2013

    Jan 23, 2013
    7,067
    5,636
    1,063
    Male
    Electrical, Electronics
    Florida
    I run SanDisk Extremes & Ultras: up to 90Mb/s, definitely worth it!
     
  6. woodgaser

    woodgaser Well-Known Member
    Rank:
    None
    Points:
    53
    Posts:
    115
    Joined:
    Mar 11, 2013

    had 2x 32 extremes go bad after a week....and a 64 ultra after a month..so went to Lexar...you start getting mount errors..
     

Share This Page

Loading...