1. Are you ready for the Galaxy S20? Here is everything we know so far!

Any SLR lens experts?

Discussion in 'Off Topic' started by dibblebill, Oct 18, 2014.

  1. dibblebill

    dibblebill Android Expert
    Thread Starter

    o I need a bit of advice. I've been using the same 18-55mm primary lens on my DSLR's since 2008. I got it wit ha Canon XTi. Lately, it's been acting up. I first noticed it last May during an outdoors shoot. This was with the XTi body. It began returning an "ERROR 99" unknown error. I thought I'd gotten water droplets in it, but got it working again. Then, while shooting a concert in September, it happened again. This time, with a Canon T5i, reporting that the contacts need cleaning. This time, it ONLY occurred while shooting in manual with a flash on. I could shoot normally without the flash, but as soon as I tried with, it failed. I reseated it and cleaned them and other things, no dice. Third time was while I had someone shooting photos at my gallery opening. Manual, no flash, nothing else in common, just started returning (on the T5i) a contacts error. Next time, T5i again, at a concert. This time shortly after swapping out my 75-300mm lens, it began doing it, but ONLY while in the 18-22mm range. I could shoot past that.

    Well, this morning, it began acting up with my Canon D20 as well. It was returning another ERR99 and not shooting, though there's a new behavior. Sometimes, the viewfinder would flicker repeatedly and then dim out. After that, I tried reseating it, cleaning it, etc., and no change. I finally managed to get my shots while zoomed in (this time past about 25mm). Any thoughts?
     


  2. mrex

    mrex Android Enthusiast

    I would have quessed that there is problem with a shutter, but if that happens with several cameras and you have cleaned those tiny contact parts, there may be problem with the aperture/focusing in the lens.
     
  3. whitehat

    whitehat Android Enthusiast

    I have never heard of this problem (Digital Rebel ->20D -> 40D -> 5D Mark III). If I understand correctly, the problem is one lens on several cameras. This situation seems to be equivalent to a cold solder joint in an electronic circuit.

    I don't know of a cure, but I would try giving the lens a few taps or shakes the next time this problem raises its ugly head. The lens probably needs to be torn down to be fixed anyway, so a few taps or shakes shouldn't hurt.
     
  4. shmn

    shmn Android Enthusiast

    Don't know what you are using to clean the contacts, but I would try DeoxIt before trying anything pricey. The stuff has fixed many problems for me in the electronics world. I would use it on the lens contacts, camera contacts and flash contacts.

    If the DeoxIt doesn't work then it sounds like a problem with the lens. Those kit lenses are cheap and easy to find used. I would not pay to have it looked at or repaired. They are pretty much disposable.
     
  5. zuben el genub

    zuben el genub Extreme Android User

    That problem usually happens with a mismatched lens. Put an older Sigma (pre-Bigma) on a Canon and you get Error 99.

    Something is probably wrong with the contacts on the camera. You might be able to have it cleaned in that area if it is something that can be cleaned. If they are worn, it might not read right at all.

    Canon D20 or 20D? 2 different cameras. Both pretty old. I have the 20D and it's working. No reason to change.

    Those lenses are fairly common used. If you can't get another locally, try the bigger camera stores online for used. Keh also has stuff.
     
  6. dibblebill

    dibblebill Android Expert
    Thread Starter

    Yeah, three different cameras, cleaned their contacts, and different ages.

    I've tried that inadvertently, I think.

    I'll try that if the rubbing alcohol didn't work.

    Canon 20D. It's three different cameras, but that's my figuring. Pawn shops have them for $40-70. Though the newest iteration that comes with the Canon SL1 is nice, they're all 18-55 kits at the end of the day.

    Part of the problem is it's the only lens I have that ALWAYS focuses right with my infrared Canon 20D.
     
  7. zuben el genub

    zuben el genub Extreme Android User

    dibblebill likes this.
  8. dibblebill

    dibblebill Android Expert
    Thread Starter

    Further testing indicates that the Aperture assembly is at fault.
     
  9. zuben el genub

    zuben el genub Extreme Android User

    That would do it.

    Can it be fixed reasonably?

    I've looked at 20DAs but too much money for what little astronomical use I'd have. I no longer have an accurately driven mount. I have to use filter, long exposure and Photoshop. But it's fun.
     
  10. dibblebill

    dibblebill Android Expert
    Thread Starter

    Nah. It's just a cheap kit lens. I may replace it and try to repair it later.
     
Loading...

Share This Page

Loading...