1. Are you ready for the Galaxy S20? Here is everything we know so far!

Any way to get 3rd party apps writeable to SDExternal?

Discussion in 'Android Devices' started by LaZeR, May 30, 2015.

  1. LaZeR

    LaZeR Android Enthusiast
    Thread Starter

    Tried various methods on my GF's rooted T-Mobile branded Avant. Xposed "Handler" or whatever it's called, didn't work. Nor did a couple claiming to achieve said purpose on playstore.

    Any tricks? I'm simply trying to get (for example) Astro File Manager to be able to move an item/pic from Sdcard0 to External, and of course I get the "Not able to do on KitKat 4.4... blah blah" error msg.

    So simple of a fix on my Note 4... Not sure if the Avant is capable of any fix for this or not?

    Thanks!
     


  2. dfuse06

    dfuse06 Android Enthusiast

    Yeah you have to get it right permission in the XML the permissions XML
     
    LaZeR likes this.
  3. LaZeR

    LaZeR Android Enthusiast
    Thread Starter

    I know some about editing certain things such as in "build.prop" and more similar laid out files. Can you elaborate on what exact filename & location for this permissions XML and what needs added/deleted?

    Sorry, maybe I am way off in my thinking of understanding what you mean.
     
  4. DMedina559

    DMedina559 Android Enthusiast

    This App enables external SD r/w access with just one click (tap)
     
    LaZeR likes this.
  5. LaZeR

    LaZeR Android Enthusiast
    Thread Starter

    That was one of the Apps I tried and it did not allow "Astro File Manager" to say, move a file to ExtSD without the KitKat complaint msg error. I even rebooted her phone. But thanks for suggesting.
     
  6. Nickforever216

    Nickforever216 Well-Known Member

    Ive used these type of apps and worked just fine. Maybe try ES file explorer? I can link you the app of play store, that worked for me.
     
  7. LaZeR

    LaZeR Android Enthusiast
    Thread Starter

    Just to update. I sort of found out by mistake. The problem was using "Fix Permissions" in TWRP.

    The reason I know this. I recently updated my GF's Avant to the latest firmware. Re-rooted, Flashed Recovery... Set phone back up. I was getting a fluke FC in one of the apps so I went into recovery and did a "Fix Permissions" under /Advanced. Luckily, I had noted that before doing this, Astro was working fine in moving files to/from Internal to External. Another thing that it had messed up and I was blaming Gmail was that you could no longer DL an attachment via Gmail App.

    Anyhow, I Odin'd back the firmware update, re-rooted, recovery, ect... And just for kicks, did a "Fix Permissions" again in TWRP resulting in the same exact problem/issue.

    ;)
     
    EarlyMon likes this.

Samsung Galaxy Avant Forum

The Samsung Galaxy Avant release date was July 2014. Features and Specs include a 4.5" inch screen, 5MP camera, 1.5GB RAM, Snapdragon 400 processor, and 2100mAh battery.

July 2014
Release Date
0
Reviews
Loading...

Share This Page

Loading...