1. Are you ready for the Galaxy S20? Here is everything we know so far!

Any way to remove Chinese text "google key tee key" water mark?

Discussion in 'Android Devices' started by KaptainKris, Apr 21, 2020.

  1. KaptainKris

    KaptainKris Newbie
    Thread Starter

    After flashing a custom ROM, I now have a watermark in the top right of my screen (screenshot attached). I've googled it and have tried several of the solutions suggested, but none have worked. Interestingly, most people get a slightly different variation of this message, in red...

    I've removed "FactoryTest" from my phone, but do not have mediatek.factorymode as some have suggested.
    I've messed around with my IMEI keys, this did not help. The message also still appears even with the SIM card removed.

    Where on the phone could this be stored? My phone is rooted, so if I could locate the file responsible, I could easily delete it.
     

    Attached Files:




    1. Download the Forums for Android™ app!


      Download

       
  2. mikedt

    mikedt 你好

    I've never seen anything like that before. But it looks like it's been built-in (baked in) that particular custom ROM. Where or how, no idea.

    Maybe try a different custom ROM, that's suitable for your phone, or try and contact the dev who built that ROM?
     
  3. KaptainKris

    KaptainKris Newbie
    Thread Starter

    Sadly there are no other ROMs available for my phone (Oukitel K7 Pro), in fact this one was made only when I requested it. I've contacted the developer but he hasn't responded yet, and not sure if he will since I messaged him over a week ago...
     
  4. Hadron

    Hadron Smoke me a kipper...
    VIP Member

    Which screens does this message appear on? I'm guessing that's a lock screen in the image, but does it appear on others? That might give a clue as to the source.
     
  5. KaptainKris

    KaptainKris Newbie
    Thread Starter

    It appears on every screen and loads soon after the phone is booted, maybe with around a 3 second delay.
     
  6. Hadron

    Hadron Smoke me a kipper...
    VIP Member

    Hmm, so it's a screen overlay of some sort.

    Crazy thought: check in developer options to see whether there's anything there. There are usually things that can produce informational overlays in there, though I've never seen anything like that. Otherwise it's perhaps some app the dev included in the ROM, but as you say the problem is guessing which (hopefully not something added to a core system component, because why would anyone want this?).
     
  7. DonaRowe3443

    DonaRowe3443 Lurker

    I have never seen like that but My friend is also facing the issue if you found any method to solve this let me know
     
  8. KaptainKris

    KaptainKris Newbie
    Thread Starter

    I've looked through all the develop settings and there doesn't seem to be anything relevant there :/
     
  9. KaptainKris

    KaptainKris Newbie
    Thread Starter

    I don't know if this helps, but "Show layout bounds" doesn't mark the watermark.
     

    Attached Files:

  10. burbigo

    burbigo Newbie

    That's reallt weird, how couldn't you not remove it ?!
     
    #10 burbigo, Apr 21, 2020
    Last edited: Nov 30, 2020
  11. crocoyes9

    crocoyes9 Lurker

    I know of a fix. First you have to download minimal ADB and fastboot on your computer. Then plug in your phone into the computer but keep the phone on. Next on the computer press windows key and R and type CMD
    Next put in these commands
    adb devices
    adb shell
    pm list packages
    pm uninstall --user 0 com.mediatek.factorymode
    Then restart your phone and it will the remove the writing.
     
  12. KaptainKris

    KaptainKris Newbie
    Thread Starter

    Sadly this does not work, I have tried this. I do not have the mediatek.factorymode file on my phone.
     
Loading...

Share This Page

Loading...