1. Are you ready for the Galaxy S20? Here is everything we know so far!

Anyone else having problems with the sd card?

Discussion in 'Android Devices' started by offthecha1n, Dec 5, 2009.

  1. defiantbeast

    defiantbeast Well-Known Member

    Ive had a kingston card for 2 weeks now and problem resolved. Yes it sucks that you have to buy a replacement card for the one that came with the phone but realize that the card was free, so theyre not going to give you quality. With the sd card fixed 90% of my problems with the behold2 are over, bring on 2.xx
     



    1. Download the Forums for Android™ app!


      Download

       
  2. Notahotshot

    Notahotshot Member

    I find this thread very interesting.

    I have been having this problem for some time now. It started as a "preparing sd card" notification. Pulling out and reinserting the sandisk sd card, making sure it was seated properly, stopped that issue. Later however it started erasing/losing its formating.

    The interesting part is that I of course called the mob's (t-mobile) troubleshooting dept. They told me they had no record of known issues with the sd cards. This was just two days ago!

    I let them know what the problem was and what steps I had taken to try to resolve the issue. They agreed to send me a replacement phone. It's on its way.

    I of course had downloaded apps from the market. When I was on the phone with the mob I was asked if I had done a factory reset. I had not. Because I did not want to lose all of the apps. Of course since I can re-download them anytime even the paid apps, I decided to give it a shot. That was two solid days ago and so far the problem has not come back.

    I have put some but not all of the apps back on my phone. I intend, one at a time, each day, to add back an app to see if the problem returns. If it does I will see if it is repeatable and post the problem app if I find one.

    Back up your contacts, factory reset the phone and let us know if it works for you. Test each new app you dl for at least a day before adding a new one.

    ****Update****
    My replacement phone got here before I had another problem. My replacement has not shown a problem either.
    ****Update****
     
  3. dctony2010

    dctony2010 Newbie

    I too am a victim of this problem. After getting fed up with the annoying "preparing sd card" message and seeing that some people are vouching for the Kingston card as the solution, I have given in and tonight, bought a Kingston 8gb microSD card to replace my 16gb Sansdisk. It has been 3 hours since I got it and so far so good. I would like to keep you all updated on my progress thought days/weeks and hopefully after some time, I will also be able to vouche for Kingston also. Stay tuned...
     
  4. mikel719

    mikel719 Lurker

    I am having this problem as well. I have a 8gb sandisk memory card and it just started two days ago. Its really starting to make me want to take back the phone since I've had it for three days. It only happens to my text message notification and I've only had it connected to my cousins laptop once which is running windows vista. Besides this annoying problem my battery drains really fast. I have to charge it two to three times a day. If anyone can help it would be greatly appreciated. mcasias1981@gmail.com. Thanks in advance.
     
  5. dctony2010

    dctony2010 Newbie

    Okay, It's been about 2 weeks now since I replaced the Sandisk for a Kingston and I have had absolutely no problem, not even one "preparing SD card" message! I would like to support using Kingston on the Behold 2. I feel the same way as defiantbeast, a big stress have been lifted off me, now bring on Androis 2.x!
     
  6. defiantbeast

    defiantbeast Well-Known Member

    A little more research and i think ive figured out the problem. The card that ships with the b2 is a free 2gb sandisk speed class 2. the problem is the speed class of the card it seems that the phone requires a speed class 4 or higher. So if your able to get a sd card thats class 4 or 6 then that should solve your problem.
     
  7. yatimameiji

    yatimameiji Android Enthusiast

    But what does it mean if I've never had a problem with the sd card? Where does it say the phone requires a speed class 4 or higher?

    Update: I took a look at mine. I suppose you have been saying Sandisk because it says so on the card. Well mine says Samsung. Maybe some got a Sandisk branded card while others got the Samsung one.
     
  8. chadmd23

    chadmd23 Android Enthusiast

    I came across this blog as a chumby owner. It's interesting to see quality issues with sd cards, even when purchasing OEM cards from big name manufacturers.

    bunnie's blog
     
  9. xristian

    xristian Newbie

    I've had a Samsung card (8 Gb class 4) for a few days... no problems so far... so I guess the card that came with the phone was the problem... my advice would be to replace it...
     
  10. offthecha1n

    offthecha1n Member
    Thread Starter

    so im about to get the kingston 8gb, everyone that has it the problem stopped right?
     
  11. Mastermind278

    Mastermind278 Android Enthusiast

    I would try to format the SD Card and see if that helps. After formatting the SD Card I had no issues. Then I changed over to an old 4gb card and did the format and have yet to have this issue again. So try formatting first.
     
  12. offthecha1n

    offthecha1n Member
    Thread Starter

    I did the format via the phone. is there another/better way?
     
  13. dctony2010

    dctony2010 Newbie

    Offthechain, I recommend getting a Kingston card. It has worked flawlessly for me. Have not gotten those annoying messages since. I cant guarantee you anything since Im no technical expert but I can say on my personal experience that it works for me.
     
  14. offthecha1n

    offthecha1n Member
    Thread Starter

    heading to ebay right now
     
  15. i<3droid

    i<3droid Lurker


    Yeah I have too...i just recently ordered a replacement phone because it did the same thing with my memory card nd sim card!!! so make sure u back up ur photos on memory card....i lost all my pics from my last one and had to use a new memory card!!! and when i put old card in cpu i could not get acess to anyting on card....asking to format it!!! SUCKS
     
  16. dan0zone

    dan0zone Well-Known Member

    Did you guys even bother reading the post in this thread,, NOTHING IS WRONG WITH THE PHONES just the crappy card that was shipped with it....
     
  17. nomadrider123

    nomadrider123 Well-Known Member


    Well a bright side maybe they will get the update on their new phone
     
  18. dan0zone

    dan0zone Well-Known Member

    True , one person has stated that they got a new behold2 with the update ..... who knows !!!
    I still think people should read a little more ....
     
    chadmd23 likes this.
  19. offthecha1n

    offthecha1n Member
    Thread Starter

    well one full day of having the update my sd problem has not happened. too bad I had ordered a kingston card last week and it arrived to day lol. I will wait a day or two though to see if it happens again


    edit: 2 days now no problem still
     
  20. msmparker83

    msmparker83 Lurker

    I received the update yesterday and it lasted about 12 hours before the "preparing the sd" notification came up. I have a 8g sandisk and i tried formatting it and i'm still having problems with it. The only thing that mess up is my message tone. I bought an 8g kingston from amazon today. I hope it works because the stock message tone really irritate me, lol
     
  21. brianary

    brianary Lurker

    I've been having the same problem with two SanDisk 16gb microSDHC cards on my Behold2, both class 2.

    I can use testdisk (Win/Mac/Linux) to fix the card (by fixing the MBR: Create log, Advanced), after which I back up the data (rsync on Linux or robocopy on Win will copy just the changes), but the card is just corrupted more and more frequently.

    Is it just me or did things actually get WORSE after the OTA update?
     
  22. rone

    rone Newbie

    In my case it was the speed of the card. I changed over to class 6 card and my problems went away. I think it was an a-data card. The speed of the card is probably more important than the brand.
     
    brianary likes this.
  23. brianary

    brianary Lurker

    The card speed as a cause makes the most sense to me. I've ordered a class 4 8gb Kingston card. We'll see how it goes.
     
  24. btbarr

    btbarr Member

    I don't know if anyone mentioned this since I was too lazy to read the whole thread, but I had this same problem too with the card that was sent with the phone. I switched out the card my behold 2 had with one I was using in my samsung omnia and I haven't had a problem since. I still use the same usb cable that came with the phone also in case anyone was wondering.
     
  25. Ggoogle

    Ggoogle Lurker

    I've had the same problem with erasing sd cards since buying my behold 2a little over a month ago and am now waiting on my third phone. I also asked the tech how it's not a known problem when there is a thread like this one. No comment. Anyway, they wouldn't give me a new sf card but they did credit my account ten bucks. Something is better than nothing. They also told me that if this happens again they will give me a different device. I will be using a different brand of sd card as well as this seems to be working for others.

    On a side note, I've found a site that you can download the new swype keyboard and let me just say, WOW! If interested email me at greg.gordon72@yahoo.com. This is an old email address but I will check it from time to time.

    Hope this helps. Peace, Greg
     

Samsung Behold 2 Forum

Features and specs are not yet known.

unknown
Release Date
0
Reviews
Loading...

Share This Page

Loading...