1. Are you ready for the Galaxy S20? Here is everything we know so far!

Anyone else having problems with the sd card?

Discussion in 'Android Devices' started by offthecha1n, Dec 5, 2009.

  1. B2user

    B2user Lurker

    I have had the same problem with my Behold 2 and I think I may have figured out the problem (Tmo and Samsung where useless) I am on my second phone and second memory card. The same issues keeps happening. I have pics and music on the SD card... I get a message that the SD card is blank and I should format it, then I lose everything on the card. In my case, I noticed the issue happened again after downloading some pics to my computer. I think it is because of the way I hooked up and unhooked the phone from the computer. When you connect the phone to the computer the phone prompts you to "mount" the phone and when you are done, you can it "turn it off" through the phone but...you have to "eject" the device from the computer first, then turn it off through the phone and then unhook the usb cord. It corrupts the files on the card in the phone if you don't turn it off from the phone and the computer before disconnecting it.
    I just did it and I have had no problem so far. I will let you know if that changes but i hope that helps someone having the same problem.
     



    1. Download the Forums for Android™ app!


      Download

       
  2. jshultz

    jshultz Lurker

    I bought a 16gb sandisk class 4 card that has had the problems mentioned in this thread. I kept getting the preparing SD card and your card is corrupted messages. I even had a problem once when it was connected to my windows 7 machine where my USB devices all quit on me. The odd thing is, if my phone is connected to my windows 7 machine and I reboot the machine the OS won't load. If it's connected to my vista machine I don't have the problem. I'm not sure why it's keeping my hp laptop with win7 installed from booting. very odd.

    either way, I'm going to replace my sandisk card with a kingston card and try that. it's frustrating not knowing when your card is going to suddenly crap out on you.

    for the record, my behold 2 has the latest update. I just got it last week. i've had it check for any updates and there's not any.
     
  3. fallenturtle

    fallenturtle Well-Known Member

    So the issue isn't just the class but that actual brand? I keep seeing sales for class 4 cards that aren't Kingston and have debated getting one... but now I don't know...
     
  4. jshultz

    jshultz Lurker

    Well, I was wrong about the sandisk card I had. it was a class 2 card. I'm replacing it with and 8gb class 4 card from kingston. amazon just shipped it.

    Here's the card i'm getting: http://bit.ly/blCUpU
     
  5. k1ll1nt1m3

    k1ll1nt1m3 Newbie

    I'm running a class 2 kingston 16g, with no problems. Maybe a bit slower, but no problems.

    Was running a class 4 kingston 8g. Still no problems. It was faster, no doubt.

    I am running BH-MAN_R8 now. No problems with a stock rom either.
     
  6. jshultz

    jshultz Lurker

    i popped back in a little 2gb card that came with my wife's CLIQ and it's working fine. it's holding me over until my 8gb card arrives tomorrow. so far, no reboots.
     
  7. jshultz

    jshultz Lurker

    I've been using the kingston class 4 8gb card for a couple of days now and have had no problems. My pleasure level has gone up considerably since switching to it. No more have I been plagued by the demons of card resets or losing data. Here's the card I'm using: http://bit.ly/blCUpU
     
  8. inaz4sun

    inaz4sun Well-Known Member

    After about 2 days of testing, I have had no more problems with my 16GB class 4 TOPRAM card in my Behold II.

    Here is what I did:

    Back up all your SD card content (if you still have access to it) to your computer hard drive prior to doing this.

    1. Unmount SD card in phone
    2. Remove SD card, place in adapter and put into your computer (windows) card reader
    3. Using Windows Explorer, right click on the card and select format. Don't do a quick format. Format the card
    4. Just to make sure also run a checkdisk and defrag on the card.
    5. Use the Remove Safely feature in Windows for this card/drive
    6. Remove card from computer and place back in phone and reboot the device
    7. Mount the SD card and copy back your backed up files from your computer.
    8. Unmount the SD card
    9. You should be good to go.

    After doing this I have had no further problems. So my guess is it has something to do with a)either the formatting of the card in the phone itself or b) unsafely removing the card from the phone or unmounting it correctly.

    See my more recent post, but the issue did come back and I think it really does have something to do with the mounting and unmounting done using the USB connection. I'll be testing this.
     
  9. B2user

    B2user Lurker

    OK, I have finally figure out the problem!! I agree with the post above but you have to be clear...it is the USB cord that you can't use for anything even charging. Its the connecting of the cord to the computer that causes the error!!!! Just throw it away! There is something wrong with the "mounting and unmounting" of the phones. I had uploaded music using the cord after formatting the card then after a few days, I lost everything AGAIN. I formatted it AGAIN and uploaded everything AGAIN and it was fine for a while UNTIL I used the cords to charge my phone....that night I got the message again!

    I took out my SD card and used the adapter to put directly into my PC, moved over all my files AGAIN and I have had no problems at all. It "prepares" itself all the time with no error messages anymore. THANK GOD. I think some people dont have the problem because either A. They dont use the cord or B. They have somehow mounted and unmounted the phone correctly, although I tried every which way, and you just can't keep the files for very long. So, keep your SD cards and just upload and download by putting the card directly in the computer. Get rid of the cord or put it away until the get a patch for it.
     
  10. jshultz

    jshultz Lurker

    You may be right, however I didn't find that to be the case. I have a chord that came with my nokia to do the transfers/etc and still had problems.
     
  11. inaz4sun

    inaz4sun Well-Known Member

    Well I think he means any USB cord/connection, that its the mounting and unmounting process that is corrupting things.

    He might be on to something, since I had found that mine usually went bad when I took it off charge and left to go somewhere. I would get in the car and find the error message had come up. This happened, in rethinking about it, each time the card error came up. So I think there is something definately to the mounting and unmounting. Might not happen every time, but sooner or later it will.

    What I am going to try tomorrow with mine is not use USB at all and see what happens.

    Also you should remember that when you put the card in your computer be sure to also "eject" or disconnect the drive via the OS BEFORE removing the card, in case it is writing to the card at the time you put it in.

    Lets test these things and report back here is we can figure out even more what is happening each time a card goes bad.

    I also thought about putting my card in my camera for a week and seeing if there were any issues with it. My guess is no, that it is strictly the phone or something related to the phone that is causing the corruption of the data each time.
     
  12. inaz4sun

    inaz4sun Well-Known Member

    Nope, it isn't the USB cable. Went about 24 hours without connecting it, and the card became corrupted just sitting on my desk not being used and not connected. So we have to look elsewhere for the problem.

    It's not:


    • Only Sandisk cards going bad
    • It's not one particular size of card
    • It's not just class 2 going bad (mine is a 4)
    • It's not the USB cable or mounting/unmounting
    It must be some program native to the phone (either an Android process or a T-mobile one) that attempts to write or otherwise access the card, perhaps when in a rested/sleep state that corrupts the card.

    Any other thoughts on what it could be? It's going to be tough to trouble shoot.

    Question has anyone ever had a Class 6 or a Kingston card become corrupted?
     
  13. chadmd23

    chadmd23 Android Enthusiast

    BurgDog likes this.
  14. inaz4sun

    inaz4sun Well-Known Member

    What I am testing today is...I downloaded the official SD card formatter and formatted the card with that application, copied back my files. Testing that. I won't connect a USB cable to it while I test. I'll also try to track any open applications at the time of fail, however as I have discovered in the past it usually becomes corrupted when the phone is in sleep mode. I don't recall having it become corrupted while I am actively doing something on the phone.
     
  15. inaz4sun

    inaz4sun Well-Known Member


    That certainly is an interesting article. Fake chips are probably more prevalent than anyone knows. I guess the problem arises in that it makes it hard to ever really know up front that your purchase will be a quality item.

    In reference to the SBII it would seem though either a lot of people have low quality cards, to which the SBII is particularily sensitive or something in the phone itself is corrupting otherwise perfectly good cards that don't have these issues in other devices.

    And strangely, people in this forum and others have been expressly suggesting that people buy a Kingston card, this article suggests that our results would be the opposite, that we should suspect the Kingston cards of being the ones with the issues-most likely to be fakes.

    So I don't know what all of that tells us. Maybe its a combination of both, poorly constructed cards, interacting with a poorly constructed phone/software.
     
  16. jshultz

    jshultz Lurker

    I'm using a Kingston 8gb Class 4 card. I'm using the cable that came with the phone. I've done formatting, syncing using Songbird, and have had zero problems. Before, I was using a 16gb Class 2 Sandisk card and had problems every day with it.
     
  17. inaz4sun

    inaz4sun Well-Known Member

    24 hours plus without an issue on my 16GB class 4 card. I have not connected it to USB, and also been extra careful to try to keep it somewhat cool, because I was thinking back and it might even be a heat related problem, as the phone gets pretty hot when charging, via USB or regular charger, especially if the screen is on/apps running.

    I'll keep reporting. None of the apps I have been using have triggered anything thus far either.
     
  18. inaz4sun

    inaz4sun Well-Known Member

    About 50+ hours now with no issues. Been keeping it as cool as possible, and no USB connection, after formatting the card with the official SD spec formatting application for Windows.
     
  19. inaz4sun

    inaz4sun Well-Known Member

    Daily update:

    3+ days now and now issues with my card. Keep it cool and away from USB. I have also run every APP i have, none of which have caused any issues.

    I'm not quite ready to definitely call it, but getting there.
     
  20. vertigo4

    vertigo4 Newbie

    The problem of the sd card unformatting and wiping everything out just happened to me after no problems for the first few weeks. Everything seemed to be fine, when tonight, all of a sudden I pull out my phone and it tells me that the sd card is blank/needs to be formatted. I tried to put it in the adapter and access it on my laptop, but of course, it didn't work... I reformatted it so I guess we'll see what happens now. For the record, I never mount/unmount using my usb cord, so that wasn't the problem for me. I also have the OTA update.
     
  21. inaz4sun

    inaz4sun Well-Known Member

    After 4 days I test the card by shutting down the phone, removing the card, backing everything up on my computer, then putting the card back in. And sure enough, upon starting up and accessing the card it said it was corrupted. So it is definitely related to the mount/unmount or having been accessed/used by another OS. Something tells me that Windows does something differently in writing to the card that phone doesn't and so when either connected via USB or taking the card out and putting it in a PC and then back in the phone can lead to a corrupt card.

    I will now try never mounting the card, never shutting down, and not removing the card. I'll transfer files via a WiFi APP, and we'll see if the card becomes corrupted, this will tell me if in fact it does have something to do with those factors.
     
  22. shauma

    shauma Lurker

    I was havin the same issues and thought I would chime in that through the same processes I ended up with a class 6 Centon that I ordered from wal-mart.com. 4 days and still no problem. Now I'm reading again and there is possibility it is the cord?

    Well as the cord idea is being looked into I wanted to say that my class 6 that is not Kingston is another option. I am siding that the class makes the difference and if my card errors all of a sudden I will chime back in.

    I also wanna thank everyone for their info. I probably would have trashed this phone if it weren't for these helpful forums. This is my 1st android. So far this and the mms have been my only concerns, which the mms was easy to handle.
     
  23. inaz4sun

    inaz4sun Well-Known Member

    After testing 4 cards and many different scenarios, I have come to the conclusion it is the cards. Borderline quality cards are what is the issue, the Behold II (or perhaps Android OS) is sensitive maybe, but the cards are ultimately to blame. Of the 4 I tried extensively, only one failed and had the corrupted issues. It wasn't size, class, mounting/unmounting, cord, etc...I eliminated them as possibilities, the only thing it could be is the card/quality of the card. 3 cards never failed for me. 1 card failed daily. So its the cards.
     
  24. Zino_BeholdII

    Zino_BeholdII Newbie

    So can you tell us which microsd card's brand name did you buy on four of the cards?, and how does it work on four of them ? You have said 3 of them were working fine , so I think it must be Kingston class 4 or any other brand name class 4 or 6 . The one that did not work must be Sandisk.

    I know this problem for a very long time because I use to have a China Made Sandisk Micro Sd card for my Nintendo DS Lite . It worked well , but after quite some time , it forced me to reformat and then suddenly it stopped working.I hope it is the memory card problem because I am planning to buy a Kingston 8GB MicroSD Class 4 on ebay.com or amazon.com .

    Thanks for everyone's helpful information in this thread . You guys did such a fantastic job .
     
  25. shauma

    shauma Lurker

    For future reference I would like to know which ones worked too. I have heard nothin good about sandisk but even my PNY class 4 had the sd removed and preparing message til it erased it and told me to reformat. This Centon class 6 has been just fine for a week now. Not a single error and I did transfer files with usb. I think I got so used to the unmounting and remounting that I'm just waitin for it. I think I picked a card that works but if it decides to error I'd like to know what other options there are. Meanwhile I'm becoming confident that this one can be added to the list.
     

Samsung Behold 2 Forum

Features and specs are not yet known.

unknown
Release Date
0
Reviews
Loading...

Share This Page

Loading...