1. Are you ready for the Galaxy S20? Here is everything we know so far!

Anyone getting "Incompatible Update" with certain apps in ESE ROMs?

Discussion in 'Android Devices' started by vincentp, Mar 8, 2010.

  1. vincentp

    vincentp Android Expert
    Thread Starter

    I think I may know why this is happening, but I don't feel like doing a full nandroid reinstall and losing my data before I ask.

    I'm getting "incompatible update" errors when trying to reinstall Facebook and Mixzing. Now, I had those apps installed and working on my previous ERE25 based ROM, however, I was at the time using the Dark 24K theme, which modified them. When I went to ESE53, I didn't nandroid, I just used update.zip, and that of course reinstalled the stock theme, which may be causing the problem. It's not showing those two apps in my installed apps list. When I check them in the market, they show "installed", but I am able to redownload and reinstall them, I just get the error during install.

    I used root explorer and tried to find the files for those two apps, but they don't seem to be anywhere. Anybody else run into this problem or know of a solution, or should I just do a nandroid restore of the full ROM?
     



    1. Download the Forums for Android™ app!


      Download

       
  2. Redflea

    Redflea Android Expert

    I had this problem w/google maps at one point after an update.zip to ERE53.

    Problem appeared to be that the app was in /system and the market is installing to /data.

    Remove all traces of the existing installation of the app from my Droid and then the install from the marketplace went OK. I went into /System using Droid Root Explorer and searched on Map to find any related files....
     
  3. Needsdecaf

    Needsdecaf Android Expert

    I had the same problem with maps. But as I noted, I hadn't wiped /data before doing the Nandroid. THat solved the problem.
     
  4. vincentp

    vincentp Android Expert
    Thread Starter

    Thanks guys. I deleted every trace of the apps that I could possibly find, but still no luck. Guess I'm just gonna do a nandroid restore and wipe the data partition.
     
  5. Stephen304

    Stephen304 Lurker

    Exact same problem with facebook just now on CM 11 - Used CM file manager to search root for "katana" (the app package name) and deleted 2 files in dalvic cache. Installs perfect from the play store.

    Edit: WHOOPS. Sorry for the necropost... Nevertheless, I hope this is helpful to someone.
     
  6. teddyearp

    teddyearp Android Expert

    Stephen304, not even sure that your post is relevant to this thread as CM11 was never released for the Motorola A855/Droid 1.

    But on another note, man I miss the Dark 24k theme . . . . . it rocked!
     

Motorola Droid Forum

The Motorola Droid release date was November 2009. Features and Specs include a 3.7" inch screen, 5MP camera, 256GB RAM, processor, and 1400mAh battery.

November 2009
Release Date
0
Reviews
Loading...

Share This Page

Loading...